Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » PC1715 GUNv3 aufbauen » Themenansicht

Autor Thread - Seiten: -1-
000
08.06.2023, 19:49 Uhr
MarioG77

Avatar von MarioG77

Ich mache mal ein neues Thema.
Über die zeit habe ich so manche Frage.

Ich nähere mich langsam der Fertigstellung der ersten Platine (soweit ich alle Teile da habe).

Wo finde ich die Software für den ATMEGA?
Ich vermute auf kc85.info - evtl. beim M052? Ich suche jetzt schon eine halbe Stunde.
Ich finde es einfach nicht...

Zu den GIDE GALs - ich vermute, die Originalen kann ich wegen der Adresse nicht nehmen? Oder war der Originale schon für verschiedene Adressen (je nachdem, welche Adressen da an den Eingängen anliegen) vorbereitet und der passt?
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
08.06.2023, 20:06 Uhr
wpwsaw
Default Group and Edit


...die GAL sind die gleichen. Für den atmega, der ja für das Netzwerk ist, da musste man zu Ralf eine freie von einer nicht mehr benutzen NW-Karte die MAC Adresse schicken und ihm sagen wofür die FW sein soll wegen der Taktfrequenz und daraus hat Ralf dann die FW für den Atmega bereit gestellt.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; und P8000 ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2 und Multicar M25 3SK; Barkas B1000 HP

Dieser Beitrag wurde am 08.06.2023 um 20:09 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
08.06.2023, 20:08 Uhr
Enrico
Default Group and Edit


Die GIDE-GALs gehen für alle machbaren Adressen.
Die sollten (!) also auch beim 1715 richtig sein, ob die nicht Heiko doch geändert hat weiß ich nicht. Denke aber, dass nicht.

Software für den ATMEGA, fürs Netzwerk?, gibts beim Ralf (SUSOWA),
da kommt die MAC rein.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
08.06.2023, 20:48 Uhr
Heiko_P



Die GALS sind die gleichen wie beim GIDE für den KC85, deren Inhalt ist nicht von der verwendeten Adresse abhängig.

Die Software für den ATMEGA gibt es bei Ralf Kästner, die Anleitung zum Projekt KCNET und alle weiteren Infos findest du hier:

http://kc85.info/index.php/projekte-mainmenu/kcnet-mainmenu-130.html.

Wichtig für den Nachbau ist der Punkt "Nachnutzung".

Gruß
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
09.06.2023, 10:38 Uhr
MarioG77

Avatar von MarioG77

ok, Ralfs Seite war/ist nicht erreichbar. Vielleicht stand das da.

Danke für die Infos, da lese ich mich heute nochmal durch.
Zumindest kann ich die GALs schon fertig machen.

Beim Netzwerkteil brauche ich eh noch einen Moment. Bei mouser sind die Wiznet gerade verfügbar. Muss nur meine Konto befragen, ob ich den Warenkorb gerade abschicken kann...

Wenn man da SMD Teile für ein Projekt (GraphicsGremlin) bestellt und dann die Stückzahlen hoch dreht, damit der Einzelpreis sinkt, summiert sich das dann doch irgendwie immer ordentlich hoch.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
09.06.2023, 14:38 Uhr
felge1966



Dann such dir schon mal ein Netzwerkgerät, welches niemals in deinen Netz zu finden ist, da du für Ralf eine MAC Adresse liefern musst (Kleiner Tip für Mario:Ich habe seinerzeit welche von defekten IP-Telefonen genutzt).

Gruß Jörg
--
http://felgentreu.spdns.org/bilder/jacob120.gif

Dieser Beitrag wurde am 09.06.2023 um 14:39 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
09.06.2023, 15:34 Uhr
Heiko_P



Der Link aus (003) ist jetzt erreichbar.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
09.06.2023, 16:16 Uhr
MarioG77

Avatar von MarioG77


Zitat:
felge1966 schrieb
Dann such dir schon mal ein Netzwerkgerät, welches niemals in deinen Netz zu finden ist, da du für Ralf eine MAC Adresse liefern musst (Kleiner Tip für Mario:Ich habe seinerzeit welche von defekten IP-Telefonen genutzt).

Gruß Jörg



Ja, den Gedanken habe ich auch gehabt...
Ich habe jede Menge alter Telefonanlagen-CPUs hier, die ausgesondert sind und darauf warten, ausgeschlachtet zu werden (waren da nicht auch Knopfzellen drauf?)
Ach... Jetzt weiß ich, warum ich noch die Backups von alten Telefonanlagen habe...
Ich weiß, wo tausende Telefone entsorgt wurden...
Da lohnt sich eine Datenbank

@Heiko. Ich meinte die alte DyDNS Adresse, deren Links immer noch vereinzelt stehen.
Ich habe mittlerweile die Historie dazu gefunden.

Und bin jetzt nach dem Lesen der KCNET Artikel erleuchtet.

Wenn man ohne Vorkenntnis einsteigt, muss man sich die Zusammenhänge erst erarbeiten. Deine Anleitung für den Bau der Platine passt perfekt - aber eben nur für das eigentlich löten...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
09.06.2023, 17:24 Uhr
Enrico
Default Group and Edit



Zitat:
MarioG77 schrieb

Ich habe jede Menge alter Telefonanlagen-CPUs hier, die ausgesondert sind und darauf warten,



Kann man die noch zu was brauchen?
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
09.06.2023, 17:55 Uhr
MarioG77

Avatar von MarioG77

Mit CPU meine ich Baugruppen.
Das sind 386 bis Pentium 4 Klasse Platinen, spätere dann mit MIPS.

Da läuft Linux mit modifiziertem Kernel. Da kann man nichts richtig sinnvolles machen. Das Linux ist was modifiziertes (inkl. Kernel) auf steinalter Mandrake Basis.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
09.06.2023, 18:24 Uhr
Enrico
Default Group and Edit


Aha, na ich meinte schon CPUs.
könnte ja sein, dass dort was brauchbares drauf ist.
Demzufolge doch nicht.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
09.06.2023, 18:49 Uhr
MarioG77

Avatar von MarioG77

SMD/BGA Zeugs.
Am ehesten könnte man noch die Flash ICs runter holen.
Kann ja Mal ein Foto von so was mailen.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
09.06.2023, 19:17 Uhr
Enrico
Default Group and Edit


Ja, von mir aus.
Ich denke aber, dass es dann eher uninteressant ist.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
15.06.2023, 19:22 Uhr
MarioG77

Avatar von MarioG77

So, aufgebaut ist sie. ATMEGA und GALs sind geflasht.
Jetzt muss ich nur noch den 2. 1715 zum Laufen bekommen.

Dann muss ich schauen, wie ich das Teil in Betrieb nehme...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
19.07.2023, 19:37 Uhr
MarioG77

Avatar von MarioG77

Mittlerweile habe ich die GUN angeschlossen.
Heiko hat mir noch die passende Software zukommen lassen.

Dummerweise funktioniert außer RTC gar nichts.
Datum/Zeit lässt sich lesen/setzen.

USB hatte ich erst noch falsch gejumpert, das habe ich vorhin korrigiert.

Bei start von usb.com hängt sich der Rechner aber ohne Meldung weg.

ncfg12 versucht nach dem Start von B: auf Laufwerk A: zuzugreifen und das wars. Er hängt.

gidehpd0 stürzt nach Start direkt mit einem Streifenmuster ab. Unabhängig, ob die GUN angeschlossen ist, oder nicht.

Besteht die Möglichkeit, dass ich ein Problem mit dem Mainboard habe?
Der RAM Test war ja ok. Außer Diskettenzugriff und tp habe ich noch nicht viel mit gemacht.

Als nächstes würde ich nochmal die GALs auslesen/prüfen.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
19.07.2023, 19:55 Uhr
Rolly2



Gidetest.com hast du ausprobiert? Option p, eingeben D0, Enter. Dann (1) Read Divice Date. Wenn das schon nicht geht? Alle ICs, außer fürs GIGE entfernen und noch einmal testen.
Ich weis nicht was für eine "GUN" du hast, du must am Jumperblock A5 jumpern.
Für D0h.

VG, Andreas

Dieser Beitrag wurde am 19.07.2023 um 19:59 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
19.07.2023, 20:46 Uhr
schlaub_01



Blöde Frage: Das USB Modul VDIP1 ist programmiert?

Viele Grüße,
Sven.

Dieser Beitrag wurde am 19.07.2023 um 20:47 Uhr von schlaub_01 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
20.07.2023, 14:02 Uhr
MarioG77

Avatar von MarioG77

Gidetest stürzt anscheinend ebenfalls ab. Jedenfalls gibt es keinen Text aus. Falls da nur ein stummer Prompt war...

GIDE ist auf A5 / D0 gejumpert. Das hatte ich aus Heikos Doku so entnommen.

@Sven: Das VDIP1 Modul sollte doch Firmware haben, oder? Beim M052 hatte ich doch auch nichts extra gemacht, abgesehen von Firmware Update vom Stick.
Evtl. mal mit dem vom M052 tauschen - das hatte ich noch nicht auf VDIP2 umgebaut.
Ich schaue mir die M052 Doku nochmal genauer an...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
20.07.2023, 16:21 Uhr
Rolly2



Das Programm GIDETEST muss auch ohne Gidemodul oder GUN starten. Zummindest bis zur Funktionsauswahl.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
20.07.2023, 18:32 Uhr
schlaub_01



Ob der VDIP1 programmiert ist, siehst Du ja beim Einschalten bzw. nach Reset am wechselseitigen LED blinken. Da haben sich ja die Programmierer nicht viel Mühe gegeben. Beim VNC2 sieht man im Quellcode, daß da einfach 5 mal die LEDs mit fester Wartezeit wechselseitig angesteuert werden. D.h. sinnlose Wartezeit für nichts. Gut, beim GUN oder im M052 spielt es keine Rolle, aber die ICs habe ich auch noch in Arbeitsprojekten im Einsatz und da ist Testzeit immer ein kostbarer Faktor...
Kann sein, daß die VDIP Module schon programmiert sind, aber mit welcher Firmware? Gibt ja mehrere Varianten für das VDIP1. Wenn man die reinen ICs bekommt, ist da keine Firmware, außer dem Bootloader drauf.

Viele Grüße,
Sven.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
20.07.2023, 19:42 Uhr
MarioG77

Avatar von MarioG77

Er blinkt beim Zugriff von usb.com kurz, aber dann hängt er sich weg.
GIDETEST hängt auch ohne GUN komplett nach dem Start.

Ich werde morgen Mal den anderen 1715 nehmen und schauen. Vielleicht hat ja doch ein RAM eine Macke...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004

Dieser Beitrag wurde am 20.07.2023 um 19:42 Uhr von MarioG77 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
21.07.2023, 19:56 Uhr
MarioG77

Avatar von MarioG77

ok, im anderen 1715 ähnliches Bild.

Wäre es denkbar, dass mit einem der PIOs was faul ist? Die UB885D sehen gebraucht (von den Polen) aus.
Der Rest der ICs ist neu.

Dummerweise kann ich die GIDE im Moment nicht Standalone anschließen - entweder muss ich eine mit Buchsenleiste zusammenbauen, oder was basteln.

GIDETEST schmiert auch im anderen 1715 ohne GIDE einfach ab.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
21.07.2023, 20:19 Uhr
Rolly2



Dann ist mit deinen beiden Boards noch etwas faul. Gidetest muss auch ohne Gide starten. Der RAM-Test ist nicht unbedingt eine Garantie. Er hilft sehr, aber zeigt auch nicht jeden Fehler im RAM.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
22.07.2023, 09:21 Uhr
Heiko_P




Zitat:
MarioG77 schrieb

Dummerweise kann ich die GIDE im Moment nicht Standalone anschließen - entweder muss ich eine mit Buchsenleiste zusammenbauen, oder was basteln.




Einen Adapter musst Du nicht extra bauen. Du kannst von der großen Platine alle ICs runternehmen und dann nur den GIDE-Teil testen. Diese Platine läuft auch ohne alle anderen Komponenten.

Genau so kannst du mit den Schaltungen von USB und Netzwerk auf der großen Platine verfahren, hier muss natürlich die Adressdekodierung mit bestückt sein. Damit lassen sich z.B. defekte PIOs ausschließen.

Gruß
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
22.07.2023, 09:38 Uhr
MarioG77

Avatar von MarioG77

Ja, wie recht du hast... Da hätte ich eigentlich auch drauf kommen können...

Ich habe die originale GIDETEST genommen. Ich habe mich schon gefragt, wie die funktionieren soll, wenn der Port nicht passt.
Hatte auch Mal den Quellcode geprüft. Dort steht als Basis $80 drin. Dann dürfte klar sein, warum es nicht gehen sollte, aber nicht, warum er abstürzt, wenn keine GUN drin ist.

Der 2. getestete 1715 ist von T5000, der sollte eigentlich funktionieren.

Gibt es noch eine andere GIDETEST.com, die ihr verwendet?
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
22.07.2023, 09:54 Uhr
Rolly2



Ich kenne keine andere GIDETEST.
Hast du mal einen anderen Ramtest genommen, zB. den MEMR Rasmussen-Ramtest?
(Ramtest.com)

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
22.07.2023, 12:42 Uhr
Heiko_P



Welche CP/M-Version benutzt du eigentlich?
(Nicht dass es damit irgendwas zu tun hat)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
22.07.2023, 18:01 Uhr
MarioG77

Avatar von MarioG77

@Andreas: noch nicht, kann ich Mal machen.

@Heiko: Die Bootdisk, die ich aktuell nutze, ist SCP
Ich weiß gar nicht, ob ich eine CP/A Disk habe... Muss das alles noch sichten.
Hatte ich Mal von Kleinanzeigen bekommen, da waren auch einige 1834 Disketten drin.

Vielleicht komme ich morgen wieder etwas mehr dazu.
Wir lassen gerade eine "richtige" PV Anlage installieren - da ist irgendwie drumherum noch viel anderer Kram zu tun.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
22.07.2023, 21:19 Uhr
Rolly2



Hallo Heiko und Mario,
GIDETEST ist es egal, ob CPA, CP/M oder SCP. Startet immer, auch ohne GIDE bis zur Funktionsauswahl.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
26.07.2023, 20:00 Uhr
MarioG77

Avatar von MarioG77

Das Problem scheint SCPDR.SYS zu sein.

Wenn ich die Dateien auf Diskette schreibe und zurück kopiere, haben die plötzlich eine andere Dateigröße.
Das Rasmussen MEMTEST.COM ist 2580 Byte groß. Kopiere ich es zurück, sind es nur noch 2048.

Der 1715 stürzt laufend ab, wenn ich versuche, es zu starten. Immer mit anderen Symptomen.

Ich muss sehen, wie ich die Dateien erstmalig auf den 1715 bekomme. TLC habe ich leider auch noch nicht auf Disk...

Verdammtes Henne/Ei Problem...

Ich habe die Disk auf dem 1715 mit INIT formatiert und dann scpset auf das richtige Format gesetzt - daran liegt es nicht. Es ist reproduzierbar. Vielleicht liegt es an NWDOS 7.
Ich hätte noch SuperCopy da, müsste ich jetzt mal probieren.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
030
26.07.2023, 20:21 Uhr
Rüdiger
Administrator



Zitat:
MarioG77 schrieb
Wenn ich die Dateien auf Diskette schreibe und zurück kopiere, haben die plötzlich eine andere



Das ist völlig normal.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
031
26.07.2023, 20:25 Uhr
Rolly2



Dein 1715 hat ein Problem, das liegt nicht an der SW. Hast du keine vernünftig funktionierende System-Disk, auf der alle nötigen Programme drauf sind?
So kommst du nicht ans Ziel.
Das ist kein Henne/Ei Problem.
Teledisk gefällt dir wohl nicht, TD0s gibt zu Haufe.

VG, Andreas

Dieser Beitrag wurde am 26.07.2023 um 20:28 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
032
26.07.2023, 20:46 Uhr
MarioG77

Avatar von MarioG77

Ich habe mit teledisk noch nicht gearbeitet.
Von Heiko habe ich die Dateien bekommen, wie bekomme ich die in eine TD0?

Ich weiss nicht, welche td0 ich da jetzt genau nehmen müsste.
Morgen probiere ich, memtest seriell auf den 1715 zu schieben, um den Speicher intensiver zu testen.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
033
26.07.2023, 20:54 Uhr
Rolly2



Ich schicke dir morgen mal einige TD0s für Teledisk + dem Programm. Du brauchst dazu aber einen geeigneten Rechner ab 286/386/ pentium1. Läuft unter DOS.
Dann klappt das auch. Hast du einen dafür geeigneten Rechner? Wenn nicht, dann
ein Problem!!

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
034
27.07.2023, 08:34 Uhr
MarioG77

Avatar von MarioG77

(SCPDR.SYS)

Zitat:
Rüdiger schrieb

Zitat:
MarioG77 schrieb
Wenn ich die Dateien auf Diskette schreibe und zurück kopiere, haben die plötzlich eine andere Größe



Das ist völlig normal.


Wofür braucht man das dann, außer um Daten zu vernichten?

@Andreas: Danke. Wenn ich die alten Threads nach der GUN durchsuche, klingt das alles so selbstverständlich, aber der Zeitaufwand, alle relevanten Informationen zusammenzusuchen (für jemanden, der nicht ausreichend Vorwissen hat) - dagegen war das Löten der Platine nicht vergleichbar.

Einen Rechner habe ich dafür vorgesehen. Ich will den so flexibel wie möglich halten.
Aktuell habe ich da vom 5,25", LS120, ZIP, JAZZ, SCSI, SATA, IDE alles drin.
Einzig bin ich mir noch nicht klar geworden, wo und wie ich das mit den Betriebssystemen machen will.
Sinnvoll wäre da alles von DOS (wenn möglich mehr als eine), Linux, Win 95-2K, OS/2.
Das Thema Bootmanager, Partitionen, etc. hat mich davon abgehalten, weil ich da vermutlich viel Zeit versenke und ich die Ost-Rechner erst fertig machen wollte.

Aber ich komme nicht dran vorbei. Ich suche mir jetzt eine schnelle Möglichkeit für Teledisk...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
035
27.07.2023, 09:51 Uhr
Rüdiger
Administrator



Zitat:
MarioG77 schrieb
Wofür braucht man das dann, außer um Daten zu vernichten?



Es werden keine Daten vernichtet. Du hast nur die Funktionsweise der Dateisysteme von DOS und CP/M noch nicht verstanden.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
036
27.07.2023, 11:52 Uhr
MarioG77

Avatar von MarioG77

Ich kopiere eine Datei mit 2580 Bytes auf die Diskette.
Kopiere die wieder zurück und bekomme 2048 Bytes.

Da fehlt irgendwie der Rest von 532 Bytes. Das ist für mich ein Datenverlust von 532 Bytes.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
037
27.07.2023, 14:22 Uhr
Rüdiger
Administrator


Was passiert, wenn Du die Datei per Hex-Editor vorher auf 3072 Bytes vergrößerst?
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
038
27.07.2023, 16:35 Uhr
PIC18F2550

Avatar von PIC18F2550

Bei 2580 bytes daten Müssen 3072 Bytes an die HDD gesendet werden.

Blöcke kleiner 512 Bytes werden nicht auf HDD gespeichert.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Aktuelle Projektdokumentationen
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
039
27.07.2023, 16:36 Uhr
wpwsaw
Default Group and Edit


034

was tutst du dich bloss so schwer,

DOS Bootdiskette in einen XT oder 286iger mit 5,25 1,2MB LW, booten lassen und dann Teledisk ausführen und IMAGE TD0 auf eine DS-DD Diskette schreiben. Keine HD nutzen! und fertig

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; und P8000 ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2 und Multicar M25 3SK; Barkas B1000 HP

Dieser Beitrag wurde am 27.07.2023 um 18:50 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
040
27.07.2023, 18:36 Uhr
ggrohmann




Zitat:
wpwsaw schrieb

DOS Bootdiskette in einen XT oder 286iger mit 5,25 1,3MB LD, booten lassen und dann Teledisk ausführen und IMAGE TD0 auf eine DS-DD Diskette schreiben. Keine HD nutzen! und fertig



Würde das Marios EC1834 auch schaffen?

Guido
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
041
27.07.2023, 19:20 Uhr
wpwsaw
Default Group and Edit


nein, nicht mit dem originalen FDC, zumindestens bei mir geht es nicht. Das Programm läuft aber beim Zugriff auf das LW passiert ausser einer Fehlermeldung nichts

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; und P8000 ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2 und Multicar M25 3SK; Barkas B1000 HP
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
042
29.07.2023, 13:49 Uhr
sstadelmann



Hallo an Alle, wie es aussieht bin ich wieder mal zu spät, ist mir beim Z1013 auch so gegangen, als es eine LP gab die alle einzelnen auf eine bündelt. Ich habe nun vor einer Woche mir einen 1715 angeschaft, nach ein paar Startproblemen (Sicherung im Monitor, Netzbuche für Monitor abgerissen, Pin in Buchse für die Tastatur abgebrochen), tut er nun ein bisschen, der Monitor muss noch abgeglichen werden, das Bild sitzt noch nicht im Zentrum. Ja und dann lese ich, das genau in der Zeit als ich mal nicht das Forum besuchte, in kurzer Zeit eine Zusatzplatine entwickelt wurde, die mir auch gut gefallen hätt. Aber, vielleicht haben noch andere Bastler Bedarf und es gibt eine zweite Auflage. Vielen Dank auch an alle, durch die Tips die Ihr hier gegeben habt, konnte ich feststellen , das mein Monitor noch lebt, aber nur nach dem booten anfängt Zeichen darzustellen. Schönes Wochenende an alle.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
043
29.07.2023, 20:43 Uhr
Heiko_P



Guten Abend,

ich kann gern noch einmal Bestellungen für die GUN sammeln und neue Platinen bestellen. Das wäre dann mindestens die 5. Auflage Es sollten aber mindestens 5, besser 10 Platinen werden, sonst wird es unbezahlbar.

VG
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
044
29.07.2023, 21:00 Uhr
Rolly2



Hallo Heiko,
warum nicht die alte Version? Funktioniert bei mir im 1715 und auch im 8924/5120 sehr gut. Habe da keine Probleme! Passt auch besser im 1715, wenn man noch andere Karten, zB. eine VGA, einbauen will.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
045
29.07.2023, 21:26 Uhr
Heiko_P



Hallo Andreas,

bei der alten Version funktioniert der Netzwerkteil nicht ordentlich. Die Fehlersuche war sehr zeitaufwendig, du hast die Diskussion hier im Forum sicher mit verfolgt. In der neuen Version tritt dieser Fehler nicht mehr auf.

Der Platz für weitere Karten ist wirklich knapp, da gebe ich dir Recht. Ich würde gern noch die eine oder andere Erweiterung in meinem 1715 unterbringen, auf der anderen Seite möchte ich nur richtig funktionierende Sachen unter die Leute bringen.

VG
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
046
30.07.2023, 17:12 Uhr
MarioG77

Avatar von MarioG77

Mal ein kurzes Update...
Mir fiel zum Glück der 486 auf, der Betriebsbereit war und Disk als CF Karte.
Mein P4 hat wohl irgendein Problem mit dem Board/Grafikkarte.

Auf dem 486 konnte ich teledisk direkt rüberkopieren.
Andreas hat mir 2 Images geschickt. Beide wurden allerdings mit Schreibfehlern geschrieben (3M 96tpi NOS Disks). Die CPA Disk ermöglichte mir dann aber den Zugriff auf die GIDE und USB Binaries.

Damit konnte ich dann eine CF Karte an der GIDE initialisieren und alle nötigen Dateien via USB Stick auf die CF Karte und auf eine andere Diskette zu schreiben.

Der Netzwerkteil will noch nicht, aber hier habe ich noch keine Zeit reingesteckt.

Im Moment kämpfe ich gerade noch mit SGEN (SYSTEM PASSWORD FALSE - wenn der GIDE geladen ist). Ich möchte gerne von der CF Karte booten. Bevor ich das EPROM brenne gehe ich davon aus, dass ich auf der ersten Partition auch ein OS benötige...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
047
30.07.2023, 17:21 Uhr
DL




Zitat:
MarioG77 schrieb
Im Moment kämpfe ich gerade noch mit SGEN (SYSTEM PASSWORD FALSE - wenn der GIDE geladen ist).



Ja logisch, der GIDE Treiber verändert die Systemdatei im RAM, ein SGEN kannst du nur mit einem sauberen System machen
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
048
30.07.2023, 17:22 Uhr
MarioG77

Avatar von MarioG77

Ja, das dachte ich mir so auch.
Deswegen sollte man doch aber die Datei von Disk laden können, oder?
...das will irgendwie nicht.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004

Dieser Beitrag wurde am 30.07.2023 um 17:23 Uhr von MarioG77 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
049
30.07.2023, 17:26 Uhr
Rolly2



Mario, auf der ersten Festplatte auf deinem GIDE must du ein System generieren. Das machst du bitte mit syswrcpa.com, anders geht das nicht.
Dann brauchst du noch den aktuellen Bootrom, im Moment ist das s502hd4.bin.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
050
30.07.2023, 18:00 Uhr
MarioG77

Avatar von MarioG77

Danke, das spart mir jetzt einiges an Zeit...

Google kennt genau eine Seite, mit dem Dateinamen:
https://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=16206

Das hätte ich so nicht gefunden.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
051
30.07.2023, 19:56 Uhr
MarioG77

Avatar von MarioG77

Wunderbar... Das macht er!

Danke für die Hilfe bis hierher!

Leider kann ich den 1715 noch nicht wieder zusammenbauen.
Ich überlege noch, wie ich eine PS2 Buchse Minimalinvasiv ins Gehäuse bekomme, oder den Tastaturanschluss am Besten realisiere.

Irgendwelche Vorschläge?

Außerdem muss ich noch nach dem Netzwerk der GUN schauen...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
052
30.07.2023, 20:20 Uhr
Rolly2



Lass ihn offen, da kommt bestimmt noch mehr. Ein kleines Steckergehäuse mit EFS und vorne eine DIN-Buchse mit Kabel, so sieht es bei mir aus.
NW braucht eigendlich keiner, mit USB geht das ja prima. Eine Flashair-Karte von Toshiba im USB-Adapter macht das sogar per WLAN. Hatte ich schon vor Jahren im Forum mal vorgestellt.

VG, Andreas

Dieser Beitrag wurde am 30.07.2023 um 20:21 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
053
30.07.2023, 20:45 Uhr
Heiko_P




Zitat:
MarioG77 schrieb
Ich überlege noch, wie ich eine PS2 Buchse Minimalinvasiv ins Gehäuse bekomme, oder den Tastaturanschluss am Besten realisiere.

Irgendwelche Vorschläge?




Wozu möchtest du eine PS/2-Buchse ins Gehäuse einbauen? Der Attiny für den Konverter passt ins Gehäuse des Original EFS-Steckers, dafür muss man nicht den Rechner "verbasteln".

VG
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
054
30.07.2023, 20:46 Uhr
Heiko_P




Zitat:
Rolly2 schrieb
NW braucht eigendlich keiner, mit USB geht das ja prima.

VG, Andreas



Da muss ich dir widersprechen. Seitdem ich meine Dateien per Netzwerk hin und her schiebe brauche ich eigentlich kein USB mehr.

VG
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
055
30.07.2023, 21:01 Uhr
Rolly2



Hallo Heiko, geht aber auch über WLAN, wie geschrieben. Braucht man halt kein Kabel.

VG, Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
056
31.07.2023, 19:20 Uhr
MarioG77

Avatar von MarioG77

Wie peinlich...
Beim ATMEGA habe ich schön drauf geachtet, die Fuses korrekt zu programmieren.
Den Flash und das EEPROM zu programmieren habe ich dabei wohl komplett vergessen...

Kaum macht man's richtig...

Mein nächstes Problem ist jetzt erst Mal - ich muss irgendwie das Thema Anzeige lösen. Mir fehlt die erste und letzte Zeile am TV.
Muss mal schauen, was ich noch so habe...

Ja ich weiß, BWS steht auf dem Wunschzettel, ich muss erst warten, bis sich mein Konto erholt hat...
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek