Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » Defektes K5601 Diskettenlaufwerk? » Themenansicht

Autor Thread - Seiten: -1-
000
10.12.2010, 15:42 Uhr
robotronDDR



hallo erst mal. ich bin neu hier und wollte mich erstmal vorstellen.
ich bin seit ca. 2 Monaten im besitz eines noch sehr gut erhaltenen
EC 1834. er stand 17 jahre lang unbenutzt in einem Heizwerk und
lief sofort ohne probleme. laufen tut er mit DCP3.3 und dem Norten
Commander. aber bereis nach dem starten und dem ram test
zeigte er mir den fehler "601: Diskette Error" an. Ich kenne
mich zwar etwas mit ComputerTechnik aus, wollte aber mal hier
erst um Hilfe fragen. Nun wollte ich mal wissen ob das laufwerk defekt
ist oder es ein anderes Problem ist? Die LED am Diskettenlaufwerk
lauchte nähmich nach dem Einschalten kurz auf.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
11.12.2010, 18:49 Uhr
Lutz_II




Zitat:
robotronDDR schrieb
hallo erst mal. ich bin neu hier und wollte mich erstmal vorstellen.
ich bin seit ca. 2 Monaten im besitz eines noch sehr gut erhaltenen
EC 1834. er stand 17 jahre lang unbenutzt in einem Heizwerk und
lief sofort ohne probleme. laufen tut er mit DCP3.3 und dem Norten
Commander. aber bereis nach dem starten und dem ram test
zeigte er mir den fehler "601: Diskette Error" an. Ich kenne
mich zwar etwas mit ComputerTechnik aus, wollte aber mal hier
erst um Hilfe fragen. Nun wollte ich mal wissen ob das laufwerk defekt
ist oder es ein anderes Problem ist? Die LED am Diskettenlaufwerk
lauchte nähmich nach dem Einschalten kurz auf.

Ich bin auch eher selten hier ... und ebenfalls stolzer Besitzer eines EC1834 ...
"601: Diskette Error" ist eine Fehlermeldung, die damals in vielen BIOS-Versionen so enthalten war und meist meint: "Disk Controller Failure".
Somit testen:
1. Kabel zwischen Diskettencontroller und Floppy-Laufwerk(en) prüfen, abziehen,
wieder anstecken (manchmal sind es nur die Steckkontakte ...)
2. Diskettencontoller raus und wieder rein (manchmal ... ...)
3. Diskettencontroller ausbauen, nur mit der Festplatte starten
4. Weiter geht nur mit Ersatzteilen ... anderer Diskettencontroller, anderes
Diskettenlaufwerk ... hier kann ich leider nicht helfen.
Viel Glück !

Lutz
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
13.12.2010, 17:38 Uhr
robotronDDR



danke ich werde es nachher mal probieren.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
14.12.2010, 08:14 Uhr
robotronDDR



Dein Ratschläge haben leider nicht Funktioniert. Ich gehe mal davon aus das dass Laufwerk defekt ist.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
23.12.2010, 10:12 Uhr
felge1966

Avatar von felge1966

Dann kapere ich den Artikel mal.

Ich habe mehrere (6 Stück) K5601, die am KC87 völlig problemlos arbeiten, am PC1715 wurden davon auch zwei getestet. Als ich sie an der D004 vom KC85 anschaltete, konnte ich sie lesend auch benutzen, aber jeder Schreibversuch schlug fehl. Nach dem Ringtausch der Floppylaufwerke geht die D004, woran kann dies liegen. Sind die Laufwerke nun defekt, obwohl sie Formatieren, Schreiben und Lesen können?

Die neu eingebauten Laufwerke sind vom gleichen Typ mit identischen Jumpern und der gleichen Terminierung.

Dieser Beitrag wurde am 23.12.2010 um 10:13 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
23.12.2010, 10:21 Uhr
Rüdiger
Administrator


Ich tippe auf ein Terminierungsproblem. Oszillografiere mal den Pegel der Schreibdatenleitung.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
25.12.2010, 10:57 Uhr
robotronDDR



OK, danke für eure Hilfe, ich wünsche euch allen noch ein Frohes Weihnachts Fest.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
30.01.2018, 23:29 Uhr
Lötspitze



Ich hänge mal meine Frage hier mit rein, da es ganz gut paßt:

Das K5601 in einer DSE am BIC wollte leider nicht so richtig. Es wurde immer nur als 360k-Laufwerk erkannt. Nach Austausch mit einem Mitsumi funktioniert die DSE nun mit 780k problemlos (mit der gleichen Diskette DS/DD wie vorher, die in anderen Rechnern auch als 780k erkannt wird).
Hat jemand eine Idee, woran das liegen könnte? Ich möchte das gute Teil ungern zum alten Eisen geben, sondern lieber wieder in Ordnung bringen und zurückbauen.

Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.

Dieser Beitrag wurde am 30.01.2018 um 23:31 Uhr von Lötspitze editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
31.01.2018, 06:45 Uhr
holm

Avatar von holm

Keine Ahnung beim BIC aber PCs ermitteln wie viele Tracks ein LW hat in dem das BIOS das Ding ganz einfach gegen den Anschlag steppt, d.h. es werden nach Suchen von Track 0 mehr als &0 Schritte nach innen gesteppt und danach zurück. Sind rückwärts weniger als &0 Schritte notwendig um den Track 0 zu erreichen war der Kopf am Anschlag und das LW hat nur 40 Spuren..

Wenn hier das selbe Prinzip benutzt wird ist das LW wohl einfach mechanisch verklemmt/verdreckt.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
31.01.2018, 08:58 Uhr
ralle



Der BIC wurde auf PC1715 getrimmt, was die Formate betrifft. Ich weiß nur, das es im RBASIC einen Reset gibt, was die Laufwerke auf 780 k initalisiert. Schau mal ins HB.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
02.02.2018, 22:26 Uhr
Lötspitze



Ja, beim BIC gibt's das RESET, um eine neue Diskette anzumelden. Normalerweise zeigt es dann am Bildschirm die "780k" an. Nur nicht bei diesem Laufwerk.

Ich habe das K5601 mal etwas gesäubert und den Lesekopf vorsichtig in beide Richtungen mehrmals bis zum Anschlag geschoben. Die Lichtschranken wurden auch gereinigt.
Für den Test habe ich das Laufwerk jetzt am Z1013 unter CPA mit 800k. Es muckert zwar immer noch, aber trotzdem konnte ich es zumindest mal überreden, das Verzeichnis einer 800k Diskette anzuzeigen:



Also schon ein kleiner Fortschritt. Kann man da noch irgendetwas besser justieren?

Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
02.02.2018, 22:48 Uhr
kaiOr

Avatar von kaiOr

Da kann man einiges justieren:
http://www.tiffe.de/Robotron/K5601/

Ich würde vermuten, das Signal /SS - Kopfauswahl nicht durchdringt und der BIC dann von einem einseitigen Laufwerk ausgeht. 40 Spuren 2-seitig oder 80 Spuren 1-seitig kommt von der Kapazität her gleich.

MfG

Dieser Beitrag wurde am 02.02.2018 um 22:51 Uhr von kaiOr editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek