Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » M052 - Startschwierigkeiten » Themenansicht

Autor Thread - Seiten: -1-
000
20.02.2023, 18:12 Uhr
_faxx



Hallo in die Runde :-)

..ich hab nun nach vielen Jahren mal wieder einen meiner KC's (hier ein 85/4) rausgekramt. Die Freude ist groß, dass der gute alte Oststein problemlos angesprungen ist (mal sehen ob das die Tage mit meinem "Floppy" Turm auch so wird...)

Das Wissen ist leider etwas eingerostet über die Jahre...

Problem (wenn es denn eines ist) ->

Ich hatte mir vor ein paar Jahren in der Bucht mal ein M052 (Version ohne Netzwerk) geholt. Ich bekomme das auch lt. HB mit "SWITCH 08 C1" eingeschaltet... (KC gibt Rückmeldung)

Das CAOS Menü bleibt aber leider leer...
Mache ich grundsätzlich etwas falsch? Muss ich das M052 erst mit der passenden SW beglücken? (bzw. kann ich irgendwie prüfen ob das bereits passiert ist)..

Entschuldigt meine (für Euch) ggf. einfachen Fragen... ich bin nur gerade etwas hilflos hier und kratze mich am Kopf, wie ich so viel vergessen konnte über die Jahre ;-)

Viele Grüße
_faxx / Uwe
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
20.02.2023, 19:07 Uhr
ralle



EPROM Alzheimer? Oder versehentlich den EEPROM gelöscht? Zumal in diesem beide passen.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
20.02.2023, 19:25 Uhr
_faxx



Tja.. das ist die Frage...

1; Kann ich das irgendwie checken mit CAOS Bordmitteln?

2; Kann ich das mit "Bordmitteln" vom KC oder anderswie ( z.B. am Rechner mit RS232 o.ä.) lösen / sprich die SW (über NullmodemKabel / USB / ..) auf das Modul bringen? (SW M052-USB Software v.3.1 aus dem KC Labor?)

Vielen Dank,

_faxx
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
20.02.2023, 19:41 Uhr
maleuma




Zitat:
_faxx schrieb
Tja.. das ist die Frage...

1; Kann ich das irgendwie checken mit CAOS Bordmitteln?

2; Kann ich das mit "Bordmitteln" vom KC oder anderswie ( z.B. am Rechner mit RS232 o.ä.) lösen / sprich die SW (über NullmodemKabel / USB / ..) auf das Modul bringen? (SW M052-USB Software v.3.1 aus dem KC Labor?)

Vielen Dank,

_faxx


1.
%SWITCH 08 C1
%DISPLAY C000
Dann sollte der Inhalt des M052-EEPROM angezeigt werden. Sollte alles FF sein, dann ist der EEPROM leer.

2. Neu beschreiben kannst Du den EEPROM mit dem Hilfsprogramm EEPROM.KCC aus dem KC-Labor. Könnte aber schwierig werden, dass ohne ein funktionierendes M052 auf den KC zu bekommen. Oder hast Du noch eine andere Möglichkeit, Programme zu laden?
--
Mario.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
20.02.2023, 19:49 Uhr
DL



Wenn ein EEPROM genutzt wird und der Jumper zum schreiben steckt ist mir das anfangs auch schon öfter passiert, da reichte nur ein falscher Aufruf des Moduls. Der Vergleich brachte dann immer nur ein paar abweichende Bytes...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
20.02.2023, 21:44 Uhr
_faxx



Ah Ok. das (1.) Teste ich Mogen mal (hab den KC nicht hier "zur Hand").

Naja, ich könnte das "klassisch" über den Kasettenport reinbraten... (wenn das mit dem .KCC File grundsätzlich geht) Bestimmt gibt es irgend ein Tool, dass die Daten in "KC-Musik" übersetzt... (wie gesagt, bin länger aus dem KleinComputer Geschäft raus... aber ich will mir Mühe geben ^-^)

Alternativ von Floppy (D004/Basis/Laufwerk)... aber dafür müsste ich "das" erstmal wieder unter Dampf setzen... (wenn es denn noch dreht; schläft auch so lange wie der KC) UND das File irgendwie auf die Disk kriegen... Das sind ja schon wieder so viele Rechner-Architektur- und Datenträger-brüche...

Ich habe ja das M052 selbst noch nicht genutzt, weiß also nicht ob der Vorbesitzer das (versehentlich) platt gemacht hat, oder vielleicht nie am Laufen hatte / ggf. die Lust verloren hat... Davon, dass es grundsätzlich funzt gehe ich eigentlich aus, nach dem bisherigen Verhalten.

Vg, _faxx
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
21.02.2023, 08:02 Uhr
Bert




Zitat:
_faxx schrieb
Naja, ich könnte das "klassisch" über den Kasettenport reinbraten... (wenn das mit dem .KCC File grundsätzlich geht) Bestimmt gibt es irgend ein Tool, dass die Daten in "KC-Musik" übersetzt..


Ja, diese Tools gibt es. Gerne wird dafür der JKCEMU genutzt. Damit kann man eine Kopplung 'virtueller KC' -> Audio -> TAPE-Schnittstelle -> 'reeller KC' herstellen und auf dem einen KC SAVE und auf dem anderen KC entsprechend LOAD benutzen.

Für Windows gibt es die Programme KCLOAD und KCSAVE, aber damit habe ich keine Erfahrung:
https://hc-ddr.hucki.net/wiki/doku.php/programme/kassetten_faq

Bei mir werkelt für solche Fälle ein Python-Skript, was die KCC-Dateien in eine WAV-Datei konvertieren kann. Danach kann ich sie auf dem PC mit jedem gängigen WAV-Player abspielen.
Das Skript sollte ich wohl mal bei Gelegenheit veröffentlichen...

Viele Grüße,
Bert
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
21.02.2023, 15:00 Uhr
_faxx



So,

ich hab mal den Speicherauszug gezogen...

%SWITCH 08 C1

08 FD C1

%DISPLAY C000

C000 FF FF FF FF FF FF FF FF
C008 FF FF FF FF FF FF FF FF
usw...

Also der "leere" Zustand...

siehe auch hier (Screenshot)
https://pasteboard.co/fzSjUGlt3PpS.jpg

Die Jumper die man oben durch den Deckel des Moduls erreichen kann (gehören nach Bestückungsplan/HB zum VNC1L) sind vermutlich für das EEPROM schreiben irrelevant..

(Modul von Vorne gesehen)
oberer Jumper (J4?) rechts (2-3 vermutlich)
unterer Jumper (J3) links (1-2 vermutlich)

lt. HB korrekte Einstellung für Kommunikation mit PIO P-A/B

Ok, das KCload / KCsave scheint recht alt zu sein... das hab ich erstmal beiseite gelegt.. das Bedarf sicher DOSbox oder sonstwas altem (ich popel mir gerade wieder ein 286-16 zusammen, da fühlt sich das Prog evtl. zu Hause ;-) )

Den jkcemu hab ich eben auch ans Laufen bekommen...

Dort muss ich jetzt quasi das EEPROM.KCC aus dem KC-Labor reinladen und dann irgendwie als WAV-File ausgeben? (was ich dann wiederum in den KC TAPE Port stopfe), richtig?

VG
_faxx

ERGÄNZUNG:

Ich habe jetzt mal nach dem im HB beschriebenen "EEPROM.KCC" gesucht. Eine Datei mit diesem Namen hab ich nirgendwo gefunden bisher... Runtergeladen habe ich "m052usb-v2.7.zip", darin enthalten sind u.a. "M052-USB mit VNC1" und "M052-USB mit VNC2 und Tastatur"...

Vermutlich habe ich ein "VNC1" Modell (Beschriftung "VDIP1")..
Ist dann das "M052-USB mit VNC1\M052usb1.kcc" File, das das ich laden muss?
(einfach mit LOAD Kommando - von Tape In, ohne weitere Parameter?)

Bild:
https://pasteboard.co/WfvUprgGxY46.png

So viele Fragen

PS: mein KC hat aktuell CAOS 4.1

Dieser Beitrag wurde am 21.02.2023 um 16:16 Uhr von _faxx editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
21.02.2023, 17:16 Uhr
maleuma



EEPROM.KCC findest du hier.
--
Mario.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
21.02.2023, 17:53 Uhr
schlaub_01



Hallo Uwe,
zunächst wäre es aber besser, wenn Du erst mal schaust, ob ein EPROM oder EEPROM verbaut ist, sonst bringt der ganze Aufwand nichts. Den EPROM bekommst Du im Modul nicht programmiert.

Viele Grüße,
Sven.

Dieser Beitrag wurde am 21.02.2023 um 17:53 Uhr von schlaub_01 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
21.02.2023, 18:35 Uhr
Enrico
Default Group and Edit


Ich denke aber nicht, dass sich ein EPROM im Modul gelöscht hat.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
21.02.2023, 18:42 Uhr
Bert




Zitat:
_faxx schrieb
ich hab mal den Speicherauszug gezogen...

%SWITCH 08 C1
08 FD C1


Geht denn bei diesem Befehl die Modul-LED an, bzw. ändert sich die Farbe?
Mit 'SWITCH 08 00' sollte m.E. die LED ausgehen.

Viele Grüße,
Bert
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
21.02.2023, 18:42 Uhr
_faxx



Hallo, erstmal vielen Dank für Eure bisherigen Hinweise :-)

Nunja, das ist vermutlich die Erklärung für die FF FF FF... (Bild im Link).

https://pasteboard.co/2lnhqPJg6DCX.png

Was kauft man da? z.B. Reichelt Best Nr. 28C64-150
(EEPROM, 64 Kb 8Kx8, 5 V, 150 ns, PDIP-28)

Wenn ich jetzt eh den ganzen Zirkus zerlegt hab, und den EEProm eh "draußen" hab, kann ich den doch bestimmt gleich in nen passenden Prommer stopfen (->VNC1\M052usb1.rom brennen) oder? (haben wir auf Arbeit vielleicht irgendwo)

Wäre dann M052-USB mit VNC1 ? (-> VNC1\M052usb1.rom)

Wenn ich keinen Prommer finde, und den Stein dann habe, dann lade ich das EEPSDP3 ab 0200h (das ist das Prog zum flashen für den KC?) und lade danach noch den eigentlichen Inhalt des EEPROMS (VNC1\M052usb1.rom ?)...

Vielen Dank für Eure Geduld mit mir
VG _faxx

Dieser Beitrag wurde am 21.02.2023 um 20:21 Uhr von _faxx editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
21.02.2023, 19:18 Uhr
_faxx



Ja, ..also bei Switch 08 C3 (glaube ich) ging die gelbe LED an (soweit ich mir gerade erinnere) also irgendwas scheint da schon zu zappeln....
Die Modulkennung (FD ist doch das hier oder?) hat der KC doch bestimmt auch wo hergeholt oder?

_faxx / Uwe
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
21.02.2023, 22:02 Uhr
schlaub_01




Zitat:
_faxx schrieb
Wäre dann M052-USB mit VNC1 ? (-> VNC1\M052usb1.rom)



Genau, bei Deinem Modul ist ein VNC1 drauf und dafür passt die genannte Datei.

Viele Grüße,
Sven.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
02.03.2023, 16:12 Uhr
_faxx



Hallo,

ich wollte mich nochmal für Eure Hilfe bedanken :-)

Wir haben das ROM heute auf den Atmel Stein gebrutzelt... und, es läuft :-)

https://pasteboard.co/dDslEVrOpkBM.png

https://pasteboard.co/sm8vzL2VvX4Z.png

Nun schauen wir mal, was wir damit schönes anstellen können :o)

VG; _faxx
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek