Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » PC1715 mit Gotek LW und FlashFloppy Lesefehler? » Themenansicht

Autor Thread - Seiten: -1-
000
28.01.2023, 13:26 Uhr
albireo



Hallo Freunde der DDR Rechentechnik,

ich habe meinem PC1715 ein Gotek Laufwerk mit Flashfloppy SW verpasst. Das Laufwerk habe ich aktuell als Laufwerk1 also "B" eingebunden. Der Rechner Bootet also über Lauferk 0 über eine Diskette.

Ich kann auf Laufwerk B zugreifen, ein Directory anzeigen und kurze Zextdeteien ansehen. Aber es kommt bei COM Dateien oder längeren Text Dateien immer zu Lesefehlern:
"BIOS ERR ON: B T:26 S: 06 ......."
"BIOS ERR ON: B T:26 S: 06 ......."
"BIOS ERR ON: B T:54 S: 01 ......."

In der Konfig von Flash Floppy habe ich folgendes aktiviert:
"shugart: P2=DSKCHG, P34=RDY (Amiga, Atari ST, many others)"

Woran kann das liegen?

Viele Grüße
Daniel
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
28.01.2023, 13:28 Uhr
albireo



Als Ergänzung ich erhalte auch die Meldung "SCPX ERR ON B: BAD SECTOR"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
28.01.2023, 15:22 Uhr
DL



Image fehlerhaft, USB-Stiick zu langsam, Steckverbindung wacklig, kein Terminator ?
Normalerweise gibts da keine Probleme.

Edit: Ok, Terminator nehme ich zurück, im LW A wird ja einer stecken, das reicht eigentlich

Dieser Beitrag wurde am 28.01.2023 um 15:24 Uhr von DL editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
29.01.2023, 12:08 Uhr
albireo



USB Sticks habe ich jetzt mehrere versucht, daran kann es eigentlich nicht liegen. Ich habe jetzt B neu initialisiert, das lief ohne Fehler. Danach habe ich eine Datei von A nach B kompiert und da kommen wieder Fehler und der Kopiervorgang wir abgebrochen :-(
Von daher kann ies eigentlich kein Fehler in den Images sein.

Einen Wackler in der Steckverbindung kann ich ausschliessen. Hat noch einer einen Tipp?

Kann es ggf. an der Verkabelung liegen?

Gotek->PC 1715 Floppy-Disk X3
_CHNG -> offen
_MTRON ->MO1
_INDEX -> IX
_SEL0 ->SE0
_SEL1 ->SE1
_DIR ->SD
_SEP ->ST
_WD -> WD
_WE -> WE
_TRK0 ->T0
_WPROT ->WP
_RD ->RD
_SIDE-> offen
_RDT->RDYL

Dieser Beitrag wurde am 29.01.2023 um 12:10 Uhr von albireo editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
29.01.2023, 12:40 Uhr
albireo



Fehler gefunden: SIDE muss auf A10!

:-)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
29.01.2023, 12:42 Uhr
Andre.as



Side / SS sollte mit angeschlossen sein.

Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
29.01.2023, 12:44 Uhr
Andre.as



Welche Lesegeschwindigkeit hast du?

Ein Test mit Power "Test S" dauert genau die doppelte Zeit gegenüber einem Disketten LW am KC85.

Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
29.01.2023, 13:23 Uhr
DL




Zitat:
albireo schrieb
Fehler gefunden: SIDE muss auf A10!

:-)



Eigentlich brauchts beim internen Anschluß doch nur einen Adapter 3,5/5,25.
Genau für SideSelect wird das frühere FaultReset genutzt und da der Bootlader dies noch als FR bedient und da Impulse rausschickt muß zum booten der Glitchfilter in der FF.CFG auf 17 bis 20 gesetzt werden um das zu unterdrücken....

https://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=19338

Dieser Beitrag wurde am 29.01.2023 um 13:32 Uhr von DL editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
29.01.2023, 20:06 Uhr
albireo



@ Andreas: ich schätze auch dass das Gotek etwas langsamer ist.
Ab und zu habe ich aber noch immer noch Lesefehler :-(

@DL ich habe das Laufwerk am externen Floppyport angeschlossen, da musste ich mir den Adapter selbst löten.

Den Glitchfilter hatte ich schon auf 17 eingestellt.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
30.01.2023, 11:50 Uhr
DL




Zitat:
albireo schrieb
ich schätze auch dass das Gotek etwas langsamer ist.



So groß kann der Unterschied da nicht sein, die Datenrate ist ja fest 250000 bit/sek...

Test aus Power am PC1715 und 800K CP/A Diskette ergab 8min 32sek mit Disk und 8min 36Sek mit dem Gotek
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
30.01.2023, 17:13 Uhr
Andre.as



Habe gerade die Messung an der D004 wiederholt und habe folgende Zeiten:

Diskettenlaufwerk 5,25" & 3,5" = 100s Gotek = 200s

So eine richtige Erklärung dazu habe ich noch nicht, MFM sollte das GOTEK doch simulieren können.


Andreas
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
30.01.2023, 17:30 Uhr
MarioG77

Avatar von MarioG77

An meinem Olivetti 286er ist mein Gotek auch Gefühlt Schneckenlahm.
Für die 6 Disketten mit FreeDOS war nach 6h noch nicht fertig.
--
Gruss Mario

Betriebsbereit: KC85/3, 2x [KC85/4, D004+Floppy], PPC512, PC1512, 2xEC1834, Soemtron 286, 3x PC1715, picoAC1
Zu restaurieren: 1x D004
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
30.01.2023, 17:49 Uhr
Enrico
Default Group and Edit


Liegt das ev. am Sektorinterleave?
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
31.01.2023, 10:16 Uhr
DL




Zitat:
Enrico schrieb
Liegt das ev. am Sektorinterleave?


Ja sicherlich, Organisation passend zur Intelligenz spart etwas Zeit beim suchen.
Mit einem I3 hab ich die 8min 36Sek immerhin auf 7min45sek drücken können, mehr wird bei 5Sektoren auch nicht rauszuholen sein.
Es dauert eben wie es dauern muss, eine Spur ist nun mal 200ms lang und die Daten kommen nicht schneller als 250000bits/sek und wenn das timing nicht stimmen würde käme da nur Grütze und eine der beliebten Fehlermeldungen raus.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek