Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Sonstiges » REX IBM-Prommer 512 » Themenansicht

Autor Thread - Seiten: -1-
000
07.03.2020, 17:59 Uhr
joka



Hallo,

Ich habe vor Jahren mal diesen Prommer bei Ebay ersteigert. Leider habe ich zu diesem Teil keinerlei Unterlagen. Heute habe ich mal probiert ihn in Betrieb zu nehmen leider nur mit bescheidenem Erfolg. Voreingestellt ist er wohl auf einen 2716. Eproms diesen Typs lassen sich auch auslesen, aber eine Programmierung schlägt leider fehl. Ich habe mehrere IC ausprobiert, schon möglich das sie defekt waren. Aber ev. liegt der Fehler ja auch woanders? Meine Frage ist nun, hat irgend wer noch Unterlagen zu diesem Teil?

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
07.03.2020, 19:26 Uhr
Enrico
Default Group and Edit


Ich habe zwar einen EPROMer von REX, das muss aber was anderes
als Deiner sein, da Du noch was von IBM schreibst.
Meiner ist für den Amiga.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
07.03.2020, 19:44 Uhr
joka



Hallo Enrico,

Das Teil muß uralt sein: ISA 8-Bit Bus und auf dem Prommer-Sockel ist auch keinerlei Beschriftung außer Rex IBM-Prommer. Komisch ist, das der EPROM nach fehlgeschlagener Programmierung vollkommen leer ist. Ich hätte gedacht, das dann wenigstens irgend welcher Datenmüll zu sehen ist? Außerdem ist das Teil laut Infodatei auch für andere Typen geeignet. Aber das muß ja dann sicherlich irgendwie codiert werden? In meinem Prommer-Programm geht nur 2716, egal was ich für einen Typ eingebe.

MFG
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
07.03.2020, 20:56 Uhr
sylvi



Hallo,
ich habe so einen, aber keine weiteren Unterlagen.
Außer der Software und der geht einfach.
Der EPROM-Typ wird in der Software eingestellt.
lg
sylvi
--
Meine Uhr ist eingeschlafen
Ich hänge lose in der Zeit
Ein Sturm hat mich hinausgetrieben
Auf das Meer der Ewigkeit
Asyl im Paradies, Silly
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
07.03.2020, 21:17 Uhr
Enrico
Default Group and Edit


Na, dann muss er ja kaputt sein.
Ich denke, da fehlt wenigstens die Programmierspannung.
Ein lese- bzw. Leertest wird der ja sicherlich haben.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
07.03.2020, 21:24 Uhr
joka



Hallo sylvi,

wenn ich den EPROM-Typ in der Software ändere erscheint im unteren Anzeigefeld nur immer 2716, Programmierspannung 25V, egal was ich eingebe! Wäre ja auch erst einmal ok, doch leider schlagen Programmierversuche fehl. Irgend etwas mache ich wohl falsch? Kannst du mir beschreiben, wie du vorgehst? Für Anfänger...

MFG

Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
07.03.2020, 23:26 Uhr
Deff

Avatar von Deff

Also ich hatte schonmal einen Defekt auf einer ISA-8 bit-EPROMMER-Karte in Form eines 7407-Gatters...
Vielleicht ist auf Deiner Karte ebenfalls ein Defekt?

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
08.03.2020, 10:56 Uhr
PIC18F2550

Avatar von PIC18F2550

Meinst Du diesen?



--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
08.03.2020, 11:24 Uhr
joka



Genau. Das Problem mit dem EPROM-Typ hat sich erledigt, das Programm ist ziemlich speziell...
Aber wahrscheinlich fehlt tatsächlich die Programmierspannung. Ich werde das Teil wohl vorerst zu den "Akten" legen.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
08.03.2020, 11:38 Uhr
felge1966

Avatar von felge1966

Falls es das abgebildete Teil ist, solltest du dir den TL497 mal unter die Lupe nehmen. Die sterben bei Überlastung auch gerne.

Gruss Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
08.03.2020, 11:40 Uhr
PIC18F2550

Avatar von PIC18F2550

Ich habe am Regler noch eine Diode einlöten müssen damit ich alle EPROMs programmieren konnte.

Das Programm ist aber einfach gehalten nichts spezielles.

Wenn ich mich recht erinnere müsste die Kalibrierung und Testroutine in der Exe enthalten sein.

Eventuell hast du noch die alte Software den da gab es mal einen Nachtrag.

Bei mir läuft es unter Novell Dos stabil.

Wenn du mir deine Email verraten würdest dann würde ich dir meine Software dazu schicken.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
08.03.2020, 11:58 Uhr
krabat



Moin,

Auch mal die Transistoren prüfen! Bei mir war mal einer defekt (Kurzer).

Gruß Peter
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
08.03.2020, 12:00 Uhr
joka



Erst einmal schönen Dank für die Hinweise. Meine Email habe ich in der Mitgliederliste hinterlegt. Ich schätze mal ich habe tatsächlich noch die alte Software. Mit "speziell" meinte ich auch, das ich das Programm erst verlassen musste, um einen anderen Typ einzustellen.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
08.03.2020, 12:12 Uhr
Deff

Avatar von Deff

Da hat REX-Datentechnik einige ähnliche Karten rausgebracht, denn meine von oben beschriebene sieht dieser hier ganz ähnlich und basiert wohl auf einem ähnlichen Schaltungsaufbau. Wie ich anmerkte, war ein Gatter des 74xx07 defekt gewesen.
Die zusätzliche Diode brauchte ich dagegen nicht einlöten, kann aber nicht verkehrt sein, ca. 0,6V aufzustocken.

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
08.03.2020, 13:17 Uhr
joka



Ich schätze mal ich weiß, welchen du meinst. Bei mir ist es ein GD74LS07. Könnte es auch am TL497ACN liegen? Den würde ich auch tauschen wollen, wenn es mit dem anderen Programm nicht klappt. Der Programmierbalken bricht bei einer beliebigen Adresse ab, und das Programm meldet dann "Programmierung fehlgeschlagen". Der EPROM ist danach noch absolut unbeschrieben.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
08.03.2020, 14:01 Uhr
Enrico
Default Group and Edit


s.o.,
sowas schrieb ich ja schon.
Aber nur einfach wild tauschen bringt auch nix.
Erst mal messen....
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
08.03.2020, 16:34 Uhr
Deff

Avatar von Deff

Na ja, erstmal messen, ist auch nicht der Beginn der Fehlersuche! Da geht zumindest DB-Studium voraus und die Entscheidungsfindung, ob man sich eine Reparatur überhaupt zutraut, weil auch etwas Equipment wie z.B. ein Multimeter und Logiktester vorhanden sind.
Die Karte sollte extern und gemäß des ISA-Bus-Pinouts mit Spg. versorgt werden, denn im PC ist die Handhabung recht bescheiden.
=> https://old.pinouts.ru/Slots/ISA.shtml
Die Vpp kann man, da sie ständig generiert wird, messen und ggf. mit dem Einstellregler kalibrieren. Kann ja sein, das da dran rumgedreht wurde...
=> https://www.datasheetq.com/TL497-doc-TI
Sollte man sich entscheiden, den TL auszulöten und zu tauschen, dann nur über eine IC-Fassung. Es soll auch schon Kondensatoren (Elkos/Tantaler etc.) gegeben haben, die ihre Fkt. verloren haben.

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)

Dieser Beitrag wurde am 08.03.2020 um 16:35 Uhr von Deff editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
08.03.2020, 16:58 Uhr
Enrico
Default Group and Edit


Das mit dem Datenblatt hatte ich natürlich vorrausgesetzt.
Wobei ja erstmal egal ist wer bzw. wie die Vpp erzeugt.

Und außerdem kann man ja auch gar nicht sagen, tausche mal dieses oder jenes,
ohne genau diesen Programmer liegen zu haben.
Das würde nicht mal was bringen, wenn man den hat.

Geht also nur mit durchmesen, ev. in Teilen einen Plan zu zeichnen.
Den wird im Netz sicherlich nicht unbedingt geben.
--
MFG
Enrico

Dieser Beitrag wurde am 08.03.2020 um 17:01 Uhr von Enrico editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
08.03.2020, 17:02 Uhr
Deff

Avatar von Deff

...genauso egal, wie, wer hier die Tipps gibt - nur stimmig sollten diese sein!
Bloss weshalb Du die Vpp-Erzeugung erneut rauspickst, keine Ahnung.
Darum geht's doch schon paar Beiträge lang.
Doch! Man kann schreiben, tauschen mal diese oder jenes! Nur wirklichen Sinn macht das keinen, und deshalb gab es derartige Tipps bisher auch nicht.

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)

Dieser Beitrag wurde am 08.03.2020 um 17:05 Uhr von Deff editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
08.03.2020, 17:06 Uhr
Deff

Avatar von Deff

Nicht soviel Edit, man kommt ja gar nicht hinterher, Enrico!
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)

Dieser Beitrag wurde am 08.03.2020 um 17:07 Uhr von Deff editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
08.03.2020, 17:07 Uhr
joka



Da ich weder Schaltplan noch anderweitigen Unterlagen zu dem Prommer habe, würde ich mit messen sicherlich nicht weit kommen und ev. nur noch mehr Schaden anrichten. Mein Plan ist daher die o.g. Bauteile mal zu tauschen und mit Fassung zu versehen. Die Vpp zu messen ist ein guter Hinweis.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
08.03.2020, 18:09 Uhr
Enrico
Default Group and Edit



Zitat:
Deff schrieb
...genauso egal, wie, wer hier die Tipps gibt - nur stimmig sollten diese sein!
Bloss weshalb Du die Vpp-Erzeugung erneut rauspickst, keine Ahnung.
Darum geht's doch schon paar Beiträge lang.
Doch! Man kann schreiben, tauschen mal diese oder jenes! Nur wirklichen Sinn macht das keinen, und deshalb gab es derartige Tipps bisher auch nicht.

Ingo



Na, wenn der nicht programmiert, ist das doch der 1. Ansatz.


Jörg, drum ja auch selber zeichnen.
Wenns sonst nicht anders mehr geht, beleibt einem nix übrig.
--
MFG
Enrico

Dieser Beitrag wurde am 08.03.2020 um 18:10 Uhr von Enrico editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
08.03.2020, 18:34 Uhr
joka



Ja, ich habe deine Philosophie auch durchaus verstanden. Mein Problem ist nur, dass sich mein eigentliches Projekt jetzt verzögert, sprich was geht schneller Schaltplan erstellen oder auf gut Glück IC tauschen? Auf jeden Fall habe ich jetzt erst einmal eine Vorstellung, wo ich den Fehler finden kann. Dafür noch einmal Danke.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
08.03.2020, 18:45 Uhr
Enrico
Default Group and Edit


i.d.R. war es jedesmal falsch rum.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
08.03.2020, 20:06 Uhr
Deff

Avatar von Deff


Zitat:
Enrico schrieb
Na, wenn der nicht programmiert, ist das doch der 1. Ansatz.


Mag sein, aber nur solange wie eine Messung von Vpp deren Vorhandensein bestätigt.
Enrico, wenn Du meinen Defekt gelsen hast, dann sollte Dir klar sein, dass auch andere Defekte zum Nichtprogrammieren führen!

Vielleicht ist es sinnvoller, dass der TO sich einen Reparateur sucht!

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)

Dieser Beitrag wurde am 08.03.2020 um 20:07 Uhr von Deff editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
08.03.2020, 20:18 Uhr
Enrico
Default Group and Edit


Ja, schon klar.
Dannach kommen Transistoren, oder vom Rechner kommt nix,
etc...
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
08.03.2020, 20:57 Uhr
PIC18F2550

Avatar von PIC18F2550

joka das Programm ist unterwegs.

Oder Du bringst das Teil zum Treffen mit.(Muss es blos wissen)
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
09.03.2020, 09:28 Uhr
PIC18F2550

Avatar von PIC18F2550

Mit deinem Postfach stimmt was nicht.
Entweder es ist voll oder dein Provider hat was gegen mich.
4 Versuche sind genug.

Entweder sagt er SPAM ist für mich auch neu. da ich nur über das Webinterface eMails versenden kann.
oder Virus als einziger zu einen fast 20 Jahre alten programm.(von CD)
oder das er die ZIP nicht öffnen kann Klar hab ich ja auch beim 4. mal Verschlüsselt.

Ein test versand zu einen Anderen Providern ohne Propleme.

So wird das nüscht.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
09.03.2020, 13:37 Uhr
sylvi



Hallo,

joka schrieb:
"wenn ich den EPROM-Typ in der Software ändere erscheint im unteren Anzeigefeld nur immer 2716, Programmierspannung 25V, egal was ich eingebe! Wäre ja auch erst einmal ok, doch leider schlagen Programmierversuche fehl. Irgend etwas mache ich wohl falsch? Kannst du mir beschreiben, wie du vorgehst? Für Anfänger.."

Wenn ich den EPROM-Typ ändere, dann erscheint unten der geänderte Typ.
Meine Software ist Ver. 4 , gibt es eine neuere?
Meiner war anfangs auch defekt, war ein Transistor, ob noch was anderes weiß ich jetzt gar nicht mehr. Aber sind ja nicht so viele Teile auf der Karte.
lg
sylvi
--
Meine Uhr ist eingeschlafen
Ich hänge lose in der Zeit
Ein Sturm hat mich hinausgetrieben
Auf das Meer der Ewigkeit
Asyl im Paradies, Silly
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
09.03.2020, 16:34 Uhr
joka



Hallo sylvi,

Das wird ja dann immer seltsamer. Den EPROM-Typ kann ich nur wechseln, wenn ich das Programm beende und neu starte. Egal, erst einmal muß ich raus finden, warum das Teil nicht programmiert. Ich werde mich am Wochenende wieder damit befassen, nach der Arbeit ist mir das zu stressig.

MFG,
Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Sonstiges ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek