Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Flohmarkt » Leiterplatte aus dem Angebot » Themenansicht

Autor Thread - Seiten: -1-
000
17.01.2017, 11:53 Uhr
Buebchen



@Alwin
Hallo Silvio!
Bei dem Programm von Dir das Du auf dem Modul drauf hast, funktionieren da für die RAM-Disk die Klammeraffen Befehle von Brosig?
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
17.01.2017, 11:54 Uhr
Deff

Avatar von Deff

Klassischer Fall für eine PN!

Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
17.01.2017, 12:00 Uhr
Buebchen



@Deff
Hallo!
Da noch andere diese Leiterplatte benutzen wollen, besteht bei Ihnen auch eventuell Informationsbedarf.
Fotos des aufgebauten Moduls 30.01.2012, ist mit den für beide Varianten gültigen Start und Ansprungadressen auf meiner Homepage zu finden.
Um die USB-Schnittstelle und die Präzitronic kompatible RAM-Disk zu testen ist das Modul sehr gut geeignet. Ich habe allerdings keine mehr, falls das als Werbung aufgefasst wird. Aber die Schaltung ist dort zu finden und mit drei Schaltkreisen (74LS00, 74LS02 und 74LS08) außer PIO, EPROM und Adresscomparator leicht auf eine Pünktchenleiterplatte aufzubauen.
Wolfgang

Dieser Beitrag wurde am 17.01.2017 um 12:06 Uhr von Buebchen editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
17.01.2017, 12:04 Uhr
Deff

Avatar von Deff

Du hast aber explizit Alwin angefunkt und eben nicht alle, ergo, ist das Quark, was Du da Begründung nennst!
Ingo
--
Die Politik ist ein Versuch der Politiker, zusammen mit dem Volk mit den Problemen fertig zu werden, die das Volk ohne die Politiker niemals gehabt hätte. (Dieter Hildebrandt)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
17.01.2017, 12:13 Uhr
Buebchen



@Deff
Hallo!
Du hast es doch auch gelesen.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
17.01.2017, 12:16 Uhr
felge1966

Avatar von felge1966

@buebchen

auf den Bildern des fertigen Moduls vom 30.01.2012 ist die neulich erwähnte Datenbusvertauschung D0 / D1 nicht drauf. Ist das richtig oder habe ich die nur übersehen?

http://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=14109

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
17.01.2017, 12:37 Uhr
Buebchen



@felge 1966
Hallo Jörg!
Auf den beiden Leiterplatten aus dem Angbot ist kein Leiterzug vertauscht. Das habe ich mit einer anderen Leiterplatte verwechselt. Diese Leiterplatten habe ich aber inzwischen alle entsorgt. Wegen der Vertauschung ( oder der nicht bestehenden auf Deiner Leiterpatte) habe ich Dir aber eine Mail geschickt.
Bitte die Seite auf meiner Homepage bis ganz runter scrollen. Es sind überall gemeinsam gültige Informationen zu finden.
Alle Bilder sind durch anklicken vergrößerbar.
Heute, im laufe des Tages kann ich warscheinllich schon etwas zur Funktion schreiben. Jetzt mache ich Mittagspause.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
17.01.2017, 13:07 Uhr
felge1966

Avatar von felge1966

@buebchen

bei den Leiterplatten 01/2012 und 11/2012 gibt es bei DB0 und DB1 schon eine Vertauschung. Die Platine von 11/2012 hat richtigerweise DB0 auf C7 und DB1 auf A7 und bei der Platine von 01/2012 ist es genau anders herum. Daher meine Frage zur Vertauschung. Ich habe die Orientierung der DB0 und DB1 vom Eprom Sockel übernommen.

Ist ja auch kein Problem, es muß halt nur beim Aufbau beachtet werden.

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
17.01.2017, 14:12 Uhr
Buebchen



@felge1966
Hallo Jörg!
Die Leiterplatte vom 30.01.2012 hat die Vertauschung, die vom 13.11.2012 ist berichtigt.
Vom Steckverbinder der Leiterplatte vom 30.01.2012 zur ersten Durchkontaktierung jeweils auftrennen und in den Durchkontaktierungen die Verbindungen zum Steckverbinder mit Drähtchen machen. Ich habe eine Leiterplattenabbildung mit den gekennzeichneten Durchkontaktierungen auf meine Homepage gestellt.
Wolfgang

Dieser Beitrag wurde am 17.01.2017 um 14:55 Uhr von Buebchen editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
18.01.2017, 16:37 Uhr
Buebchen



@felge1966
Hallo Jörg!
Das Modul funktioniert jetzt.
Die Software lässt sich durch j DF00 umladen und es meldet sich DVU bereit. Das Modul USB4Pre werde ich anschliessend testen. Das sollte ja jetzt wo die Software geladen ist funktionieren. Ein Problem bestand noch in der Jumperstellung auf dem Z1013-128. Jetzt steckt Jp. 6 auf 1-2, Jp. 8 auf 2-3, Jp. 9 auf 2-3, Jp. 11 auf 1-2, Jp. 17 auf 2-3, jp. 18 auf 2-3, Jp. 19 auf 1-2. Auf Jp 14 steckt nichts. Vorher war der Speicherbereich von DF00 scheinbar nicht ansprechbar. das Problem, das bei Spielen die Meldung RAM voll kam mag auch an einem falsch gesteckten Jumper gelegen haben.
Das PRD-Modul mit der Präzitronic kompatiblen RAM-Disk verhält sich beim stecken unauffällig. Das heist, sie stört den Betrieb des Computers nicht. Noch habe ich aber nicht geschafft die Software dafür zu installieren und das RAM-Testprogramm laufen zu lassen. Ich brauchte das SCP. Habe aber noch kein Color BWS betriebsfähig. Über die PIO des PRD Moduls, also über USB, werde ich versuchen Software auf den Computer zu bringen. Muß aber erst noch die Adressen einstellen und sehen wo ich an ein SCP komme, das ohne BWS läuft. Auf Volkers Homepage habe ich noch nichts gefunden. Wie ich das SCP dann auf den Computer bekomme habe ich auch noch zu ergründen.
Die Unterlagen zur Leiterplatte aus dem Angebot setze ich dann auf meine Homepage. Die Schaltung ist unwesentlich verändert. Damit wird das /MEMDI Signal nur noch beim ansprechen des Eproms erzeugt. Bei abgeschalteten Eprom ist das Modul für den Computer nicht mehr existent.
Bei der anderen Leiterplattenvariante die Silvio verwendet hat war das schon gegeben.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
18.01.2017, 17:22 Uhr
Creep



Ahh, noch einen Leiterzug auf der Bestückungsseite unter dem '02 auftrennen. Und ausgerechnet jetzt hab ich entgegen meiner Gewohnheit den Chip mal ohne Fassung eingelötet. Egal, '02er könnte ich noch genug haben, den schneide ich dann einfach raus...

Rene
--
- Privatnachrichten bitte per Email. Mein Postfach ist immer knapp vor Überlauf -
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
18.01.2017, 18:55 Uhr
Lötspitze




Zitat:
Buebchen schrieb
das Problem, das bei Spielen die Meldung RAM voll kam mag auch an einem falsch gesteckten Jumper gelegen haben.


Nein, hat es nicht. Die Programme waren definitiv zu lang und hätten das DVU2 überschrieben. Das meckert das DVU an.

VG Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
18.01.2017, 19:35 Uhr
Lötspitze




Zitat:
Buebchen schrieb
Jp. 6 auf 1-2, Jp. 8 auf 2-3, Jp. 9 auf 2-3, Jp. 11 auf 1-2, Jp. 17 auf 2-3, jp. 18 auf 2-3, Jp. 19 auf 1-2. Auf Jp 14 steckt nichts.


Ich versuche den Zustand des Rechners mal anhand der Doku "Jumperbeschreibung" und dem Schaltplan des Z1013-128 zu erläutern:

JP6 auf 1-2 =64k-high ist generell abgeschalten; damit JP19 funktionslos
JP8 auf 2-3 =nach RESET ist der 32k-Eprom aktiv (ohne Abschaltung kein RAM ab 8000h!)
JP9 auf 2-3 =interner BWS und Monitor-ROM aktiv nach RESET
JP11 auf 1-2 =32k-Eprom aktivierbar mit JP8
JP17 auf 2-3 =IBM-Zeichensatz aktivierbar mit JP18
JP18 auf 2-3 =IBM Zeichensatz ist aktiviert nach RESET (ist das gewollt?)
JP19 auf 1-2 =64k-high aktivierbar mit JP6 (unrelevant, da JP6 1-2)
JP14 offen =zweite 4k-Monitorebene aktiv (warum funktioniert die erste nicht, d.h. auf 1-2?)

VG Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
18.01.2017, 19:40 Uhr
Alwin

Avatar von Alwin

JP14 offen, weil er den Brosig Monitor verwendet, 2.02 wird sicher auch funktionieren
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
18.01.2017, 19:58 Uhr
Lötspitze



Stimmt, stand ja auch irgendwo.
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Flohmarkt ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek