Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » A5120 mit 16 Bit Erweiterung Z8001 » Themenansicht

Autor Thread - Seiten: -1-
000
29.04.2019, 10:29 Uhr
MGK



Hallo,

Nachdem es mir nach einer recht aufwändigen Instandsetzung eines weiteren A5120 nun gelungen ist, zumindest die defekten U2164 auf der 256k-Platine zu ermitteln und zu tauschen, suche ich ein UDOS mit dem Monitorprogramm für den 5120 um auch den 16-Bit Rechner testen zu können. Auf der Speicherplatine habe ich tatsächlich alle Speicher-ICs auslöten und anschließend im EC1834 testen müssen. Dafür habe ich jetzt zumindest die Gewissheit, dass der Speicher fehlerfrei ist. Auch sind jetzt alles Speicher-IC gesockelt.
Bei Holm auf dem Server liegt zwar das komplette MUTOS für den A5120, aber um es zu starten wird wohl auch das passende UDOS-Bootmedium gebraucht. Genau danach bin ich momentan auf der Suche. Hat jemand vielleicht ein passendes System für mich und könnte mir das bitte als Image oder Diskette zur Verfügung stellen?
Ein Test des Speichers mittels ramd256.com will momentan auch noch nicht recht funktionieren. Es erscheint zwar die Ausschrift RAM-Disk on E: aber danach friert der Rechner ein.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
29.04.2019, 11:09 Uhr
MichaRa



Hallo, der Speicher muss mit ramd256 funktionieren! Wenn nicht, ist da noch ein Fehler. Ich hab die UDOS Boot Disk...bin aber voraussichtlich erst in 14 Tagen wieder zu hause...ich könnte eine Kopie machen und dir zusenden.

Grüße Micha

Dieser Beitrag wurde am 29.04.2019 um 11:10 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
29.04.2019, 11:33 Uhr
MGK



Hallo

und Danke, die 14 Tage warte ich gern auf die Kopie. Für den Aufwand würde ich selbstverständlich auch aufkommen. Ich bastle gefühlt schon ewig an dem Rechner herum. Einen nächsten Speichertest will ich mal mit CPA durchführen. Da ist ja eigentlich nur in der bios.mac eine 0 gegen ein 1 zu tauschen, um den 256k-Speicher zu unterstützen...
Denn ob meine ramd256k.com selbst fehlerfrei ist, weiß ich leider auch nicht. Die RAMs selbst kann ich mittlerweile als Fehler ausschließen. Die Signale an den Adressleitungen, RAS, CAS, usw. sehen auf dem Oszi eigentlich auch brauchbar aus. Eventuell doch noch ein Logikproblem.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
29.04.2019, 20:03 Uhr
sebastian czech

Avatar von sebastian czech

Interessantes Thema!

@Micha: Hast Du die Disk als Image oder nur physich? Hatte nämlich mit Rüdiger in Garitz auch noch mal über dieses Thema gesprochen. Leider fehlt es mir gänzlich an Medien und seine waren wohl 8->5,25" Konvertierungen ohne Funktionsgarantie.

Grüße
sebastian
--
biete 3-Raum-Computer 96m², Dusche, WC, Zentralheizung, Ferritkerngrill...(nicht ganz) ruhige Wohnlage....zum Zeitwert...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
29.04.2019, 20:52 Uhr
MichaRa



Die beiden MUTOS Disks hab ich als Teledisk Image, die UDOS Bootdisk lässt sich ja nur physisch kopieren, so jedenfalls mein Kenntnisstand. Ich hab das alles aber vor vielen Jahren auch mal von Rüdiger bekommen. Jedenfalls kann ich damit auf meiner 16 Bit Erweiterung MUTOS starten.

Ich mache gerne Kopien davon! Hab mich damals auch sehr gefreut das ich die bekommen habe.

Grüße Micha

Dieser Beitrag wurde am 29.04.2019 um 20:52 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
29.04.2019, 21:22 Uhr
holm

Avatar von holm

Ich würde mich mal als Interessent für eine Kopie der UDOS Bootdisk anmelden wollen, hier steht auch so ein Ding..

Da die Doku die Anteuerung der Speicherkarte her gibt, könnte ich auch mal versuchen ambrosius Ramtest-Programm entsprechend aufzublasen...Ralph hat seine erweiterungen ja leider nicht als Source zur Verfügung gestellt.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
30.04.2019, 08:00 Uhr
MGK



Hallo Holm,

das mit dem Speichertest ist eine gute Idee, dürfte nur nicht ganz soo einfach werden. Ich schlage mich selbst gerade mit der Logik herum, die den abwechslenden Zugriff aus der 8- oder 16-Bit-Welt steuert. Da gilt es neben der PIO, unter anderem auch einen 7489-TTL-RAM richtig zu initialisieren, der eine Art Seitenzugriff und Schreibschutz für den RAM organisiert.
Ich hatte mich dann, wie schon erwähnt, für das komplette Auslöten des RAMs entschieden. Da bleiben zumindest dort keine Zweifel mehr. Auch die rote Paritäts-LED ist nicht unbedingt eine Hilfe bei der Fehlersuche. Die zeigt nur an, DAS man einen Speicherfehler hat, aber nicht wo.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
30.04.2019, 08:07 Uhr
MichaRa



Wenn ich wieder zu hause bin schmeiße ich den 8924 an und kopiere die UDOS Disk. Ich hoffe ich vergesse das bis dahin nicht... Drei Disketten hab noch.

Auf meiner 16Bit Erweiterung war einiges defekt...die RAMs musste ich eh alle auslöten, da ich nur die 64K Variante hatte und auf 256K aufgerüstet habe.

Grüße Micha

Dieser Beitrag wurde am 30.04.2019 um 08:11 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
30.04.2019, 09:03 Uhr
DL




Zitat:
MichaRa schrieb
... die UDOS Bootdisk lässt sich ja nur physisch kopieren, so jedenfalls mein Kenntnisstand. ...


Testweise hatte ich mal ein paar Disketten von einem UDOS 1526 mit so einem KryoFlux Diskdumper kopiert, das ging klaglos - mit Teledisk und CopyQM war da nix zu machen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
30.04.2019, 09:33 Uhr
MGK



Ob sich eine Diskette mit teledisk kopieren lässt, hängt mE. nach ganz schwer vom verwendeten Floppycontroller ab. So kann ich z.B. mit einem alten Controller mit ACER-Chip im alten 486er nahezu alles kopieren, wo andere Controller scheitern. Die Bootdisketten vom 7100 sind so ein Beispiel, wo es einen Wechsel in der Formatierung der Boot- zu den Datenspuren gibt. UDOS konnte ich leider noch nicht testen, denn die suche ich ja gerade…

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
30.04.2019, 09:36 Uhr
felge1966

Avatar von felge1966

@Dl
das könte mit dem Format von UDOS zusammenhängen, denn die meisten FDCs haben mit 128Byte Sektoren ihre Probleme und UDOS1526 hatte da eine Parametrierung mit 128byte * 26 Sectoren für die Floppy.

Gruß Jörg

Dieser Beitrag wurde am 30.04.2019 um 09:37 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
30.04.2019, 09:52 Uhr
holm

Avatar von holm

Guckt doch mal ob sich die Udos Disketten mit "format cpa" unter CP/A kopieren lassen (Formatieren einer Disk mit Quelle), man muß halt nur das physische Format entsprechend einstellen.
Gebrauchte Disketten habe ich ausreichend, könnte Dir MichaRa ggf. mal eine Schachtel zukommen lassen.

Gruß,
Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 30.04.2019 um 09:53 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
30.04.2019, 09:58 Uhr
volkerp
Default Group and Edit
Avatar von volkerp


Zitat:
MGK schrieb
Ob sich eine Diskette mit teledisk kopieren lässt, hängt mE. nach ganz schwer vom verwendeten Floppycontroller ab. UDOS konnte ich leider noch nicht testen, denn die suche ich ja gerade



Hallo Micha, UDOS verwendet Sektoren zu 134 Byte. Das kennt teledisk nicht.
Mit catweasel und mit kryoflux können UDOS-Disketten kopiert werden; aus den catweasel-Dumps (im dmk-Format) können auch die Daten extrahiert werden.
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)

Dieser Beitrag wurde am 30.04.2019 um 11:30 Uhr von volkerp editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
30.04.2019, 10:37 Uhr
felge1966

Avatar von felge1966


Zitat:
UDOS verwendet Sektoren zu 132 Byte



Im Format von CPA wurden allerdings damals die 26*128 eingestellt und vom UDOS gelesen. Ist da noch ein Block, der da ignoriert wurde?
Die 128*26 hatten wir als Tauschformat zwischen UDOS und CPA genutzt.

Gruß Jörg

Dieser Beitrag wurde am 30.04.2019 um 10:38 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
30.04.2019, 10:38 Uhr
Jens Krause



Hallo MUTOS Interessierte

Ein paar Anmerkungen, Hinweise, Fragen von mir dazu.

Das "Problem" bei UDOS 3.x, 4.x sind die 3 zusätzlichen Wörter für die Abspeicherung von Zeigern auf den vorherigen und folgenden Block und dem CRC, daher ist die Blockgröße im Minimum 134 Bytes .. damit scheitern die modernen Floppycontroller ..

SuperCard pro oder KryoFlux sind die sichersten Kopiermethoden ausserhalb der Originalhardware.

Unter UDOS 5 konnte neben dem moderneren DDOS (Abspeicherung der Zeiger nicht am Sektor sondern in einer extra Datei) auch der alte Treiber ZDOS zum lesen der UDOS Disks < 5.x aktiviert werden .. leider ist mir damit (noch) nicht gelungen Daten zu lesen .. Hat jemand damit Erfolg gehabt .. und wenn ja, wie?

Es existieren (soweit erkannt) zwei Versionen der UDOS-MUTOS Treibersoftware. Die eine ist die MU50 die unter UDOS geladen wird und 8" und 5" Disketten in SD einseitig lesen kann und die andere, die eine Erweiterung der Diskformate auf DD hat. Damit sind dann 128Byte oder 512Byte per sector, 40 oder 77 Spuren, FM oder MFM lesbar .. einseitig.

Mit dem UDOS Programm load16 wird der MUTOS Kernel (meist als Datei "mutos" auf der UDOS Diskette) in die EM geladen und dort dann der kern gestartet. Das MU50 hat dann "nur" die Konsolen ein/ausgabe, den Diskettenzugriff und die serielle Kommunikation zu regeln.

Bisherige Probleme treten meisst mit der ROOT Diskette auf .. wohl dem Problem geschuldet, das auf der ROOT Diskette ein fester Bereich als SWAP reserviert sein muß, dessen Größe und Position aber im MUTOS-Kernel fest kodiert ist .. stimmt das nicht überein, überschreibt das Beschreiben des SWAP Bereiches durch den MUTOS-Kern Teile des Filesystems.

Diskussionsansätze .. keine 100%ige Richtigkeit garantiert.

VG Jens


Zitat:
felge1966 schrieb
@Dl
das könte mit dem Format von UDOS zusammenhängen, denn die meisten FDCs haben mit 128Byte Sektoren ihre Probleme und UDOS1526 hatte da eine Parametrierung mit 128byte * 26 Sectoren für die Floppy.

Gruß Jörg


Dieser Beitrag wurde am 30.04.2019 um 10:39 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
02.05.2019, 21:03 Uhr
sebastian czech

Avatar von sebastian czech

Hallo Jens.
Vielen Dank für die Details bzgl. des File-System write problems. Wußte bisher nicht, was da im Detail passiert.

ciao
seba
--
biete 3-Raum-Computer 96m², Dusche, WC, Zentralheizung, Ferritkerngrill...(nicht ganz) ruhige Wohnlage....zum Zeitwert...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
08.05.2019, 07:59 Uhr
MGK



Hallo,

kurzes Update meinerseits: Die Erweiterung läuft jetzt sowohl mit ramd256.com als auch mit einem eigens erstellten CPA. Defekt war eigentlich nur ein K555LA4. Hier hat sich wieder die Methode bewährt, zu allererst an allen Kxxx-Schaltkreisen auf korrekte Pegel an den Ausgängen zu testen.
Gibt es eigentlich noch eine andere Möglichkeit die 16bit CPU zu testen außer unter UDOS? Denn auf das UDOS warte ich ja noch ganz gespannt.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
08.05.2019, 08:27 Uhr
MichaRa



Perfekt! Micha

der euch nicht vergessen hat...komme voraussichtlich am Fr nach Hause.

Dieser Beitrag wurde am 08.05.2019 um 08:28 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
21.05.2019, 19:02 Uhr
holm

Avatar von holm

...die Diskette ist angekommen, hab Dank!

Werde mal was zusammenstecken und der auf den Zahn fühlen...

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
21.05.2019, 21:58 Uhr
MichaRa



Ja, mach mal. Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
27.05.2019, 09:21 Uhr
MGK



Hallo,

nachdem ich nun dankenswerterweise das UDOS bekommen habe, komme ich leider trotzdem mit dem 16bit-Modus nicht weiter. Nachdem die Aufforderung zum Einlegen der Root-Diskette kommt und ich dann mit Leertaste bestätige, ist der Rechner fest und die gelbe LED auf der CPU aus. Floppy-LED geht auch nicht an.
Die Z8000-CPU selbst habe ich schon gewechselt, Bustreiber und Logik-IC auf der Platine so weit wie möglich geprüft. Langsam gehen mir die Ideen aus…

Der 8Bit-Modus mit der ramd256.com läuft einwandfrei. Könnte es noch an der Einbaureihenfolge der Platinen liegen? Bei mir von links nach rechts: ATS,ZE16,EM256,ZRE,ABS,AFS,OPS Wie habt Ihr Eure eingebaut? Können es noch falsch gesetzte Wickelbrücken sein?

Holm, hast Du es zum Laufen bekommen?

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
27.05.2019, 13:21 Uhr
MichaRa



Links –> Rechts K8924

OPS,AFS,ASS,ZRE,ZE16,EM256,ABS...+ weitere Karten.

Bei mir war damals, neben der CPU, auch noch einiges defekt. Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
27.05.2019, 13:53 Uhr
felge1966

Avatar von felge1966

Kam es nicht auch genau auf die beiden Steckplätze an?
Die Rückverdrahtung hat doch im Koppelbus zwei verbundene Steckplätze, die genau für solche Doppelkarten angelegt waren. Das dürfte aber auch in der Doku der Karten stehen.

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
27.05.2019, 14:05 Uhr
MGK



Ich glaube nicht, dass es am Koppelbus liegt. Das einzige Signal was da überhaupt von der Erweiterung benutzt wird, ist das MDI/MDO.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
28.05.2019, 08:28 Uhr
MGK



Hallo,
einen kleinen Fortschritt mit der 16Bit-CPU habe ich, aber der verwirrt jetzt mehr als er nützt.

Die 16Bit-CPU blieb bisher stumm. Keine Statussignale, absolut nix los auf dem Bus. Der RESET der CPU hing praktisch in der Luft. Ist im Schaltplan aber auch so dargestellt, kann aber nicht richtig sein. Jetzt habe ich den RESET-Ausgang Pin14 vom 8127 mit Pin16 RESET der CPU verbunden. RESET und Takt sehen jetzt auf dem Oszi auch gut aus.

Wie muss denn das richtig gewickelt sein? Wo muss die CPU Ihren RESET herbekommen? Denn jetzt habe ich ein neues Phänomen:

Das „LOAD16 mutos“ lief bisher problemlos durch und die grüne LED blinkte dabei. Jetzt bleibt es mit der Ausschrift „FF“ stehen (siehe Bild) und wartet auf eine Eingabe. Eingeben kann ich auch beliebige Zeichen, die auch auf dem Bildschirm erscheinen, aber es geht nicht weiter. Bis zur Aufforderung die Root-Diskette einzulegen, komme ich nicht mehr.

Gruß,
Micha

Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
28.05.2019, 12:20 Uhr
Jens Krause



Hi Micha

also nur LOAD16 mutos reicht nicht zum starten des MUTOS.

Es gibt eine TASANP (vermutlich zur Umschaltung Groß- und Kleinschreibung), dann muss der MU50/MU51 MUTOS Unterstützungsterminal unter UDOS geladen und noch ein wenig Diskettenkonfiguration durchgeführt werden.

Meine start-batch datei sieht so aus

LOAD16 mutos
TASANP
SET DISKCON=5 5 5 8
F MU51,
B
ECHO insert root on drive 2, type "space" when ready
PAUSE;X 9000


mit X 9000 wird er Mutos/Udos teil (MU51) angesprungen und gestarter (F MU51 lädt den nur ohne ihn zu starten. Dieser MU51 initiallisiert die Kommunikation zum ZRE16 mittels Interrupts und Interruptbehandlung in beiden Richtungen, bereitet den Diskettenzugriff unter MUTOS vor startet dann softwareseitig den U8000 .. daher gibt es keinen Hardware Reset für Mutos8000 (denke ich)

Gruß Jens
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
28.05.2019, 12:43 Uhr
MGK



Hallo Jens,

Danke für den Hinweis, aber dass das zum Starten nicht ausreicht ist mir klar. Die Batch-Dateien sind zum Glück auch mit auf Michas Diskette gewesen. Was ich meine ist, dass ich mit "stillstehender", weil im Dauer-RESET befindlichen Z8001, bis zur Meldung zum Einlegen der Root-Diskette komme.
Ist der RESET normal gewickelt ist halt beim LOAD16 Schluss.
Kann man ja auch ohne die Batch-Datei machen, da nur die Datei hinter dem LOAD16 ja in den RAM geladen wird.
Ich vermute, ich habe ein Problem mit einigen falsch oder gar nicht gesetzen Wickelbücken. Wäre es eventuell möglich, ein Bild von einer 16Bit CPU-Platine zu bekommen, auf der ich die korrekte Bewickelung sehen könnte?

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
28.05.2019, 13:12 Uhr
Jens Krause



Hallo Micha,

der vielleicht interessierende Teil:



Gruß Jens

P.S. Auf nachdrücklichen Wunsch versuche ich auch die Brücken nachzuverfolgen ;-)

Dieser Beitrag wurde am 28.05.2019 um 13:13 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
28.05.2019, 13:16 Uhr
Jens Krause




Zitat:
MGK schrieb

Ist der RESET normal gewickelt ist halt beim LOAD16 Schluss.




Das meinte ich .. wird der Kern standalone ohne die UDOS Programme gestartet weiß er ja nicht zu kommunizieren wenn er selbsttätig losläuft. Daher wird der U8000 erst durch einen E/A Befehl vom MU51 gestartet

Dieser Beitrag wurde am 28.05.2019 um 13:20 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
28.05.2019, 13:19 Uhr
MGK



Hallo Jens,


vielen Dank, das hilft mir wirklich, wirklich sehr weiter. Ich entdecke sofort eine Wickelbrücke die bei mir fehlt (X13:3 4). Ich vermutete das schon, da diese die STB-Signale an die 8212-Bustreiber (Statusregister) bringt. Ohne diese weiß der 8-Bit Teil nicht was der 16-Bit gerade tut.
Ich werde das heute Abend mal testen und berichten.

Danke und Gruß
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
030
28.05.2019, 18:53 Uhr
MGK



Hallo,

die Wickelbrücken waren in der Tat das wesentliche Problem. Jetzt gibt es die ersten wirklichen Lebenszeichen des 16bit-Teils.
Nur hänge ich nun schon wieder fest. Ich habe als ROOT-Diskette die von Holms Server genommen. Habe auch unterschiedliche Laufwerkskonfigurationen per diskcon durchprobiert, der MUTOS-Kernel quittiert mir das maximal mit "panic".
Ich schäme mich, schon wieder zu betteln, aber hätte jemand von Euch biite noch ein Image einer ROOT-Diskette aus einer funktionierenden Inststallation für mich? Diese sollten doch im Gegensatz zum UDOS auch als TD0 funktionieren.

Gruß,
Micha

Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
031
29.05.2019, 11:56 Uhr
Jens Krause




Zitat:

Ich schäme mich, schon wieder zu betteln, aber hätte jemand von Euch biite noch ein Image einer ROOT-Diskette aus einer funktionierenden Inststallation für mich? Diese sollten doch im Gegensatz zum UDOS auch als TD0 funktionieren.



Du musst Dich nicht schämen .. hast Post .. hoffentlich

VG Jens
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
032
05.06.2019, 17:03 Uhr
MGK



Hallo,

an dieser Stelle nochmal ein großer Dank an MichaRa und Jens, ohne deren Hilfe ich es nicht zum Laufen bekommen hätte. Jetzt aber läuft das MUTOS auf dem 5120 endlich.

Gruß,
Micha

Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
033
05.06.2019, 18:03 Uhr
felge1966

Avatar von felge1966

Dann mal Gratulation zur erfolgreichen Inbetriebnahme.
Aber mal andere Fragge, was kann man unter Mutos eigentlich damit machen?

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
034
05.06.2019, 18:32 Uhr
MGK



Hallo,

ist eigentlich mehr der Spieltrieb das halt wieder zum Laufen zu bekommen. War auch allerhand kaputt auf den Platinen.
Mit einem modernen UNIX/Linux-System ist das natürlich nicht zu vergleichen. Ich habe aber immerhin auch einen C-Complier mit dazu und das ist der nächste Punkt, den zum Laufen zu bringen, bzw. mal zu testen was überhaupt geht.
Bei uns in der Firma läuft das ERP-System schon lange Zeit unter linux, daher bin ich nicht total unerfahren mit UNIX-artigen Systemen (habe mal mit XENIX begonnen).

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
035
05.06.2019, 18:38 Uhr
holm

Avatar von holm

Ich habe mit Holger (ambrosius) heute mal ein Bisschen gespielt:






Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 05.06.2019 um 18:39 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
036
05.06.2019, 18:47 Uhr
MGK



Dann können wir doch ein 5120-Netzwerk per uucp einrichten...
Aber das war glaube ich erst beim MUTOS 7150 mit dabei.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
037
05.06.2019, 19:34 Uhr
holm

Avatar von holm

Das ist nur der Singleuser-Modus, für uucp braucht man Multiuser.

Ich muß erst mal lesen wie man z.B. die CMD Disk mounted oder die C-Compiler Disks und Irgend Jemand schrieb das sich die Dateisysteme wohl selbst zerlegen weil der Kern wohl nicht zu den restlichen Floppies paßt... 1)

Wie kopiert man die Udos Startdiskette?


1) mir ist aufgefallen das Teledisk beim schreiben der CMD und der CC Disks einen Fehler wegen Laufwerk nicht bereit wirft..was natürlich Quatsch ist. Das passierte regelmäßig und wiederholbar beim Zugriff auf Track 77. Wenn ich mir überlege das 8 Zoll Floppies Spuren von 0 bis 76 haben, schwant mir dabei das das eigentlich 8" Images sind...

Gruß,
Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 05.06.2019 um 19:34 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
038
05.06.2019, 19:46 Uhr
Rolly2



Ich habe hier noch einige Archiv-Dateien im ZIP-Format von MUTOS. Wenn Interesse besteht, bitte Mail. Die sind zusammen zirka 2,5 MB groß.

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
039
05.06.2019, 20:29 Uhr
MGK



Hallo Holm,

den multiuser bekommst Du, wenn Du nicht gleich als root einloggst, sondern so ca. 1min wartest. Ist im Prinzip wie beim 7150-Mutos.

Die UDOS-Diskette kopierst Du mit "COPY.DISK 0 TO 1" wobei 0=LW A: 1=LW B: usw. ist. Voher "FORMAT" nicht vergessen, wobei Du Dich hier noch entscheiden musst, ob es mal eine System-Disk werden soll.

Unter MUTOS die CMD-oder CC-Disk mit z.B. "mount /dev/rk1 /mnt" mounten, wobei das rk0-2 wieder die Laufwerke A:-C: sind.

Mit den Images (z.B. die aus dem ronny.rar auf Deinem Server) hast Du wahrscheinlich leider Recht. Dort wo es im Teledisk bis Spur 77 fehlerfrei geht, handelt es sich tatsächlich um ursprüngliche 8"-Disketten, deren Inhalt ich bisher auch nicht brauchbar zu Lesen bekommen habe.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
040
05.06.2019, 21:42 Uhr
MichaRa



Ich hab die zweite Diskette nach /usr gemountet und dann init 2

Micha

Dieser Beitrag wurde am 05.06.2019 um 22:40 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
041
05.06.2019, 22:43 Uhr
holm

Avatar von holm

@rolly2: findest Du meine Mailadresse noch? Mich interessieren die Dateien auf jeden Fall...

Ich werde morgen mal probieren was ich erreichen kann, werd erst mal die Bootdiskette sichern.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
042
06.06.2019, 12:27 Uhr
holm

Avatar von holm


Zitat:
Jens Krause schrieb

Zitat:

Ich schäme mich, schon wieder zu betteln, aber hätte jemand von Euch biite noch ein Image einer ROOT-Diskette aus einer funktionierenden Inststallation für mich? Diese sollten doch im Gegensatz zum UDOS auch als TD0 funktionieren.



Du musst Dich nicht schämen .. hast Post .. hoffentlich

VG Jens



Mal ganz abgesehen davon das ich natürlich auch die root Diskette bzw. das TD0 Image von meinem Server genommen hatte..und das funktioniert..würde mich mal intressieren was Du da noch so hast Jens.
Ich würde das, wenn es denn unterschiedlich ist in ein Jens - Driectory ablegen wenn Du nix dagegen hast.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 06.06.2019 um 12:27 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
043
06.06.2019, 13:29 Uhr
holm

Avatar von holm


Zitat:
felge1966 schrieb
Dann mal Gratulation zur erfolgreichen Inbetriebnahme.
Aber mal andere Fragge, was kann man unter Mutos eigentlich damit machen?

Gruß Jörg



IHMO gabs da keine "wesentlichen" Anwendungen, aber ein C-Compiler ist dabei.
Das Ganze ist im Wesentlichen eine Studie denke ich und kann als Werkzeug zur Programmentwicklung für U8000 dienen..das war wohl der Zweck.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
044
07.06.2019, 18:50 Uhr
Bert



Was bräuchte man, um einen 'normalen' A5120 zur 16-Bit-Version aufzurüsten?
Eine U8001-CPU-Karte und eine 256k-Speicherkarte, oder?
Gibt es Unterlagen zu den beiden Karten?

Grüße,
Bert
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
045
07.06.2019, 19:58 Uhr
Jens Krause



Hallo Bert,

prinzipiell (vom K1520 Standard her ja) .. aber ..

Wenn der A5120 normal konfiguriert ist ist aber der 5er Rahmen im normalen BC mit OPS, AFS, ASS, ZRE, ABS vollbestückt und damit nicht erweiterbar.

dazu brauch man den A5120.16 mit dem 11er Rahmen oder einen K8924.

ansonsten braucht man ein lauffähiges UDOS und am besten 1.2 oder 1.4er Laufwerke .. oder 8 Zoll ;-) mit passender AFS.

Gruß Jens

P.S. sehr gute Unterlagen Sammlung bei Hlm auf dem Server


Zitat:
Bert schrieb
Was bräuchte man, um einen 'normalen' A5120 zur 16-Bit-Version aufzurüsten?
Eine U8001-CPU-Karte und eine 256k-Speicherkarte, oder?
Gibt es Unterlagen zu den beiden Karten?

Grüße,
Bert

Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
046
07.06.2019, 20:14 Uhr
holm

Avatar von holm

A5120 gabs mit 11er und später mit 7er Rahmen, nie mit 5er,die waren nur in den K891x.
Die Steckplätze wurden weniger als von 4x 16 DRAM auf 1x 64K DRAM umgestellt wurde.

BTW: Rolly2 hat mir sein Mutos.zip geschickt, es enthält Mutos für den A7150, also die 8086 Variante.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
047
07.06.2019, 20:19 Uhr
Rolly2



Da hat Holm recht, ich kenne nur A5120 mit 7er und 11er Rahmen. Für die .16er-Version benötigt man nur die beiden genannten Karten und die beiden Verbindungskabel. Und natürlich die SW.

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
048
07.06.2019, 20:22 Uhr
Jens Krause



Mea maxima culpa .. etwas mit ungerade ;-)


Zitat:
Rolly2 schrieb
Da hat Holm recht, ich kenne nur A5120 mit 7er und 11er Rahmen. Für die .16er-Version benötigt man nur die beiden genannten Karten und die beiden Verbindungskabel. Und natürlich die SW.

VG, Andreas


Dieser Beitrag wurde am 07.06.2019 um 20:23 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
049
07.06.2019, 20:37 Uhr
Rolly2



Was soll das jetzt? Ein 7er würden ausreichen. Fühlst Du dich angegriffen?

VG
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
050
07.06.2019, 20:53 Uhr
Jens Krause




Zitat:
Rolly2 schrieb
Was soll das jetzt? Ein 7er würden ausreichen. Fühlst Du dich angegriffen?

VG



Wiki: mea culpa - Gelegentlich wird der Ausdruck allgemein für eine weitreichende oder bedeutungsvolle Vergebungsbitte verwendet.

Ich lese da nix mit Angriff. Lass bitte mal Deine Goldwaage kalibrieren.

Ich bin da mal raus.

Jens
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
051
07.06.2019, 21:37 Uhr
Rolly2



Gelegentlich nach Wikipedia? Ohne das geht es nicht mehr. Wir reden Deutsch und das vernünftig und brauchen kein Wiki!!

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
052
07.06.2019, 22:25 Uhr
MGK



Hallo,

von der Bestückung her ist es (fast) völlig Wurscht. Es funktioniern beide Varaianten:

OPS,AFS,ASS,ZRE,ZE16,EM256,ABS

ASS,ZE16,EM256,ZRE,ABS,AFS,OPS

auch im 7er Rahmen absolut kein Problem, solange die IEI-IEO-Kette passt.

habe ich ausprobiert.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
053
07.06.2019, 23:15 Uhr
holm

Avatar von holm


Zitat:
Jens Krause schrieb


Ich bin da mal raus.

Jens



.und wozu soll das jetzt gut sein?

Meine Frage oben wolltest Du wohl nicht beantworten?

Gruß,
Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
054
08.06.2019, 09:33 Uhr
MichaRa



Ich hab dir meine root und cmd Disk mal zugemailt...kann aber sein das ich das schon mal gemacht habe. Micha
Dieser Beitrag wurde am 08.06.2019 um 09:40 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
055
08.06.2019, 12:10 Uhr
holm

Avatar von holm

..hab ich mit auf die Halde geräumt, Robotron/K1520/A5120_16/MUTOS...

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
056
09.06.2019, 14:05 Uhr
kaiOr

Avatar von kaiOr

Die Abbilder unter "michara" sind inhaltl. identisch zu denen im Hauptordner.
Die Abbilder unter "ronny" sind irgendwie völlig schräg ausgelesen (in 128Byte Teilstücken völlig neu verkettet und auch noch partiell rotiert). Durch nen verstellten Interleave lässt sich das glaube nicht alleine erklären/zurückdrehen.

Ist die /bin/c_beispiel.c auf DISK_CC1.TD0 beschädigt oder liegt das an meinem WEGA?

Dieser Beitrag wurde am 09.06.2019 um 14:08 Uhr von kaiOr editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
057
10.06.2019, 17:27 Uhr
kaiOr

Avatar von kaiOr

Es scheint nur die /bin/c_beispiel.c zu betreffen, vielleicht ist die aus irgend einem Buch abgeschrieben/reparabel?! Erneut taucht die Meldung "Bdos Err On D: $Bad Sector$Select$File R/O" auch nicht auf. Vermutlich wurde da mal unter SCP oder CP/A versucht auf die Diskette zuzugreifen.... ^^

http://pontacko.tfn-clan.de/files/tmp/mutos.tar
Die symbolischen Links auf der Root-Disk bekomme ich leider nicht mit gesichert.

Mit den Abbildern von Ronny komme ich auch nicht weiter. Die abweichende Dateiinhalte und Ablageorte auf der Diskette machen es schwierig die Abfolge der 128Byte-Segmente innerhalb einer Diskettenspur herrauszufinden um das Ganze geradezuziehen. Möglicherweise hatte das der zugehörige Kernel von der UDOS-Diskette aber auch so drin, zwecks besserer Datenrate/Zugriffszeit.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
058
10.06.2019, 19:17 Uhr
holm

Avatar von holm

Danke das Du 'Dich damit mal auseinander setzt, ich habe dafür noch keine Zeit gehabt.

In dem Zusammenhang sollte man auch mal drüber nachdenken das hier irgendwer gemeldet hatte das sich die Filesysteme der Disketten nach einer Weile von selbst zerlegen, im Zusammenhang mit der vorgefundenen 77 Spur Geschichte und der Ausschrift "SET DISCON=5 5 5 8" gibt mir das zu denken.
Ich hatte mal quer über die Doku gelesen und hatte herausgefunden das das Defaultformat eigentlich 256 Byte Sektoren für die 5er Floppies hat, hier werden aber 26x128 verwendet also 8 Zoll Formate.

Gruß,

Holm
.
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
059
12.06.2019, 15:52 Uhr
Jens Krause




Zitat:
kaiOr schrieb
...
Ist die /bin/c_beispiel.c auf DISK_CC1.TD0 beschädigt oder liegt das an meinem WEGA?
...



Scheinbar gibt es nur diese "Version" der als CC(1/2) gelabelten MUTOS Diskette .. bei allen die ich kenne ist c_beispiel.c zerstückelt.

Vielleicht ein Schutz der Hochtechnologie ;-)

Mit ein wenig Forensik habe ich eine c_beispiel.c zusammengefunden.

Sie sieht soweit "logisch" aus und die Klammerung passt auch .. habe sie aber nicht getestet!! (weder compiliert noch ausgeführt noch mathematisch überprüft).

VG

Dieser Beitrag wurde am 13.06.2019 um 09:02 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek