Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » A5120 mit 16 Bit Erweiterung Z8001 » Themenansicht

Autor Thread - Seiten: -1-
000
29.04.2019, 10:29 Uhr
MGK



Hallo,

Nachdem es mir nach einer recht aufwändigen Instandsetzung eines weiteren A5120 nun gelungen ist, zumindest die defekten U2164 auf der 256k-Platine zu ermitteln und zu tauschen, suche ich ein UDOS mit dem Monitorprogramm für den 5120 um auch den 16-Bit Rechner testen zu können. Auf der Speicherplatine habe ich tatsächlich alle Speicher-ICs auslöten und anschließend im EC1834 testen müssen. Dafür habe ich jetzt zumindest die Gewissheit, dass der Speicher fehlerfrei ist. Auch sind jetzt alles Speicher-IC gesockelt.
Bei Holm auf dem Server liegt zwar das komplette MUTOS für den A5120, aber um es zu starten wird wohl auch das passende UDOS-Bootmedium gebraucht. Genau danach bin ich momentan auf der Suche. Hat jemand vielleicht ein passendes System für mich und könnte mir das bitte als Image oder Diskette zur Verfügung stellen?
Ein Test des Speichers mittels ramd256.com will momentan auch noch nicht recht funktionieren. Es erscheint zwar die Ausschrift RAM-Disk on E: aber danach friert der Rechner ein.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
29.04.2019, 11:09 Uhr
MichaRa



Hallo, der Speicher muss mit ramd256 funktionieren! Wenn nicht, ist da noch ein Fehler. Ich hab die UDOS Boot Disk...bin aber voraussichtlich erst in 14 Tagen wieder zu hause...ich könnte eine Kopie machen und dir zusenden.

Grüße Micha

Dieser Beitrag wurde am 29.04.2019 um 11:10 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
29.04.2019, 11:33 Uhr
MGK



Hallo

und Danke, die 14 Tage warte ich gern auf die Kopie. Für den Aufwand würde ich selbstverständlich auch aufkommen. Ich bastle gefühlt schon ewig an dem Rechner herum. Einen nächsten Speichertest will ich mal mit CPA durchführen. Da ist ja eigentlich nur in der bios.mac eine 0 gegen ein 1 zu tauschen, um den 256k-Speicher zu unterstützen...
Denn ob meine ramd256k.com selbst fehlerfrei ist, weiß ich leider auch nicht. Die RAMs selbst kann ich mittlerweile als Fehler ausschließen. Die Signale an den Adressleitungen, RAS, CAS, usw. sehen auf dem Oszi eigentlich auch brauchbar aus. Eventuell doch noch ein Logikproblem.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
29.04.2019, 20:03 Uhr
sebastian czech

Avatar von sebastian czech

Interessantes Thema!

@Micha: Hast Du die Disk als Image oder nur physich? Hatte nämlich mit Rüdiger in Garitz auch noch mal über dieses Thema gesprochen. Leider fehlt es mir gänzlich an Medien und seine waren wohl 8->5,25" Konvertierungen ohne Funktionsgarantie.

Grüße
sebastian
--
biete 3-Raum-Computer 96m², Dusche, WC, Zentralheizung, Ferritkerngrill...(nicht ganz) ruhige Wohnlage....zum Zeitwert...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
29.04.2019, 20:52 Uhr
MichaRa



Die beiden MUTOS Disks hab ich als Teledisk Image, die UDOS Bootdisk lässt sich ja nur physisch kopieren, so jedenfalls mein Kenntnisstand. Ich hab das alles aber vor vielen Jahren auch mal von Rüdiger bekommen. Jedenfalls kann ich damit auf meiner 16 Bit Erweiterung MUTOS starten.

Ich mache gerne Kopien davon! Hab mich damals auch sehr gefreut das ich die bekommen habe.

Grüße Micha

Dieser Beitrag wurde am 29.04.2019 um 20:52 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
29.04.2019, 21:22 Uhr
holm

Avatar von holm

Ich würde mich mal als Interessent für eine Kopie der UDOS Bootdisk anmelden wollen, hier steht auch so ein Ding..

Da die Doku die Anteuerung der Speicherkarte her gibt, könnte ich auch mal versuchen ambrosius Ramtest-Programm entsprechend aufzublasen...Ralph hat seine erweiterungen ja leider nicht als Source zur Verfügung gestellt.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
30.04.2019, 08:00 Uhr
MGK



Hallo Holm,

das mit dem Speichertest ist eine gute Idee, dürfte nur nicht ganz soo einfach werden. Ich schlage mich selbst gerade mit der Logik herum, die den abwechslenden Zugriff aus der 8- oder 16-Bit-Welt steuert. Da gilt es neben der PIO, unter anderem auch einen 7489-TTL-RAM richtig zu initialisieren, der eine Art Seitenzugriff und Schreibschutz für den RAM organisiert.
Ich hatte mich dann, wie schon erwähnt, für das komplette Auslöten des RAMs entschieden. Da bleiben zumindest dort keine Zweifel mehr. Auch die rote Paritäts-LED ist nicht unbedingt eine Hilfe bei der Fehlersuche. Die zeigt nur an, DAS man einen Speicherfehler hat, aber nicht wo.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
30.04.2019, 08:07 Uhr
MichaRa



Wenn ich wieder zu hause bin schmeiße ich den 8924 an und kopiere die UDOS Disk. Ich hoffe ich vergesse das bis dahin nicht... Drei Disketten hab noch.

Auf meiner 16Bit Erweiterung war einiges defekt...die RAMs musste ich eh alle auslöten, da ich nur die 64K Variante hatte und auf 256K aufgerüstet habe.

Grüße Micha

Dieser Beitrag wurde am 30.04.2019 um 08:11 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
30.04.2019, 09:03 Uhr
DL




Zitat:
MichaRa schrieb
... die UDOS Bootdisk lässt sich ja nur physisch kopieren, so jedenfalls mein Kenntnisstand. ...


Testweise hatte ich mal ein paar Disketten von einem UDOS 1526 mit so einem KryoFlux Diskdumper kopiert, das ging klaglos - mit Teledisk und CopyQM war da nix zu machen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
30.04.2019, 09:33 Uhr
MGK



Ob sich eine Diskette mit teledisk kopieren lässt, hängt mE. nach ganz schwer vom verwendeten Floppycontroller ab. So kann ich z.B. mit einem alten Controller mit ACER-Chip im alten 486er nahezu alles kopieren, wo andere Controller scheitern. Die Bootdisketten vom 7100 sind so ein Beispiel, wo es einen Wechsel in der Formatierung der Boot- zu den Datenspuren gibt. UDOS konnte ich leider noch nicht testen, denn die suche ich ja gerade…

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
30.04.2019, 09:36 Uhr
felge1966

Avatar von felge1966

@Dl
das könte mit dem Format von UDOS zusammenhängen, denn die meisten FDCs haben mit 128Byte Sektoren ihre Probleme und UDOS1526 hatte da eine Parametrierung mit 128byte * 26 Sectoren für die Floppy.

Gruß Jörg

Dieser Beitrag wurde am 30.04.2019 um 09:37 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
30.04.2019, 09:52 Uhr
holm

Avatar von holm

Guckt doch mal ob sich die Udos Disketten mit "format cpa" unter CP/A kopieren lassen (Formatieren einer Disk mit Quelle), man muß halt nur das physische Format entsprechend einstellen.
Gebrauchte Disketten habe ich ausreichend, könnte Dir MichaRa ggf. mal eine Schachtel zukommen lassen.

Gruß,
Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 30.04.2019 um 09:53 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
30.04.2019, 09:58 Uhr
volkerp
Default Group and Edit
Avatar von volkerp


Zitat:
MGK schrieb
Ob sich eine Diskette mit teledisk kopieren lässt, hängt mE. nach ganz schwer vom verwendeten Floppycontroller ab. UDOS konnte ich leider noch nicht testen, denn die suche ich ja gerade



Hallo Micha, UDOS verwendet Sektoren zu 134 Byte. Das kennt teledisk nicht.
Mit catweasel und mit kryoflux können UDOS-Disketten kopiert werden; aus den catweasel-Dumps (im dmk-Format) können auch die Daten extrahiert werden.
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)

Dieser Beitrag wurde am 30.04.2019 um 11:30 Uhr von volkerp editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
30.04.2019, 10:37 Uhr
felge1966

Avatar von felge1966


Zitat:
UDOS verwendet Sektoren zu 132 Byte



Im Format von CPA wurden allerdings damals die 26*128 eingestellt und vom UDOS gelesen. Ist da noch ein Block, der da ignoriert wurde?
Die 128*26 hatten wir als Tauschformat zwischen UDOS und CPA genutzt.

Gruß Jörg

Dieser Beitrag wurde am 30.04.2019 um 10:38 Uhr von felge1966 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
30.04.2019, 10:38 Uhr
Jens Krause



Hallo MUTOS Interessierte

Ein paar Anmerkungen, Hinweise, Fragen von mir dazu.

Das "Problem" bei UDOS 3.x, 4.x sind die 3 zusätzlichen Wörter für die Abspeicherung von Zeigern auf den vorherigen und folgenden Block und dem CRC, daher ist die Blockgröße im Minimum 134 Bytes .. damit scheitern die modernen Floppycontroller ..

SuperCard pro oder KryoFlux sind die sichersten Kopiermethoden ausserhalb der Originalhardware.

Unter UDOS 5 konnte neben dem moderneren DDOS (Abspeicherung der Zeiger nicht am Sektor sondern in einer extra Datei) auch der alte Treiber ZDOS zum lesen der UDOS Disks < 5.x aktiviert werden .. leider ist mir damit (noch) nicht gelungen Daten zu lesen .. Hat jemand damit Erfolg gehabt .. und wenn ja, wie?

Es existieren (soweit erkannt) zwei Versionen der UDOS-MUTOS Treibersoftware. Die eine ist die MU50 die unter UDOS geladen wird und 8" und 5" Disketten in SD einseitig lesen kann und die andere, die eine Erweiterung der Diskformate auf DD hat. Damit sind dann 128Byte oder 512Byte per sector, 40 oder 77 Spuren, FM oder MFM lesbar .. einseitig.

Mit dem UDOS Programm load16 wird der MUTOS Kernel (meist als Datei "mutos" auf der UDOS Diskette) in die EM geladen und dort dann der kern gestartet. Das MU50 hat dann "nur" die Konsolen ein/ausgabe, den Diskettenzugriff und die serielle Kommunikation zu regeln.

Bisherige Probleme treten meisst mit der ROOT Diskette auf .. wohl dem Problem geschuldet, das auf der ROOT Diskette ein fester Bereich als SWAP reserviert sein muß, dessen Größe und Position aber im MUTOS-Kernel fest kodiert ist .. stimmt das nicht überein, überschreibt das Beschreiben des SWAP Bereiches durch den MUTOS-Kern Teile des Filesystems.

Diskussionsansätze .. keine 100%ige Richtigkeit garantiert.

VG Jens


Zitat:
felge1966 schrieb
@Dl
das könte mit dem Format von UDOS zusammenhängen, denn die meisten FDCs haben mit 128Byte Sektoren ihre Probleme und UDOS1526 hatte da eine Parametrierung mit 128byte * 26 Sectoren für die Floppy.

Gruß Jörg


Dieser Beitrag wurde am 30.04.2019 um 10:39 Uhr von Jens Krause editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
02.05.2019, 21:03 Uhr
sebastian czech

Avatar von sebastian czech

Hallo Jens.
Vielen Dank für die Details bzgl. des File-System write problems. Wußte bisher nicht, was da im Detail passiert.

ciao
seba
--
biete 3-Raum-Computer 96m², Dusche, WC, Zentralheizung, Ferritkerngrill...(nicht ganz) ruhige Wohnlage....zum Zeitwert...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
08.05.2019, 07:59 Uhr
MGK



Hallo,

kurzes Update meinerseits: Die Erweiterung läuft jetzt sowohl mit ramd256.com als auch mit einem eigens erstellten CPA. Defekt war eigentlich nur ein K555LA4. Hier hat sich wieder die Methode bewährt, zu allererst an allen Kxxx-Schaltkreisen auf korrekte Pegel an den Ausgängen zu testen.
Gibt es eigentlich noch eine andere Möglichkeit die 16bit CPU zu testen außer unter UDOS? Denn auf das UDOS warte ich ja noch ganz gespannt.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
08.05.2019, 08:27 Uhr
MichaRa



Perfekt! Micha

der euch nicht vergessen hat...komme voraussichtlich am Fr nach Hause.

Dieser Beitrag wurde am 08.05.2019 um 08:28 Uhr von MichaRa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
21.05.2019, 19:02 Uhr
holm

Avatar von holm

...die Diskette ist angekommen, hab Dank!

Werde mal was zusammenstecken und der auf den Zahn fühlen...

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
21.05.2019, 21:58 Uhr
MichaRa



Ja, mach mal. Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
Heute, 09:21 Uhr
MGK



Hallo,

nachdem ich nun dankenswerterweise das UDOS bekommen habe, komme ich leider trotzdem mit dem 16bit-Modus nicht weiter. Nachdem die Aufforderung zum Einlegen der Root-Diskette kommt und ich dann mit Leertaste bestätige, ist der Rechner fest und die gelbe LED auf der CPU aus. Floppy-LED geht auch nicht an.
Die Z8000-CPU selbst habe ich schon gewechselt, Bustreiber und Logik-IC auf der Platine so weit wie möglich geprüft. Langsam gehen mir die Ideen aus…

Der 8Bit-Modus mit der ramd256.com läuft einwandfrei. Könnte es noch an der Einbaureihenfolge der Platinen liegen? Bei mir von links nach rechts: ATS,ZE16,EM256,ZRE,ABS,AFS,OPS Wie habt Ihr Eure eingebaut? Können es noch falsch gesetzte Wickelbrücken sein?

Holm, hast Du es zum Laufen bekommen?

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
Heute, 13:21 Uhr
MichaRa



Links –> Rechts K8924

OPS,AFS,ASS,ZRE,ZE16,EM256,ABS...+ weitere Karten.

Bei mir war damals, neben der CPU, auch noch einiges defekt. Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
Heute, 13:53 Uhr
felge1966

Avatar von felge1966

Kam es nicht auch genau auf die beiden Steckplätze an?
Die Rückverdrahtung hat doch im Koppelbus zwei verbundene Steckplätze, die genau für solche Doppelkarten angelegt waren. Das dürfte aber auch in der Doku der Karten stehen.

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
Heute, 14:05 Uhr
MGK



Ich glaube nicht, dass es am Koppelbus liegt. Das einzige Signal was da überhaupt von der Erweiterung benutzt wird, ist das MDI/MDO.

Gruß,
Micha
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek