Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » K8915 » Themenansicht

Autor Thread - Seiten: -1-
000
06.01.2019, 18:45 Uhr
Rolly2



Vielleicht kann jemand eine Auskunft geben. Welche Version des SCP lief auf dem alten K8915 mit 5 1/4 Laufwerken und einer ZVE K2521? Ich habe einige Versionen des SCP8915 hier, bin mir aber nicht sicher.
Oder hat jemand die Richtige Version für mich.

Vielen Dank und VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
06.01.2019, 21:15 Uhr
DKt



Hallo Andreas,

Du meinst sicher den braunen K8915 mit ZVE K521 und den zwei 5 1/4 Laufwerken K5601?
Dort läuft ein SCPX8915 BIOS 4.4.

Es gibt aber auch eine Zwischenversion K8915, die schon beige ist, aber noch die K2521 hat, aber schon die neue ATS (045-8732). Dann ist es SCPX8915 BIOS 4.7

Viele Grüße und noch alles Gute für 2019, Dirk
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
06.01.2019, 21:33 Uhr
Rolly2



Hallo Dirk, euch alle Wünsche zurück. Danke. Es ist die erst genannte. Die hat die 012-6720 K7028.20 drinnen.
Hast Du diese Versionen, wenn ja, kannst du sie mir zur Verfügung stellen?

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
06.01.2019, 21:47 Uhr
DKt



Hallo Andreas,

Mail ist parallel raus.

Viele Grüße, Dirk
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
08.01.2019, 20:45 Uhr
Rolly2



Hallo an Alle,
macht diese Version an Anfang ebenfalls einen Selbsttest. Oder anders gesagt, wie läuft der Bootvorgang bei der Version mit ZVE K2521 und paralleler Tastatur ab? Eine INT-Prioritätenkette, wie üblich, scheint es da nicht zu geben.

VG, Andreas

PS. Der Bilder-Upload scheint nicht zu funktionieren?
--
wie man denkt, so lebt man!

Dieser Beitrag wurde am 08.01.2019 um 20:50 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
08.01.2019, 22:11 Uhr
holm

Avatar von holm

..die INT-Kette gibts schon, nur ist die nicht auf der ZVE zweigeteilt so das ein "Kreis" entsteht. IMHO liegt /IEI aud dem Bus am Anfang auf Masse.
Das funktioniert exakt genauso wie bei meinem Krzkalla System, Interrupt "normal" und keine DMA, FDC im WAIT Betrieb (anders gewickelt als im BC oder K8924).

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 08.01.2019 um 22:11 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
08.01.2019, 22:18 Uhr
Rolly2



Ah, danke Holm. Genau so ist das hier, am Anfang auf "MASSE". FDC funktioniert, ist anders gewickelt als beim 5120/8924. ZVE auch OK, ABS OK.
Die spezielle 64k-Karte (eine 045-8530) und die ATS kann ich so nicht testen. Na mal sehen, wie es weiter geht. Aber ich denke, es liegt an der Ram-Karte.

Danke und VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
08.01.2019, 22:35 Uhr
holm

Avatar von holm

Die RAM Karte sollte eine K3528 sein.. mit 8212 Register um Speicherbanken (MEMDI) umzuschalten.
So eine Karte hatte ich unbestückt zu DDR Zeiten bekommen (wir hatten ja Nichts) und es hat mich üble Kopfstände gekostet das Ding mit der K2526 überhaupt zum Laufen zu bekommen. Das ist zeitkritisch, offenbar sind die M1 Zyklen da zu kurz...

Da die K2521 keinen Bootloader-mechanismus wie die K2526 hat, werden die ROMs und die U202 auf der ZRE mit diesem 8212 Register abgeschaltet. IMHO können 2 solche Karten in einem K8915 stecken.
Neuere K8915 haben eine längere ZVE und da ist der Speicher (128K) samt 8212 on Board.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
09.01.2019, 19:13 Uhr
Rolly2



Hallo Holm, danke für die Info. Einen neuen 8915 habe ich hier stehen. Ich habe die ROMs mal untersucht. Danach müsste der "ALTE" 8915 ebenfalls eine Selbsttestroutine haben.
Hätte jemand die Schaltungsunterlagen für eine K7028.20 012-6720 ATS?

Danke und VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
10.01.2019, 21:17 Uhr
Rolly2



Die ATS ist jetzt funktionstüchtig, ging auch ohne Schaltungsunterlagen. Es wäre trotz alledem einfacher gewesen, wenn ich sie gehabt hätte.
Ich suche jetzt zusätzlich die Schaltung der OPS K3528.00. Wer kann da helfen?

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
11.01.2019, 00:20 Uhr
holm

Avatar von holm

Guck mal bei mir auf den Server, es gibt da irgendwie zu K8915 Unterlagen die Schaltpläne dieser Karten enthalten. ATS und RAM.

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek