Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » Z1013+GIDE+USB+RTC usw. » Themenansicht

Autor Thread - Seiten: -1-
000
11.02.2017, 20:46 Uhr
Creep



Hallo,

ich finde es irgendwie unpassend, im Z1013-Flohmarkt-Thread mit technischen Fragen zu kommen. Deshalb mach ich mal hier einen neuen auf. Vielleicht kann man hier dann ja quasi Fragen und Antworten sammeln, die beim Inbetriebnehmen speziell vom Z1013-128 und Erweiterungen aufkommen. Dann kann sie jeder leicht finden.

Also, mein Z1013-128 läuft inzwischen einwandfrei mit BWS, Mega-Flash Modul, USB-VDIP und 2x256k RAM-Floppy. SCP läuft im 32x64 Modus der BWS, lädt vom USB-Stick und nutzt die Ramfloppy als Laufwerk A+B.

Heute habe ich mal Buebchens Prototypenplating für GIDE+VDIP+RTC bestückt und in Betrieb genommen. USB und Zugriff auf den Stick funktioniert schon einwandfrei. Jetzt würde ich gern auch RTC und für allem das DOM am GIDE in Betrieb nehmen.

Leider komme ich irgendwie grad nicht auf die HUCKI-Seite. Und die ist ja wohl der Sammelpunkt für die meisten Anleitungen und Dateien.

Ich hab schon hier im Forum etwas gefunden und bin soweit, daß ich "SCP64HP8" vom Stick geladen habe, SCP wie gewohnt startet, und ich auf "C:" wechseln kann. Dort werden mir dann mit "DIR" lauter Doppelpunkte angezeigt. Was ja wohl richtig ist, wenn das DOM noch nicht formattiert ist.

Könnte mir vielleicht jemand auf die Sprünge helfen, wie ich das DOM am besten einrichten kann, die RTC nutze und wo ich die nötigen Treiper/Tools finden kann?

Vielen Dank,
Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
11.02.2017, 21:04 Uhr
Rolly2



Rene, nutze DUF05.com, Menüpunkt 4 um das DOM zu leeren. Dann funzt das auch. Hast Mail.

VG, Andreas
--
wie man denkt, so lebt man!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
11.02.2017, 21:06 Uhr
Creep



Danke für die schnelle Antwort! Probier ich gleich nach einer Folge Daredevil auf Netflix.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
11.02.2017, 22:10 Uhr
Alwin

Avatar von Alwin

Beim SCPHP8 kann man mit HDFormat alle Laufwerke formatieren.
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
11.02.2017, 22:25 Uhr
Creep



@Andreas: Hab noch keine Mail.

@ Alwin: Braucht man dazu noch etwas? Ich hab nur das .z80 File, was SCP mit den Treibern startet,

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
11.02.2017, 22:33 Uhr
Alwin

Avatar von Alwin

HDformat.com aufm Stick ziehen und dann auf die RFL kopieren. Dann jedes Laufwerk vom GIDE, als 6x das HDFORMAT C: usw. Ausführen.
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
11.02.2017, 22:35 Uhr
Rolly2



Ich benenne die Datei mal in .txt um.

VG, Andreas
--
wie man denkt, so lebt man!

Dieser Beitrag wurde am 12.02.2017 um 08:28 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
11.02.2017, 23:20 Uhr
Creep



Danke! Probier ich gleich. Jetzt ist es angekommen. Aber nimm bitte oben meine Mailadresse raus, die muß ja nicht jeder Spambot finden.

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
16.02.2017, 17:29 Uhr
Creep



Nachdem mein Z1013 inzwischen mit DOM am GIDE funktioniert, USB ja sowieso, hab ich noch eine Frage zur RTC. Wird die auf dem Z1013 schon von Software unterstützt? Klar, es gibt ja kein DOS, was alles verwaltet und intern eine Zeit nutzt. Ich glaube, CP/M hatte auch keine Zeitstempel, oder? Schon so lange her...

Aber ich hab über z.B. GIDE-Check gelesen, was ich für AC1 oder LLC2 gefunden habe. Ist das auf dem Z1013 nutzbar? Oder ist die RTC nur auf der Karte und man muß sich entsprechende SW selber stricken? Die Register sind ja dokumentiert. Dann würde ich das mal probieren...

Man muß doch wieder umdenken, wenn man auf einmal vor einem Rechner ohne "echtes" OS, nur mit einem Monitor sitzt.

Gruß, Rene

Dieser Beitrag wurde am 16.02.2017 um 17:30 Uhr von Creep editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
08.04.2017, 11:33 Uhr
Lötspitze



Hallo in die Runde,

ich habe aktuell beim Prototypen der Zusatzplatine das Problem, daß der batteriegepufferte sRAM Datenverlust hat. Aufgrund der Tatsache, daß beim Abschalten der Spannungszufuhr vom Z1013-128 und dieser Platine die LEDs der RFL-LW gleichzeitig kurz noch mal aufblinken, habe ich die Vermutung, daß die RFLs hier noch mal kurz zugeschalten werden und wahrscheinlich sogar ein Schreibzugriff erfolgt. Da reichen ja ein paar Byte und die Daten sind erledigt.

Kennt jemand dieses Problem und weiß, wie man dagegenwirken kann? Mir kam der Gedanke, einen 4,7k Widerstand nach +5V in die /CS Leitung des sRAM zu hängen, damit die noch eine Zeit sicher auf High bleibt. Bevor ich aber auf der Platine rumändere, wollte ich hier mal gern Eure Meinung hören.
Vielleicht sind aber auch die 3x 1000µF Pufferkondensatoren bei den +5V dieser Zusatz-Platine zu viel des Guten und damit wird die Spannung nach Gesamtabschaltung zu lange gehalten.
Der sRAM AS6C4008 hat laut Datenblatt 1,5V Erhaltungsspannung und von der Batterie liegen noch 2,7V an. Also daran kann der Datenverlust eigentlich nicht liegen.

VG Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
08.04.2017, 12:20 Uhr
Enrico
Default Group and Edit


Kenne die Schaltung ja nicht.
Aber beim EIn- und Ausschalten pasert ja erstmal IRGENDWAS, bis da wirklich alles initialisiert ist, bzw. die Spannung weg ist.

Geht dort in der Schaltung vom RAM, der TL7705 mit rein?
Solange der auf RESET hält, dürfen die Signale zum RAM nicht freigegeben werden.
Dann sollte das klappen. Siehe RAF.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
08.04.2017, 13:50 Uhr
Lötspitze



Der TL7705 geht nicht mit in diese RFL-Schaltung ein.

Ich habe Dir mal was geschickt und werde morgen zusehen, daß ich mit dem Oszi die vermuteten Signale eingefangen und nachgewiesen bekomme. Heute komme ich leider nicht dazu.

VG Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.

Dieser Beitrag wurde am 09.04.2017 um 00:36 Uhr von Lötspitze editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
10.07.2017, 18:41 Uhr
PIC18F2550

Avatar von PIC18F2550



Das /EN geht bei mir auf einen Decoder der auch aus der gepufferten Spannung des SRAM versorgt wird.
Der Decoder ist ein 74HC138. Kein LS typ
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"

Dieser Beitrag wurde am 10.07.2017 um 18:46 Uhr von PIC18F2550 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
11.07.2017, 21:23 Uhr
Lötspitze



Ich werde wahrscheinlich das /RST des vorhandenen TL7705 nutzen, um das /CS am letzten Gatter vor dem sRAM zu blockieren. Der arbeitet ja auch bei fallender Spannung identisch. Muß nur zwei andere Gatter verwenden für D8/G6 und G5 und zumindest das letzte dann mit 2 Eingängen sowie Open-Collector Ausgang, damit der Ruhestrom des sRAM im µA-Bereich bleibt. Mit den LS04 zog der viel zu viel Saft im Ruhezustand (hatte schon auf LS05 gewechselt).

VG Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
11.07.2017, 23:46 Uhr
PIC18F2550

Avatar von PIC18F2550

Ich hoffe der TL7705 ist der der das RESET an die CPU sendet alle anderen sind ungeeignet.

Eigentlich müsste das Gatter D8/G5 durch ein Nand (74HC00) ersetzt werden.
Der Extra Eingang kommt an das /RESET vom K1520 BUS.
Wenn Reset = H dann ist das CS vom SRAM auch möglich.

Nicht vergessen der 74HC00 muss an die selbe Spannung wie der SRAM sonnst wird es nichts mit dem Ruhestrom.

Mein SRAM hält seit mehr als 2 Jahren seine Daten.
Zerstörter Speicherinhalt kenne ich nicht.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
15.07.2017, 12:21 Uhr
Lötspitze



Habe [013] mit zwei 03er Gatter umgesetzt. Dazu 4,7k an den Ausgang des ersten (G6) nach 5V und 100k an den Ausgang des zweiten (G5) nach Vcc des sRAM. Zur Zeit gibts weder Datensalat noch Datenverlust

Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
26.10.2017, 20:07 Uhr
Lötspitze



Hallo,

kann jemand sagen, welcher Adresse der "Track 60" von der RFL nach präcitronic MP 3/88 entspricht bzw. bei welcher Adresse der beginnt? Bei 4 MHz Takt habe ich ab dieser Adresse Fehler auf der RFL B. Dagegen ist RFL A weiterhin OK und bei 2 MHz sind beide RFL der Zusatzplatine 100% OK.

Matthias
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
06.12.2017, 20:36 Uhr
Lötspitze



Track 60 der RFL B entspricht 10111100 auf den Adressen A18-A11 des D27 in [011].
--
___________________
...geboren, um zu löten.

Wer rennen soll, muß auch mal stolpern dürfen.

Dieser Beitrag wurde am 06.12.2017 um 20:52 Uhr von Lötspitze editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek