Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Sonstiges » removable media bit (RMB) auf CF-Karte » Themenansicht

Autor Thread - Seiten: -1-
000
28.01.2017, 00:34 Uhr
wpwsaw

Avatar von wpwsaw

Guten Morgen,

ich habe einen Kleinstrechner auf dem Windows XP auf einer CF Karte läuft. leider muss die CF Karte öfter mal gewechselt werden. Seit dem letzten Wechsel habe ich Probleme unter anderem, mit der Auslagerungsdatei. Sie kann nicht mehr erstellt werden. Nach vielem Suchen habe ich den Fehler. Die alte Karte wurde als Festplatte erkannt. Die jetzige als Wechsedatenträger. Das liegt am RMB. Es müßte auf 0 gesetzt werden. Hat jemand eine Idee (bitte keinen Filtertreiber).

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
28.01.2017, 01:19 Uhr
Enrico
Default Group and Edit


Du steckst die CF aber schon per IDE und nicht per USB an?

Es gibt verschiedene Typen CF-Karten.
Einige laufen auch als IDE sprich als Platte, andere können das nicht.
Kann sein, dass deine neue Karte auch sowas abgespecktes ist.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
28.01.2017, 10:31 Uhr
wpwsaw

Avatar von wpwsaw

Es soll Tools geben, da kann man das RMB löschen und die CF Karte oder der USB-Stick werden als lokale Festplatte erkannt und nicht als Wechseldatenträger. Jetzt suche ich so ein Tool.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
28.01.2017, 10:46 Uhr
Rolly2



Vielleicht hilft dir das weiter. Siehe unter "Hintergrundinfos".

http://www.wintotal.de/tipparchiv/?id=1656
https://board.bloodnet.de/index.php?act=ST&f=22&t=1323&

VG, Andreas

PS: Link vergessen
--
wie man denkt, so lebt man!

Dieser Beitrag wurde am 28.01.2017 um 11:17 Uhr von Rolly2 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
28.01.2017, 10:47 Uhr
wpwsaw

Avatar von wpwsaw

Danke

hatte ich schon auf meiner Liste.
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2

Dieser Beitrag wurde am 28.01.2017 um 11:04 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
28.01.2017, 12:35 Uhr
wpwsaw

Avatar von wpwsaw

zum 2. Link, hatte ich wo anders gelesen, das diese Filtertreiber Probleme unter XP bewirken können.

Danke

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
28.01.2017, 13:14 Uhr
Enrico
Default Group and Edit


Mit Gparted kannst Du das problemlos partitionieren.
Ob das dann hinterher auch noch für XP ok ist, weis ich nicht.
--
MFG
Enrico

Dieser Beitrag wurde am 28.01.2017 um 14:00 Uhr von Enrico editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
28.01.2017, 13:19 Uhr
wpwsaw

Avatar von wpwsaw

im Moment versuche ich das HP USB Tool. Mit Linux wäre mein nächster Versuch.

Ich hatte die CF-Karten gleichen Typs, Hersteller und Größe. Eine funktioniert und eine nicht.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
28.01.2017, 16:00 Uhr
millenniumpilot

Avatar von millenniumpilot

Hallo wpw,

ich meiner lange nicht mehr benutzen Kamera habe ich noch eine 1GB IBM Microdrive. Also eine 1GB-Platte im CF-Format.
Wahrscheinlich könnte ich die "freimachen" und wenn es Dir hilft, könntest Du sie dann auch haben.

Gruß aus Berlin
Dirk
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
28.01.2017, 16:19 Uhr
wpwsaw

Avatar von wpwsaw

Hallo Dirk,

nein Danke, sie ist zu klein.

Mit HP USB Tools habe ich auch keinen Erfolg gehabt. Es liegt direkt an der Hardware. Ich hatte hier 6 Kingston CF mit 8GB. 4 davon funktionieren und werden als Festplatte erkannt. die 2 und eine 16GB werden nur als Wechseldatenträger erkannt. Mit Acronis kann ich zwar ein Image drauf bringen und die läuft (bootet) auch, nur da sich die CF als Wechseldatenträger anbeldet, kann man z.B. keine Auslagerungdatei darauf anlegen. Und noch einige andere Dinge funktionieren nicht, die ich benötige.

Ich werde jetzt mal Linux ins Rennen schicken. Mal sehen was da passiert. Alles andere mit FAT16, 32, NTFS, partitionieren ..... bringt keinen Erfolg.

Dieses eine Bit auf der CF (RMB) muss auf 0 gesetzt werden.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
28.01.2017, 17:01 Uhr
PIC18F2550

Avatar von PIC18F2550

Wo steck den das Bit?

Wenn es im Masterbootrecord steht kannst Du das mit den Norton Utilis im Sector 0 zurücksetzen.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
28.01.2017, 17:09 Uhr
wpwsaw

Avatar von wpwsaw

Das habe ich noch nicht richtig heraus bekommen. Es soll im CF im Controller sitzen genau so wie bei den USB Sticks
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
28.01.2017, 17:34 Uhr
Pollyplay



Hallo wpwsaw,

Rein theoretisch lt. Beschreibungen müsste es machbar sein.
M.E. verm. im MBR?

Du hast mit HB-Tool gearbeitet. Es wird die hbusbfw.exe angegeben und testdisk, die hierbei behilflich sein sollen.
Ich habe es noch nicht probiert.

Dann gibt es noch die Möglichkeit mit : xpfildrvr1224_320.zip ,
Filtertreiber zum Entfernen des RMB
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
28.01.2017, 17:41 Uhr
timpi



Moin,

das Bit sitzt im Controller (Device properties) und nicht im nutzbaren Datenbereich. Um es zu ändern muss die Karte das auch unterstützen. Selbst bei zwei -augenscheinlich- identischen Karten, wenn diese unterschiedliche Firmwaren haben kann's sein dass es bei einer funktioniert, bei der anderen nicht.


Hier noch ein Tool:
BootIt


Timpi.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
28.01.2017, 21:41 Uhr
wpwsaw

Avatar von wpwsaw

Hallo Timpi,

danke für die Info. Habe ich gleich getestet, leider noch kein Erfolg.

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
29.01.2017, 00:32 Uhr
ROBOTROONIE



zu timpis Tip steht auf der Wintotal-Seite

"Hinweis: Das Tool "Lexar BootIt", was auf seine Webseite erwähnt wird, sollte NICHT verwendet werden, da das Tool mehr Schaden als Nutzung bringt."
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
29.01.2017, 06:15 Uhr
wpwsaw

Avatar von wpwsaw

es scheint nichts zu funktionieren. Ich werde wohl eine kleine preiswerte SSD versuchen.

Danke

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
29.01.2017, 10:34 Uhr
Enrico
Default Group and Edit


Richtest Du denn nun über IDE-Anschluss oder über USB ein?

Über USB wollte bei mir damals auch etwas nicht funktionieren.
Weis aber nicht mehr was es war. Per IDE und FDISK ging das.
(hatte das noch Windows)

Linux kennt übrigens auch ein FDISK.
--
MFG
Enrico

Dieser Beitrag wurde am 29.01.2017 um 10:35 Uhr von Enrico editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
29.01.2017, 11:40 Uhr
Enrico
Default Group and Edit


Bringt Dir auch nix.
Zeigt zwar alles an, von dem Bit weis es aber auch nichts.
Habs mal eben mit Platte und USB-Stick probiert.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
29.01.2017, 13:50 Uhr
Pollyplay



Es ist durchaus möglich, dass einige CF-Karten sich nicht als Festplatte verwenden lassen, obwohl diese von der Bezeichnung her mit einer anderen gleich sind. Vermutlich lassen die sich nicht oder nicht so ohne Weiteres umfunktionieren.
Das Problem wird hier behandelt.
http://www.uwe-sieber.de/usbtrouble.html#partitionieren
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
29.01.2017, 14:16 Uhr
Enrico
Default Group and Edit


Sagte ich doch schon.....
Und das andere Problem ist Windows also solches.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
29.01.2017, 19:46 Uhr
wpwsaw

Avatar von wpwsaw

Hallo,
bin wieder da.

getestet habe ich unter ide. Eineichten wollte ich es mit einem USB Adapter. Ich werde Morgen noch ein paar Versuche machen. Ansonsten hole ich mir eine kleine ide ssd bei ebay und gut.

Wahrscheinlich würde eine ssd einen Beschleunigungseffekt gegenüber einer cf-karte bringen.
Der PC ist nur ein 1 GHz mit 1GB RAM Typ IGEL 4120. Er läuft bei mir mit XP und sammelt, visualisiert Daten und steuert meine Haussysteme. Alle notwendigen Programme laufen und ich greife mit Remote darauf zu.

Gerade jetzt im Winter kann ich rechtzeitig Fehler in meinen Heizungssystemen rechtzeitig erkennen. Früher, bei meiner Tätigkeit konnte ich bequem auf alle meine Haussysteme auch aus der Ferne zugreifen.


Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
29.01.2017, 20:00 Uhr
Enrico
Default Group and Edit


Mit dem USB-Adapter wird das nix.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
03.02.2017, 12:25 Uhr
Pollyplay



Testergebnisse bei XP 32 Bit mit USB-Sticks und SD-Cards.

Das Tool "Lexar BootIt" funktionierte bei einem USB-Stick Lexar 8 GB und bei einem PConKey 4 GB.
Jedoch wohl vermutlich mit Trickserei?



Es werden 2 Floppy-Disks angezeigt, obwohl keine Floppy vorhanden sind.
Aber die Sticks werden ansonsten wie Festplatten behandelt. In diesen beiden Fällen funktionierte es.


Die anderen Sticks und SDs werden mit dem o.g. Treiber als Festplatte erkannt. Hierbei sind dann bei den beiden o.g. Sticks auch diese Floppies nicht mehr zu sehen.
Die xpfildrvr1224_320.zip entpacken.



In die cfadisk.inf mit Editor die Zeile: "%Microdrive_devdesc% = cfadisk_install,USBSTOR\GenDisk" einfügen und speichern.



Dann über Systemsteuerung und Gerätemanager den Treiber aktualisieren mit geänderter cfadisk.inf.
Wenn das bei Sticks und sd-Cards klappt, müsste es m.E. auch bei CF-Cards funktionieren.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
03.02.2017, 12:48 Uhr
wpwsaw

Avatar von wpwsaw

Hallo,

ja, das mit den Filtertreibern hatte ich schon überlegt, aber in einigen Beiträgen wurde wegen Nebenwirkungen abgeraten.

Ich habe jetzt eine PATA SSD mit 16 GB getestet und die scheint zu funktionieren. Sie ist auch bezahlbar und reicht für diese Art von Rechnern aus.

danke für deine Mühen

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
03.02.2017, 13:07 Uhr
felge1966

Avatar von felge1966

Der IGEL hat doch auch einen IDE Steckverbinder, daher hatte ich mich schon gefragt, warum du dir das Gefrieme mit der CF Karte antust. Die DOMs sind doch speziell für solche Systeme entwickelt und dürften den Betrieb länger aushalten.
Zu der zerstörten CF-Karte habe ich allerdings noch eine Frage. Brauchst du wirklich eine Auslagerungsdatei auf der Karte? Das müßte doch auch anders gehen.

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
03.02.2017, 13:21 Uhr
Pollyplay



Nebenwirkung scheint es mit dem "Lexar BootIt" zu geben, wie ich es im Bild dargestellt habe. Das klappt wahrscheinlich nur mit Lexar?
Mit dem Filtertreiber ist mir nichts bekannt.

Dieser Beitrag wurde am 03.02.2017 um 13:23 Uhr von Pollyplay editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
03.02.2017, 13:48 Uhr
wpwsaw

Avatar von wpwsaw

Hallo Jörg,

ich weiß, der IGEL hat beides. Ich wollte nur keine Festplatte da laufen haben. Für das Datensammeln, Anwendersoftware und WIN XP wären die mir bekannten DOM im MB Bereich zu klein. Ich denke immer erst wieder über andere Lösungen nach, wennes notwendig wird so wie jetzt mit der defekten CF. Das Problem, dass Windows keine Auslagerungsdateien auf Wechseldatenträger schreibt wäre auch nicht der einzige Grund. Ich habe noch Anwendersoftware die auch zwischen Festplatte und Wechseldatenträger unterscheidet.

wie schon geschrieben habe ich jetzt eine PATA SSD 16 GB für 30 Euro zum testen. Das wird den Rechner auch ein bisschen schneller machen.

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
03.02.2017, 20:33 Uhr
Enrico
Default Group and Edit


Oder Du lässt einfach XP weg?
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
03.02.2017, 22:17 Uhr
wpwsaw

Avatar von wpwsaw

Geht leider wegen der Anwendersoftware nicht.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Sonstiges ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek