Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » EPROMs retten » Themenansicht

Autor Thread - Seiten: -1-
000
22.07.2021, 09:48 Uhr
Rüdiger
Administrator


Ich habe immer wieder EPROMs U555, die durch Selbstlöschung fälschlich als Zufallsgenenerator arbeiten.
Versuche, beim Auslesen die Betriebsspannungen zu verändern (Was beim U2716 durchaus zum Erfolg führen kann), haben mich hier nicht weiter gebracht. Einfrieren des EPROMs ebensowenig.

Gibt es irgendwelche Tricks beim U555, um doch noch einmal ein korrektes Leseergebnis zu erhalten?
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
22.07.2021, 10:44 Uhr
wpwsaw

Avatar von wpwsaw

...es klingt zwar ganz simpel und hast du bestimmt auch schon gemacht, aber die Beinchen haben manchmal unterschiedliche Übergangswiderstände. Ich habe so etwas beim Testen meiner Eprommer erlebt. Wenn ich dann gereinigt habe (mechanisch und mit Alkohol) waren die Leseergebnisse wieder stabil. Auch die Schwenkhebelfassungen sind auch nicht mehr, was sie mal waren. Alles in den letzten Wochen erlebt.

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; und P8000 ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2 und Multicar M25 3SK; Barkas B1000 HP

Dieser Beitrag wurde am 22.07.2021 um 10:45 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
22.07.2021, 12:18 Uhr
daracote



ja die Oxidation von Kontakten ist ein großes Problem. Ich verwende da hauptsächlich Kontaktspray Kontakt 61. Wenn man den roten Kontakt 60 benutzt so sollte man gründlich danach das alles Waschen ( evt. WL) sonst oxidiert alles weiter und ist defekt.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
22.07.2021, 12:40 Uhr
kaiOr

Avatar von kaiOr

Vorsichtiges Nachprogrammieren mit 00h könnte man noch testen. Viel weniger Pulse und am besten noch mit zusätzlicher Strombegrenzung. Ist halt die Frage wie schnell die wirklich leeren Zellen gegenüber den halb leeren umswitchen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
22.07.2021, 12:42 Uhr
Rüdiger
Administrator



Zitat:
wpwsaw schrieb
...es klingt zwar ganz simpel und hast du bestimmt auch schon gemacht, aber die Beinchen haben manchmal unterschiedliche Übergangswiderstände.



Das kann ich als Fehlerursache ausschließen: auf sowas achte ich schon und reinige die auch im Zweifelsfall.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
22.07.2021, 13:52 Uhr
Buebchen



@Rüdiger
An welchen Spannungen hast du denn beim Auslesen gedreht? Relevant sollten nur die +5V sein. Wenn die niedrieger werden, kann es sein, das das auslesen wieder klappt.
Wolfgang

Dieser Beitrag wurde am 22.07.2021 um 13:52 Uhr von Buebchen editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
22.07.2021, 14:20 Uhr
Rüdiger
Administrator



Zitat:
Buebchen schrieb
An welchen Spannungen hast du denn beim Auslesen gedreht?



An allen.
Wobei meine Möglichkeiten da begrenzt sind, weil der EPROMer sowas nicht vorsieht.

Falls Du da bessere technische Möglichkeiten hast: lege doch mal einen U555 ins Löschgerät, bis er instabil wird und versuche ihn über die Spannungen wieder zu stabilisieren.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
22.07.2021, 14:36 Uhr
Wusel_1



Hast du schon mal den Lesezyklus verlangsamt? Hat bei mir mal geholfen.
--
Beste Grüße Andreas
______________________________________
DL9UNF ex Y22MF es Y35ZF
JO42VP - DOK: Y43 - LDK: CE

*** wer glaubt, hört auf zu denken ***
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
22.07.2021, 16:34 Uhr
Rüdiger
Administrator



Zitat:
Wusel_1 schrieb
Hast du schon mal den Lesezyklus verlangsamt? Hat bei mir mal geholfen.



Ich wüsste nicht, wie ich das tun könnte: Zur EPROMer-Software habe ich keine Quelltexte.
Falls Du da eine Lösung hat, würde ich Dir mal so einen EPROM schicken.
--
Kernel panic: Out of swap space.

Dieser Beitrag wurde am 23.07.2021 um 10:02 Uhr von Rüdiger editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
23.07.2021, 17:22 Uhr
kaiOr

Avatar von kaiOr

Man könnte evtl. das Programm [WEGA] von der WEGA-Startdiskette neu übersetzen. Da stecken die eigentlichen Programmierroutinen für das Programm [pburn] unter WEGA drin.
Speziell bei 2708 (U555) programmiert der 1024Bytes hintereinander mit jewl. 1ms Impuls und dies nicht nur 50 sondern 100 mal.

Reduziert man das auf einzelne Durchläufe a 1ms bei Neuprogrammierung mit jewl. 00h (leerer EPROM FFh FFh..., voller EPROM 00h 00h...) und sichert nach jedem Durchlauf einen kompletten Abzug weg ergibt sich evtl. in einem gewissen Bereich ein stabiles Bitmuster (bevor auch gänzlich leere Zellen anfangen auf voll umzuschalten).

Müsste man mal mit einem absolut leeren U555 testen, nach wieviel Impulsen a 1ms die Zellen umswitchen bzw. ob das eher einheitlich passiert oder völlig unkontrollierbar, vielleicht schon nach dem ersten 1ms-Impuls.

Dieser Beitrag wurde am 23.07.2021 um 17:24 Uhr von kaiOr editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
23.07.2021, 17:45 Uhr
Buebchen



@kaiOr
Hallo,
Das mit dem einen Impuls 00H programieren Kannst du nach meiner Erfahrung vergessen. Bei meinen Versuchen mit dem 2708 Programieradapter habe ich die Erfahrung gemacht, das viele Zellen schon nach einem 1msec (auch 0,5msec) Programierimpuls exemplarabhängig sicher gebrannt war. Nur aus Sicherheitsgründen wurden mindestens 4 Zyklen über alle Adressen mit 1msec gebrannt und dann noch einige Sicherheitszyklen hinterher. Siehe Programieralgorithmus des KC85/3-5 Brenners M030 für den Maleuma das neue Steuerprogram geschrieben hat.
Auch was Rüdiger bei mir angefragt hat einen Eprom anzulöschen und dann mit Unterspannung von Vcc +5V auszulesen funktioniert nicht, da der Zeitpunkt wann das Datenbit umkippt nicht sicher bestimmt werden kann. Einzelne bits sind schon FFH und andere haben ihre Daten noch. Der Energieeintrag in den Eprom, der die Ladung verschiebt ist mit einer Löschlampe einfach zu groß.
Ich kann mir vorstellen, das das Auslesen am Buebchenbrenner mit verminderter Ucc +5V funktionieren könnte, habe aber keinen mehr zur Verfügung. Der Buebchenbrenner verwendet ebenfalls einen intelligenten Algorithmus von Reiner Brosig beim brennen aller Eproms der durch den geringeren Energieeintrag sehr schonend für die Eproms ist und die Datensicherheit erhöht, im Gegensatz zum Standardalgorithmus, der durch Erwärmung zu mechanischen Spannungen im DI führen kann die den Ausfall des Eproms möglich macht.
Wolfgang

Dieser Beitrag wurde am 23.07.2021 um 17:54 Uhr von Buebchen editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
23.07.2021, 18:47 Uhr
kaiOr

Avatar von kaiOr

Danke Wolfgang, das nimmt mir jede Illusion.

Gruß,
Kai
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
23.07.2021, 19:33 Uhr
mark1111



@Rüdiger:

Hast Du am U555 schon mal die Datenausgänge D0 bis D7 mit einem Multimeter bei statischen Pegel an den Adresseingängen A0 bis A9 gemessen? Ich hatte mal einige U555 mit "komischen Werten" auf bestimmten Speicheradressen. Es waren dann Spannungen im verbotenen Bereich an den Ausgängen zu messen, z.B. 2,0V und weniger. Nach den Löschen lagen diese alle auf ca. 4 V bis 4,7V. Der EPROM war nicht defekt, nur Alzheimer nach ca. 35 Jahren. Also mal die statischen Pegel messen Ich habe dazu auf dem Steckbrett eine einfache Testschaltung mit DIP-Schaltern aufgebaut. Vielleicht läßt sich über diese Methode was machen.

Viele Grüße
mark1111
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
23.07.2021, 20:16 Uhr
Buebchen



@Rüdiger
Hallo,
Der Vorschlag von mark1111 ist sehr vernünftig und könnte ein Weg sein die Daten zu retten. Statische Spannungen an den Datenausgängen sollten dem Dateninhalt entsprechen. An die Adressleitungen Pullup Widerstände nach +5V legen und mit Schaltern zur Adressierung nach Masse schalten. An Ucc des Eproms +5V oder auch versuchsweise etwas wehniger anlegen und die Spannungen an den Datenpins messen. Nicht vergessen vor allen Spannungen erst die -5V anlegen. Als zweites die +12V, zum Schluss die +5V. Ansonsten kann der Eprom zerstört werden. Datenblatt beachten, besonders die Pegel an den Spannungspins beim Auslesevorgang.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
24.07.2021, 10:55 Uhr
jde

Avatar von jde

@Rüdiger
ich würde einen Microcontroller mit analog Eingängen nehmen.
Z.B. AT89C51CC03 und die Daten über den A/D Wandler einlesen.
Die könntest du über die serielle Schnittstelle als 8-Bit Wert für jedes Bit als HexDump ausgeben.
Oder die Daten jedes Bits intern schon vorverarbeiten und die H/L Schwellwerte im Programm passend einstellen.
Jonny
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
24.07.2021, 11:51 Uhr
Rüdiger
Administrator



Zitat:
Buebchen schrieb
Bei meinen Versuchen mit dem 2708 Programieradapter habe ich die Erfahrung gemacht, das viele Zellen schon nach einem 1msec (auch 0,5msec) Programierimpuls exemplarabhängig sicher gebrannt war.



Könnte es etwas bringen, die Impulse noch kürzer zu machen?
Interessant wäre auch, was passiert, wenn man die Spannung der Programmierimpulse verringert.
--
Kernel panic: Out of swap space.

Dieser Beitrag wurde am 24.07.2021 um 11:56 Uhr von Rüdiger editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
24.07.2021, 14:49 Uhr
Buebchen



@Rüdiger
Hallo,
Das verringern der Programierimpulsbreite auf 0,1 msec habe ich auch schon probiert. Da aber meine Programierimpulse sehr Stromstark sind änderte das nichts. Die Spannung des Programierimpulses dient zum umschalten zwischen lesen und Programieren, jedenfalls ist das bei den Größeren Eproms der Fall. Zur Auswirkung der Programierimpulshöhe beim 2708/U555 habe ich noch nichts gefunden. Da aber bei zu geringer Stromergiebigkeit des Programierimpulses, also wenn der Programierimpuls innerhalb desr Programierimpulsgrenze die 25 V nicht sicher erreicht, keine Programierung stattfand halte ich auch das für nicht Zielführend. Nur der von mark1111 in der012 angesprochenen und von mir in der 013 präzisierte Weg halte ich für erfolgversprechend. Miss doch bei einem unkritischen 2708/U555 die Ausgangspegel der Datenleitungen und stelle fest welche Unterschiede es gibt. Da die Pegel beim altern, wie beim Löschen von 0V gegen +5V gehen, sollte eine High-Low Unterscheidung möglich sein. Die jedoch ein digitales Bauelement nicht auswerten kann.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
24.07.2021, 17:53 Uhr
Rüdiger
Administrator



Zitat:
mark1111 schrieb
Hast Du am U555 schon mal die Datenausgänge D0 bis D7 mit einem Multimeter bei statischen Pegel an den Adresseingängen A0 bis A9 gemessen?



Mangels passender Hardware nein. Mein EPROMer schaltet die Spannungen ja nur kurzzeitig zu.


Zitat:
Ich hatte mal einige U555 mit "komischen Werten" auf bestimmten Speicheradressen. Es waren dann Spannungen im verbotenen Bereich an den Ausgängen zu messen, z.B. 2,0V und weniger.



Dann sollte es helfen, acht Spannungsteiler 2:1 in die Datenleitungen zu schalten, um den Anteil der als L erkannten Bits zu vergrößern?
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
24.07.2021, 18:33 Uhr
Buebchen



@Rüdiger
Hallo,
Nur ein extra Aufbau zum Beispiel auf Lochraster mit anlegen der nötigen Spannungen in der richtigen Reihenfolge und das anlegen von einer Adresse nach der anderen von 000H an kann dein Problem lösen. Kein Spannungsteiler kann aus den Fehlerhaften Daten ein Logiksignal generieren. Es ist aufwendige Fleisarbeit mit Messen jeder Pinspannung nötig und das übersetzen des Spannungswertes jedes bits von Hand in Datenbytes.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
24.07.2021, 22:53 Uhr
schlaub_01



Also mit dem händischen Ausmessen könnte auch problematisch sein. Ich hatte auch vor einiger Zeit mal so einen EPROM, der auf einigen Adressen fehlerhafte Bits brachte. Mit dem Oszi konnte ich dann aber sehen, daß der Pegelverlauf auch sehr zeitabhängig war. Bis etwa 1µs konnte man noch eine Richtung erkennen, in der das Bit wirklich liegt. Aber danach gab es eher Lade- bzw. Entladekurven und es war dann gar nichts mehr zu erkennen. Zum Glück hatte ich damals die Originaldaten und konnte den EPROM wieder brennen. Der lief dann auch wieder problemlos.
Ich denke mal, das Ausmessen mit dem ADC, so wie das jde geschrieben hatte, könnte möglicherweise zielführender sein. Aber eventuell kann da auch der Klaus (paulotto) weiterhelfen. Der kennt sich mit dem Auslesen von solchen EPROMs sehr gut aus, wo die Bits am kippen sind.

Viele Grüße,
Sven.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
25.07.2021, 07:42 Uhr
Buebchen



@schlaub_01
Hallo,
Wie bist du denn an das Problem heran gegangen? Hast du den Eprom in einer ansonsten funktionierenden Schaltung untersucht oder wie in meinem Vorschlag statisch in einem Versuchsaufbau?
In einer ansonsten funktionierenden Schaltung ist mir das Verhalten in deinem Fall völlig erklärlich. Beim statischen Auslesen halte ich solch Verhalten für unmöglich.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
25.07.2021, 10:38 Uhr
schlaub_01



Hallo Wolfgang,

die Untersuchungen habe ich in meinem EPROM Brenner gemacht. Das ist ein SENG Gerät und die Quellen waren alle offen, so daß ich meine eigenen Routinen anpassen konnte, damit ich nur auf betroffenen Adressen zugreife. Das Verhalten fand ich auch seltsam, aber war immer wieder genauso nachvollziehbar. Wie gesagt, nach dem Löschen und erneuten brennen, lief der EPROM wieder ganz sauber.

Viele Grüße,
Sven.

Dieser Beitrag wurde am 25.07.2021 um 10:38 Uhr von schlaub_01 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
25.07.2021, 13:05 Uhr
Buebchen



schlaub_01
Hallo,
Ich halte einen externen Aufbau mit statisch angelegten Signalen für sicherer und funktioneller. Ob das Lesesignal statisch beim Seng Brenner angelegen hat weiss ich nicht. Ich weiss auch nicht ob du die Adressen die ganze Meßzeit über angelegt hattest. Bei einem Eprom sollte das für Messungen aber gemacht werden, die statische Ausgaben betreffen. Ich habe den Seng Brenner an einem MSX-Computer in Betrieb. Der kann allerdings keine 2708/U555 brennen. Ausser vieleicht mein Nachbau mit extra 2708 Fassung. Den habe ich aber noch nicht getestet.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
25.07.2021, 17:47 Uhr
Rüdiger
Administrator



Zitat:
Buebchen schrieb
Nur ein extra Aufbau zum Beispiel auf Lochraster mit anlegen der nötigen Spannungen in der richtigen Reihenfolge und das anlegen von einer Adresse nach der anderen von 000H an kann dein Problem lösen.



8182 Analogmessungen pro Schaltkreis: ich bin mir nicht sicher, ob ich das durchhalten werde. Hast Du so eine Ausdauer?
Wieviele Schaltvorgänge ein DIP-Schalter überlebt, müsste man auch erstmal erforschen.

Ich gehe davon aus, dass mein EPROMer Schmidttrigger-Eingänge hat, also keinen verbotenen Pegelbereich besitzt. Wenn ich bei jeder Lesung andere Ergebnisse bekomme, bedeutete das, dass auch bei analoger Messung jedesmal eine unterschiedliche Spannung aus den Datenleitungen herauskommt.

Aus der Annahme, dass sich ein gewolltes H-Bit nie durch Selbstlöschung in ein L-Bit verwandeln kann, wohl aber ein gewolltes L-Bit durch Selbstlöschung in ein H-Bit, postuliere ich:
1. dass ein stabil gelesenes L-Bit in jedem Fall ein gewolltes L-Bit ist.
2. dass Bits, die wechselnde Ergebnisse bringen, nur gewollte L-Bits sein können.
3. dass stabil gelesene H-Bits entweder gewollte H-Bits oder fälschlich permanent umgekippte L-Bits sind.

Die Fälle 1 und 2 sind trivial, die Daten ließen sich mittels vielfachem Lesen zurückrechnen.
Fall 3 ist der einzig spannende, hier könnte man mit der Analogtechnik ansetzen.
Da müsste man doch nur einen Pegel-Umschaltpunkt wählen, der so hoch liegt, dass unter Beachtung der Herstellungstoleranzen H-Bits gerade so noch sich als H erkennt werden.
Also den Umschaltpunkt auf 4V...4,5V legen.
Oder habe ich einen Denkfehler?
--
Kernel panic: Out of swap space.

Dieser Beitrag wurde am 25.07.2021 um 18:02 Uhr von Rüdiger editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
25.07.2021, 19:09 Uhr
P.S.



@Rüdiger <023>
Ich hatte Dir zu diesem Thema eine eMail geschickt ...
Eine recht gute Beschreibung der gesamten EPROM-Problematik (außer den technologischen Aspekten) ist in http://www.ps-blnkd.de/KdT-Heftinhalt/H41.pdf zu finden.

Leider ist (noch) nicht bekannt, wie die Leseverstärker/Datenpuffer im EPROM funktionieren - insbesondere unter dem 3-Betriebspannungs-Regim des U555C. Wenn dort schon Schwellwert-Trigger eingebaut sind, ist es eigentlich unwahrscheinlich Daten-Pegel außerhalb von TTL-Bedingungen zu bekommen.
Daß der jeweilige Speicher-MOSFET mit seinem "Floating Gate" durchaus analog arbeitet, ist jedoch nachvollziehbar.

Wir hatten damals im Vorfeld der M030-Entwicklung im AEB viele Versuche mit vielen EPROM-Typen angestellt - DDR-, NSW- und SU-Typen. Es war auch eine riesige Menge Unterlagen dazu vorhanden, aber die habe ich offensichtlich schon mal jemanden aus der RT-Gemeinde "übergeholfen".

Erinnerlich ist mir jedenfalls, daß wir in Abspreche mit Mühlhausen auf den U555C verzichtet hatten, weil es dort zu viele "Variable" gegeben hätte - von der komplizierte Betriebsspannungsversorgung mal ganz abgesehen ...

Auf meiner HP-Agenda steht immer noch ein Artikel zur EPROM-History im FWE. Vielleicht findet sich ja doch noch ein wissensvermittelnder Insider aus der dortigen HL-Entwicklung ... ?

Übrigens - zum Thema "EPROM" hatten wir hier im RT-Forum schon vielfach Diskussionen - einfach mal "Suchen" bemühen ...

Das Wissen der Menschheit gehört allen Menschen! -
Wissen ist Macht, wer nur glaubt, der weiß nichts! -
Aber - Unwissenheit schützt vor Strafe nicht! -
Gegen die Ausgrenzung von Unwissenden und für ein liberalisiertes Urheberrecht!
PS
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
25.07.2021, 19:17 Uhr
kaiOr

Avatar von kaiOr

Also Komparatoren zwischenschalten, z.B. 2x LM339AN und die negativen Eingänge an einen gemeinsamen Spannungsteiler baumeln? Die Ansprechzeiten sind allerdings unterirdisch, man müsste jeden Lesezugriff mit mind. einem WAIT pausieren. :/
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
25.07.2021, 20:49 Uhr
Buebchen



@Rüdiger
Ich glaube, du denkst zu kompliziert. Die Eproms können nicht mehr sauber gelesen werden, weil die Lowspannungen in den verbotenen Bereich in die Mitte zwischen 2 und 3V gewandert sind. Wahrscheinlich eher leicht über 2V Zu den High Pegeln wird ein deutlicher Abstand sein. Du brauchst nur 1024 Adressen und wenn der Eprom nicht bis zum letzten Byte gebrannt ist nicht einmal die. Die acht Datenleitungen kannst du mit mehreren Spannungsmessern parallel abfragen. Falls du vier Stück auftreiben kannst brauchst pro Adresse nur die vier bits, also hohes Byte, niedriges Byte umschalten. Ähnliches habe ich schon vor dreißig Jahren praktiziert. Jetzt habe ich die Konzentration nicht mehr. Wenn dir die Daten es Wert sind ist es auch die Mühe Wert. Ich würde zum umschalten des Low und High Bytes keine normalen Umschalter nehmen, die sind zu unzuverlässig bei den niedrigen Spannungen und Strömen, sondern eventuell die DDR Umschalter im DIL Gehäuse mit vergoldeten Kontakten. Wenn du keinen hast kannst du ihn von mir bekommen, oder sicherheitshalber auch zwei. Zeitaufwand für das auslesen pro Byte schätzungsweise 5 sec inclusive eintragen. Sollte machbar sein. Falls du noch Fragen hast sende sie mir als Mail. Ich schicke dir dann einen Schaltungsvorschlag und wenn ich deine Adresse bekomme auch die Umschalter.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
25.07.2021, 22:34 Uhr
mark1111



@ P.S.
Die U555 & die K573RF1 haben keine Schmitt-Trigger Datenausgänge. Das habe ich schon vor ca. 35 Jahren festgestellt, als es darum ging, die EPROMS U555 für die Melodieklingel nach FA 04/86 zu duplizieren. Ich nutzte damals den Schaltungsvorschlag aus dem FA 10/86 "Test-Programmiergerät für EPROMs S 555 C1/C2" den ich entsprechend modifiziert hatte. Auf Grund von Störimpulsen, die damals über die Datenleitungen mit eingeschleppt wurden, kam es manchmal zur unvollständigen Programmierung des U555. Die Datenausgänge hatten beim lesen dann auch Werte im verbotenen Bereich, die beim nachfolgenden löschen wieder auf H-Pegel gingen.

@ Buebchen
Gute Idee, man kann den Aufwand noch etwas höher treiben und die Schaltung aus dem FA 10/86 auf manuelle Adress-Weiterschaltung modifizieren.

oder ähnlich hier:

https://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=18740

Viele Grüße
mark1111
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
26.07.2021, 09:08 Uhr
Buebchen



Hallo,
Weil mich das ganze interessiert habe ich mir 4 Panelmeter für zusammen rund 7,-€ in China bestellt und werde, wenn sie bei mir sind einen Versuchsaufbau machen. Nach meinen Überlegungen ist mir die Lösung des Problems klar. Aber mir liegt es, so etwas praktisch zu erproben. So habe ich das bisher gehalten, das hat zum Verständnis vieler unklarer Probleme beigetragebn. Aber für die komplette Datenerfassung fühle ich mich nicht berufen.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
28.07.2021, 10:54 Uhr
Buebchen



@Rüdiger
Hallo,
Ich bin dabei einen Buebchenbrenner fertig zu machen. Mit einer neuen Programierfassungsleiterplatte habe ich parallel zu den Datenausgängen 4,7K Widerstände nach Masse gelegt, die den Low Pegel sichern sollen. Die Datenleitungen sind weiter über einen 74HCT245 geführt, der für die PIO verwertbare Pegel bereitstellt. Damit sollten solche alten Eproms noch sicher gelesen werden können. Ein Buebchenbrenner, der ersten Serie, den ich mir geliehen habe, konnte bei Eproms U555 und K573RF1 die vor mehr als 35 Jahren gebrannt wurden die Daten Gestern lesen und wieder gebrannt werden. Einer von den U555 brauchte Allerdings 240 Programierzyklen inklusive der rund 200 Sicherheitszyklen. Da weigert sich jeder andere Brenner diesen Vorgang bei einem Gleichartigen Eprom abzuschließen. Allerdings würde ich solch einen Eprom nur im Notfall verwenden. Die meisten brauchen bloss einen Programierzyklus + den Sicherheitszyklen.
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek