Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » zeichensatz robotron K 6314 » Themenansicht

Autor Thread - Seiten: -1-
000
28.04.2012, 22:36 Uhr
treaki



hallo,

ich weiß nicht woher (Sperrmüll wahrscheinlich) aber ich aber ich bin irgendwie an einen robotron K 6314 gekommen der noch wunderbar funktionsfähig ist. von der robusten konstruktion (nichts sind im Vergleich dazu die heutigen Tintenpisser) bis zur coolen features (austauschbare schnittstelle) gefällt mir das ding sehr. außerdem ist das ding noch voll funktionsfähig und wie ich heute rausgefunden habe auch mit dem bei meinen debian mitgelieferten ibm proprinterII treiber voll grafikfähig. Im Textmodus ist er allerdings viel schneller... Allerdings habe ich es nicht hingekrigt rauszufinden welcher zeichensatz das gerät hat. mit diesem schnell erstellten programm:

code]
//zeichensatztest.c
#include <stdio.h>

main(){
unsigned char zeichen=0;
while (zeichen<255) {
printf("%i: %c\n",zeichen,zeichen);
zeichen++;
};
}
[/code] habe ich versucht es rauszufinden. (./zeichensatztest > /dev/lp0) allerdings finde ich beim vergleichen des ausdrucks und durchprobieren verschiedener zeichensätze mit der gleichen ausgabe im textiditor keine passende übereinstimmung. sehr merkwürdig ist das schon vor dem umlauten das grichische alphabet (alpha, beta, gamma) kommt...

des weiteren würde ich gerne wissen wie man den automatischen linefeed der immer wieder kommt ausstellt da dies bei Endlospapier sehr nervig ist.

im Anhang sende ich einen scan des ausdrucks mit, enn ihr mehr benötigt einfach sagen.

also nochmal zusammengefasst: welcher zeichensatz ist das (und wie wandel ich von utf8 in diesen unter gnu/linux um) und wie kriege ich die automatischen absätze (hier z.b. zwischen 144 und 145) ausgeschaltet

danke euch

gruß treaki

keine anhangfunktion?? dann hier: http://treaki.tk/~treaki/120428_scan_robotronprinter_zeichensatz.jpg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
28.04.2012, 22:42 Uhr
Olli

Avatar von Olli

Ab 128 ist das kyrillische Alphabet
--
P8000 adventures: http://pofo.de/blog/?/categories/1-P8000
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
28.04.2012, 22:48 Uhr
Mobby5



Griechisch? Das ist Kyrillisch. Und die "automatischen Absätze" sind eigentlich die Stellen, wo der Seitenumbruch, also die Perforation, beim Endlospapier liegen sollte. Das Endlospapier muss schon richtig positioniert werden, bevor man mit dem Drucken loslegt.
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
28.04.2012, 23:28 Uhr
Rüdiger
Administrator



Zitat:
treaki schrieb
des weiteren würde ich gerne wissen wie man den automatischen linefeed der immer wieder kommt ausstellt da dies bei Endlospapier sehr nervig ist.

Schalter 13:1 auf on stellen


Zitat:
welcher zeichensatz ist das

Finde das ROM-Modul vorn rechts im Drucker und baue es aus.
Auf dem Stecker des ROM-Moduls steht üblicherweise, wie der Zeichensatz heisst.
--
Kernel panic: Out of swap space.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
29.04.2012, 01:51 Uhr
treaki



vielen dank euch werd ich machen.


Zitat:
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden

wenn du den im printf befehl meines kleinen c programms meinst:
nein der doppelpunkt ist ein teil des strings der ausgebeben wird und wird nicht interpretiert. "<dezimalzahl des zeichens>: <zeichen>"

gruß und danke euch
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
29.04.2012, 02:00 Uhr
treaki



könnt ihr mir sagen wie genau ich die ausbaue und was es mit dem bindfaden auf sich hatt? (ich glaube den hab ich "kaputt" gemacht der hing vorher straf und jetzt ist er locker)

danke und gruß
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
29.04.2012, 04:03 Uhr
ambrosius



Wenn der "Bindfaden" das Seil ist, welches den Druckkopf transportier (es läuft auf beiden Seiten über Rollen), dann hast Du ein Problem und mußt es austauschen. Das ROM-Modul liegt unter der Blecklasche, welche eigentlich von oben frei zugänglich ist. Die Lasche läßt sich entnehmen, wenn Du die kleine M3-Schraube, welche die Lasche fixiert, entfernst. Darunter ist dann die ROM-Kassette, welche Du (vorsichtig!) nach oben abziehen kannst.

Beste Grüße
Holger
--
Viele Grüße
Holger
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
29.04.2012, 09:40 Uhr
Mobby5




Zitat:
treaki schrieb


Zitat:
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden

wenn du den im printf befehl meines kleinen c programms meinst:
nein der doppelpunkt ist ein teil des strings der ausgebeben wird und wird nicht interpretiert. "<dezimalzahl des zeichens>: <zeichen>"

gruß und danke euch

Alles was im Thread unter -- steht, gehört zur Signatur des jeweiligen Autors und nicht zum Thread.
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
29.04.2012, 11:45 Uhr
treaki



alles klar, so groß ist das Ding ein ganzer Plastikkarte.

auf der Platine im Kasten sind 2 Chips auf dem einen klebt ein zettel auf dem steht:


Quellcode:
6.15-3-ai/02
V24/CL/CEN   EPS/IBM
IBM SU

wo steht hier die Codierung? soll "EPS" heißen das dass gerät PostScript spricht??

danke und gruß

Dieser Beitrag wurde am 29.04.2012 um 11:47 Uhr von treaki editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
29.04.2012, 12:03 Uhr
felge1966

Avatar von felge1966

EPS ist Epson kompatibel

Die ganze Beschreibung findest du in den Beiträgen:

http://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=6045

http://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=8310

http://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=6421

Gruß Jörg
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
29.04.2012, 12:43 Uhr
kaiOr

Avatar von kaiOr

An Interface-Modulen unterstützt der ROM also V24, IFSS (Current Loop) und Centronics. Kompatibel zu EPSON und IBM einstellbar, IBM-SU -> vermutlich Codepage 866.

Also der Faden geht von links her oben an beiden Rollen vorbei und wird dann in eine 8 geführt und das möglichst so, dass er sich selbst nicht kaputtsägt.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
29.04.2012, 13:56 Uhr
Wolfgang



Den baugleichen Drucker habe ich gerade repariert. Er ist Baujahr 1989 und die Unterlagen, die ich bisher gefunden habe, stimmen mit dieser Ausführung nicht überein.
Der Zeichensatz befindet sich auf einem 27256.

Erscheinungsbild des Fehlers: keine Funktion.

Ursache war der Kurzschluss eines Elko (Röderstein!) im NT. Dadurch waren 2 Leiterzüge in Mitleidenschaft gezogen worden.
--
Gruss
Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
29.04.2012, 16:27 Uhr
treaki



ok, also ich habe schwierigkeiten beim zusammenbauen... mit dem "bindfaden meine ich den faden der dafür sorgt dass das farbband weitergeführt wird. dies hat einen ausgeklügelten mechanischen mechanismuss der dafür sorgt das das farbband nur in einer richtung weitergeführt wird... allerdings bekomme ich es nachdem ich den faden abgebaut habe nicht mehr richtig hin...

währe klasse wenn ihr mir in einer ziechnung wie dieser zeigen könntet wie ich den faden richtig einfädeln.
http://treaki.tk/~treaki/120429_ddr_drucker_faden_problem.jpg
danke euch
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
29.04.2012, 19:34 Uhr
kaiOr

Avatar von kaiOr

Von unten gesehen so:


Wie du den Faden führst, damit er sich möglichst wenig aufreibt, ist jeweils zu erproben.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
29.04.2012, 22:18 Uhr
treaki



ok in der form einer 8 wurde schon gesagt... aber das ding ist dass so der faden nicht immer oben rauskommt sondern auch unten also wo wie die enden sind währe sehr wichtig zu wissen. soll heißen so gibt es verschiedene möglichkeiten:




wie genau wird der faden richtig aufgewickelt damit das Farbband korrekt weiter gedreht wird??

danke und gruß
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
29.04.2012, 22:26 Uhr
treaki



alter ich bin wohl blind der faden auf deinen bild hat ja andang und ende... dann werd ich dass mal ausprobieren vielen dank schonmal
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
08.05.2012, 22:07 Uhr
treaki



puh keuch. diesen bindfaden einzufädeln ist eine echte geduldsorgie, lässt du beim fedeln einmal locker fällt das vorhergefedelte sofort ab und du kannst nochmal von vorne anfangen. aber jetst sitzt der faden mit seiner Feder in der richtigen Wicklung dank eurer Hilfe wieder.

VIELEN DANK!!!

eine frage noch: der ich sage mal "druckkopf" (das ding wo HOT draufsteht) wird der gleich am anfang warm oder erst im laufe der zeit. ich habe gerade ein wenig panil weil ich keine wärme spüre, die ausdrucke blass sind und ich während des fedelns oft am Kabel rumgebogen habe.

gruß treaki
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
08.05.2012, 22:14 Uhr
Patrick S.

Avatar von Patrick S.


Zitat:
treaki schrieb
puh keuch. diesen bindfaden einzufädeln ist eine echte geduldsorgie, lässt du beim fedeln einmal locker fällt das vorhergefedelte sofort ab und du kannst nochmal von vorne anfangen. aber jetst sitzt der faden mit seiner Feder in der richtigen Wicklung dank eurer Hilfe wieder.

VIELEN DANK!!!

eine frage noch: der ich sage mal "druckkopf" (das ding wo HOT draufsteht) wird der gleich am anfang warm oder erst im laufe der zeit. ich habe gerade ein wenig panil weil ich keine wärme spüre, die ausdrucke blass sind und ich während des fedelns oft am Kabel rumgebogen habe.

gruß treaki

Die Blässe dürfte auf das Farbband zurückzuführen sein, wenn es schon älter ist.
Die Warnung "HOT" steht vermutlich bei jedem Nadeldrucker auf dem Druckkopf,
da die Spulen darin mit der Zeit einiges an Wärme erzeugen.
Zum drucken muss das Ding jedenfalls nicht vorher warm werden.

Bei einem Röhrenradio das gerissene Skalenseil zu ersetzen ist übrigens auch eine fummelige Angelegenheit.

Ich gratuliere Dir zur Instandsetzung.
--
"Das gute an Standards ist, dass es so viele davon gibt."

Dieser Beitrag wurde am 08.05.2012 um 22:16 Uhr von Patrick S. editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
08.05.2012, 23:20 Uhr
treaki



vielen dank für die info. ja das Farbband währe mein nächster Kandidat, ich werd bei Gelegenheit mal schauen ob ich einen passenden Ersatz finde

> Bei einem Röhrenradio das gerissene Skalenseil zu ersetzen ist übrigens auch eine fummelige Angelegenheit.

kann ich mir sehr gut vorstellen.


> Ich gratuliere Dir zur Instandsetzung.

vielen dank, hat mich Stunden Fummelei gekostet (hauptsächlich wiel ichs falsch eingefedelt habe) aber der Erfolg macht allen ärger wider wet

um nochmal meine eigene frage zu beantworten:

das gerät hatt tatsächlich den Codepage 866 zeichensatz der leider keine deutschen Umlaute besitzt. allerding lassen sich unter linux mit:


Quellcode:
iconv -t CP866//TRANSLIT < utftextedateieingabe > cp866textdateiausgabe

wunderbare Ergebnisse erziehen. ä ö ü werden hierbei durch ae oe ue ersetzt und ß durch ss


gruß und danke nochmal
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
10.05.2012, 00:57 Uhr
treaki




Zitat:
Schalter 13:1 auf on stellen

wo sind denn da schalter??? ach ja da super funktioniert

aber was kann ich alles schönes mit den anderen Schaltern einstellen??
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
24.10.2012, 23:21 Uhr
treaki



hi,

leider ist das bild welches von KaiOr im thred 013 eingefügt wurde nun nur noch ein toter link. daher hier nochmal falls jemand anderes das Problem hat:



es ist meiner Meinung immer wichtig das darauf geachtet wird Content der noch wichtig sein könnte nicht vom Netz zu nehmen

gruß treaki

Dieser Beitrag wurde am 24.10.2012 um 23:23 Uhr von treaki editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
26.10.2012, 19:07 Uhr
kaiOr

Avatar von kaiOr

Das Servicehandbuch ist inzwischen gut über Google zu finden...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
26.10.2012, 20:55 Uhr
paulotto



dann stell doch mal den Link gleich hier rein...

Gruß,

Klaus
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
26.10.2012, 21:27 Uhr
kaiOr

Avatar von kaiOr

Aber treaki hat doch extra das Bild wieder hochgeladen und den Thread aus der Versenkung geholt, ich will das nun nicht schmälern. Ich wollte nur begründen warum ich meins gelöscht hab.
Dieser Beitrag wurde am 26.10.2012 um 21:29 Uhr von kaiOr editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
26.10.2012, 21:38 Uhr
BobCat

Avatar von BobCat

http://www.mpm-kc85.de/html/Drucker.htm#K6313
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
26.10.2012, 21:46 Uhr
paulotto



Götz,

da ist doch aber kein Servicemanual dabei, oder habe ich da was übersehen...

Gruß,

Klaus
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
26.10.2012, 22:01 Uhr
BobCat

Avatar von BobCat

Huch, dann habe ich gedanklich etwas daneben gelegegen. Dort ist nur das "Service Handbuch K6313/K6314". Den Drucker-MANUAL hat Elmar soweit fertig gemacht. Er muß "nur" noch überarbeitet und aufbereitet werden. Komme im Moment nicht dazu.
Eine Anleitung direkt als "Servicemanual" bezeichnet, ist mir bisher nicht bekannt

Dieser Beitrag wurde am 26.10.2012 um 22:01 Uhr von BobCat editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek