Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » KCNET 1.2 » Themenansicht

Autor Thread - Seiten: -1-
000
15.07.2008, 17:10 Uhr
susowa



Heute war grosse Aktualisierung des Projektes auf der Homepage:

http://www.kc85.susowa.homeftp.net

Die Software ist jetzt nicht mehr KC85-lastig, mit PIO an der CP/M-CPU muss man nur noch 3 Sachen erledigen:

- KC85 auf NO
- PIO I/O-Adresse eintragen
- ev. Terminalcodes anpassen

und das Testprogramm neu übersetzen. Alle Standard CP/M-Sachen werden meist von der SYSLIB erledigt. Wer damit schon mal was gemacht hat, sollte also keine Probleme haben. Probieren kann ich das selbst natürlich nicht aber die CPMNET.COM wird ohne Fehlermeldung erzeugt und mehr kann und werde ich dann für die CP/M-Freunde auch nicht tun.

Alle Nicht-KC85/x User müssen das bei Interesse ja sowieso selbst in die Hand nehmen. Für den KC85/x hat Enrico wohl jetzt ernsthaft mit dem Modul-Layout begonnen.

Wer es nachbauen will, kann sich wegen der Firmware mit der gewünschten MAC-Adresse bei mir melden, kostet nix, wird aber nicht publiziert. Ich habe für mich eine MAC von einer alten 3Com ISA-Karte genommen, werde ich sicher nicht mehr brauchen :-).

Viel Spass beim Lesen und Anschauen!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
15.07.2008, 18:26 Uhr
holm

Avatar von holm

Ich wollte mir mal angucken was Du da getrieben hast, Dein Apache erzählt mir dauernd was von Permission denied...

Sollndas?

Gruß,

Holm
--
float R,y=1.5,x,r,A,P,B;int u,h=80,n=80,s;main(c,v)int c;char **v;
{s=(c>1?(h=atoi(v[1])):h)*h/2;for(R=6./h;s%h||(y-=R,x=-2),s;4<(P=B*B)+
(r=A*A)|++u==n&&putchar(*(((--s%h)?(u<n?--u%6:6):7)+"World! \n"))&&
(A=B=P=u=r=0,x+=R/2))A=B*2*A+y,B=P+x-r;}

Dieser Beitrag wurde am 15.07.2008 um 18:27 Uhr von holm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
15.07.2008, 18:33 Uhr
Enrico
Default Group and Edit


geht einwandfrei
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
15.07.2008, 19:13 Uhr
susowa




Zitat:
holm schrieb
Dein Apache erzählt mir dauernd was von Permission denied...
Holm

Ja das ist ein Problem mit dem Download-Modulen auf der rechten Seite, wenn man oben über das Top Menü in den Downloadbereich geht, funktioniert alles.

Ich habe sie bisher immer noch gelassen, da man so schneller sieht was neu ist, auch wenn das Aufrufen der Links zum genannten Zugriffsproblem führt.

Man kann natürlich auch die Suchfunktion bemühen.

Sorry!

Dieser Beitrag wurde am 15.07.2008 um 20:53 Uhr von susowa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
16.07.2008, 20:32 Uhr
BobCat

Avatar von BobCat

@ Ralf

Ich hatte habe auch gelegentlich o.g. Problem. Im Ganzen geht das aber.

Ich möchte dir aber eigentlich für deine geleistete Arbeit in Sachen KCNET danken, um so mehr da du alles bereitwillig für Interessenten offen legst.
Für Mario L. gilt Selbiges.

@ Enrico

Ganz im Groben: Wann ist es soweit mit'm Modul ??

mfg
götz

Dieser Beitrag wurde am 19.07.2008 um 00:11 Uhr von BobCat editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
16.07.2008, 20:48 Uhr
susowa




Zitat:
BobCat schrieb
Ich hatte habe auch gelegentlich o.g. Problem. Im Ganzen geht das aber.
götz

Also seit heute nervt es mich auch nicht mehr, habe die beiden Module nun ausgeschaltet und etwas umgeräumt.

Bitte mit dem Modul nicht ungeduldig sein, Enrico ist jetzt wirklich dabei. Leider ist es aber auch so, dass man das nicht über das Knie brechen kann, wir (Mario, Frank, ich) haben ihm da harte Nüsse zum knacken gegeben, weil wirklich wenig Platz ist, ich will auch keine Details bekannt geben, bevor nicht klar ist, was geht.

Und das hängt jetzt alles davon ab, was Enrico layoutet bekommt. Ihr könnt ihn zwar anfeuern aber bitte nicht unter Zeitdruck setzen - das rächt sich spätestens dann, wenn irgendwelche Leiterzüge aufgekratzt werden müssen, weil es nicht 100%ig passt und wenn ich Enrico wäre, würde ich keinen Zeitpunkt nennen in der jetzigen frühen Phase.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
16.07.2008, 21:51 Uhr
Enrico
Default Group and Edit


Na gut denn, wenn Du ich wärst ( tolles Bild, Du rothaarig ) sag ich auch nix. Jedenfalls habe ich mir vorgenommen, bis zum KC-Treffen fertig sein zu wollen.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
18.07.2008, 21:54 Uhr
BobCat

Avatar von BobCat

Danke. Mein Herz schlägt wie das einer Beutelratte.

gruß
götz
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
21.07.2008, 17:46 Uhr
susowa




Zitat:
Alle Nicht-KC85/x User müssen das bei Interesse ja sowieso selbst in die Hand nehmen...

... Schaltplan online...

... Möglichkeit vorgesehen, neben einem NM7010B+, auch die neuere Variante WIZ810MJ per Jumperauswahl zu betreiben


Dazu dann noch folgende Ergänzung:

Habe heute das WIZ810MJ erfolgreich getestet, läuft problemlos.

Das heisst für alle dann, dass dieses Modul mit dem aktuellen Chip W5100 dann das Standardmodul werden wird.

Auch für das KC85-Modul werden wir dieses Netzwerk-Modul nehmen und sind damit dem engültigen Plan wieder ein kleines Stückchen näher gekommen.

Das auch erhältliche WIZ811MJ-Modul (2,54 mm Stiftleisten für den Anschluss) ist zwar mit dem gleichen Chip (W5100) ausgestattet aber die Pins sind erstens anders belegt als beim 810MJ und es fehlen drei wichtige Signale am Ausgang, so dass sich ein vorhandener LINK nicht sicher ermitteln lässt. Dafür lässt es sich mit Amateurmitteln leichter verarbeiten.

Wie ich ausserdem vom dt. Distributor erfahren habe, werden die 2,54 mm Raster zwar längs an den Stiftleisten eingehalten - quer in der Breite gibt es aber einen Versatz von ca. 0,4 mm, sollte aber mit Lochrasterplatine als Träger noch beherrschbar sein, da hat der Layouter nicht mitgedacht.

Im Moment bezahlt man bei www.dacomwest.de für eine Einzelbestellung des WIZ810MJ mit Versand 34,51 EUR (Modul 18,00 EUR netto + Versand 11,00 EUR netto + MWSt.), ab 25 Stck. kostet das Modul noch 13,10 netto.

Dieser Beitrag wurde am 03.08.2008 um 23:43 Uhr von susowa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
21.07.2008, 18:16 Uhr
Enrico
Default Group and Edit


Beim Versand schlagen die aber ordentlich zu.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
21.07.2008, 19:53 Uhr
susowa




Zitat:
Enrico schrieb
Beim Versand schlagen die aber ordentlich zu.

Leider - aber an gew. Abnehmer verkaufen sie auch nicht nur 1 Stck., wie an mich und dann fällt das nicht mehr ganz so auf :-)

Ich bin eigentlich ganz froh, dass ich nicht in Korea bestellen musste - dort wären das bei der gleichen Bestellung so luftige 45 Dollar Frachtkosten per Fedex gewesen!

Dieser Beitrag wurde am 21.07.2008 um 19:57 Uhr von susowa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
26.07.2008, 22:18 Uhr
susowa



So, es wird langsam. Im Moment wird CPMNET in CAOSNET transplantiert und ist auch schon bis auf die beiden geplanten Datenübertragungsfunktionen fertig.

Da der Echoserver per UDP oder TCP bereits läuft, kann man jetzt aber endlich mal sehen, was geht.

Habe heute dann mal im CAOS-Betrieb zwei Videos gemacht, wo die Übertragung in Echtzeit auf der PC-Seite zu sehen ist und in den Downloadbereich (Dokumentation -> Dokumente) gestellt.

Diese Geschwindigkeit lässt sich dann im Z80-System fahren, wenn man das Interface, wie unter CAOS, im I/O-Adressbereich der CPU hat, also auch mit Euren "alten" CP/M-Kisten :-).

Dieser Beitrag wurde am 26.07.2008 um 22:29 Uhr von susowa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
26.07.2008, 22:27 Uhr
Ralph



Na das klingt doch mal sehr gut.. da bin ich ja gespannt wann die Jungs bei dacomwest.de mal meine Bestellung bearbeiten. Die haben bisher noch nicht gezuckt..

Gruß Ralph
--
Es geht alles erst richtig los !

Dieser Beitrag wurde am 26.07.2008 um 22:34 Uhr von Ralph editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
29.07.2008, 15:14 Uhr
volkerp
Default Group and Edit
Avatar von volkerp

Zur Info: es gibt Interesse für das Projekt in comp.os.cpm
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
29.07.2008, 16:31 Uhr
Enrico
Default Group and Edit


Die gibts nicht.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
29.07.2008, 19:12 Uhr
volkerp
Default Group and Edit
Avatar von volkerp

Natürlich gibts diese >Newsgroup<
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
016
29.07.2008, 19:38 Uhr
Enrico
Default Group and Edit


Na, das kann ich ja nun wissen. Sowas hab ich nicht.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
017
29.07.2008, 20:01 Uhr
susowa




Zitat:
volkerp schrieb
Zur Info: es gibt Interesse für das Projekt in comp.os.cpm

Ja danke - lese schon einige Zeit etwas amüsiert mit :-)

Meiner Meinung nach ist aber die CP/M-Schiene so gut wie tot - hatte ja bereits 09/2007 in Gaby's Forum auch zum Mitmachen aufgerufen aber da kamen NULL Kommentare.

Es gab noch nicht mal in irgendeiner Art und Weise eine Diskussion dazu, weder im positiven, noch im negativen Sinne und das war für mich auch nicht gerade motivierend auf die CP/M-Leute Rücksicht zu nehmen.

Werde mich höchstwahrscheinlich auch wieder mehr in Richtung KC85 und CAOS orientieren, da macht es einfach mehr Spass. Wer das unter CP/M benutzen will, muss sich dann die Programme selbst portieren, was die Ein- und Ausgaben zum System betrifft, netzwerkseitig läuft es durch die hardwareunabhängige Socket-Schnittstelle absolut identisch ab.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
018
29.07.2008, 22:27 Uhr
susowa




Zitat:
Enrico schrieb
Sowas hab ich nicht.

Hast Du schon - auch dort ist Google Dein Freund, Newsgroup-bedingt aber erst nach Registrierung, haben das aber ganz gut mit der (Nicht)Anzeige der E-Mail Adresse gemacht und den vielen Spamschutz-Mechanismen:

http://groups.google.de/
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
019
30.07.2008, 09:41 Uhr
volkerp
Default Group and Edit
Avatar von volkerp

alternativ (und kostenlos, braucht aber auch einen Arcor-Account): news.arcor.de
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)

Dieser Beitrag wurde am 30.07.2008 um 09:42 Uhr von volkerp editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
020
03.08.2008, 23:46 Uhr
susowa



Ich musste leider mein Posting 008 etwas anpassen.

Das WIZ811MJ ist zwar fast aber eben doch nicht ganz identisch mit dem WIZ810MJ - sorry !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
021
04.08.2008, 00:34 Uhr
Ralph



@susowa... ohwe.. da hab ich nun schon das WIZ811 bestellt und bezahlt.. na mal sehen ob die das noch tauschen..

Gruß Ralph
--
Es geht alles erst richtig los !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
022
04.08.2008, 00:37 Uhr
Enrico
Default Group and Edit


Das macht doch nichts. Hauptsache das ist funktionskompatibel, was es ja auch ist. Da Du es ja im AC1 einbaust, kannst Du es ja machen, wie Du willst.

Gerade habe ich mal im CPM-Forum nachgesehn. Da scheints wirklich (fast) niemanden zu interessieren.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
023
04.08.2008, 00:48 Uhr
Ralph



@Enrico.. und wie versteh ich dann das hier ..

Zitat:
Das auch erhältliche WIZ811MJ-Modul (2,54 mm Stiftleisten für den Anschluss) ist zwar mit dem gleichen Chip (W5100) ausgestattet aber die Pins sind erstens anders belegt als beim 810MJ und es fehlen drei wichtige Signale am Ausgang, so dass sich ein vorhandener LINK nicht sicher ermitteln lässt.


--
Es geht alles erst richtig los !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
024
04.08.2008, 08:25 Uhr
BobCat

Avatar von BobCat


Zitat:
Enrico schrieb
Gerade habe ich mal im CPM-Forum nachgesehn. Da scheints wirklich (fast) niemanden zu interessieren.

Ich hatte auch mal so alles abgeleuchtet (engl.Sprachraum). Also Interesse ist da schon vorhanden. Es wird auch der KC-Club im Zusammenhang des GIDE erwähnt. Was bedauert wird ist eben das es keine durchgehend engl. Dokumentationen gibt und wir als KC-Club so ziemlich isoliert da stehen.
Irgendwo habe ich auch gesehen das es jemand gibt der Ralfs Seiten bezüglich KCNET schon als übersetzten Link einbinden würde.
Inzwischen hat ja Ralf auch einen Dialog in "english" aufgenommem.

Aber ich hätte das Interess daran auch für gößer gehalten, kann ja noch "boomen". Denn es ist wohl mit die wichtigste Entwicklung für die alten 8Bit-Rechner und insbesondere für CP/M.

Dieser Beitrag wurde am 04.08.2008 um 08:26 Uhr von BobCat editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
025
04.08.2008, 08:26 Uhr
susowa




Zitat:
Ralph schrieb

Zitat:
Das auch erhältliche WIZ811MJ-Modul (2,54 mm Stiftleisten für den Anschluss) ist zwar mit dem gleichen Chip (W5100) ausgestattet aber die Pins sind erstens anders belegt als beim 810MJ und es fehlen drei wichtige Signale am Ausgang, so dass sich ein vorhandener LINK nicht sicher ermitteln lässt.


Leider bin ich auch nur ein Mensch und auch mir passiert mal ein Fehler, habe es eben nicht explizit kontrolliert, da ich annahm, dass WIZnet das Layout 1:1 kopiert hat, was sie aber nicht getan haben.

Funktionelle Probleme treten nicht auf, ausser dass man natürlich anders verdrahten muss.

Das Problem ist das /Link Signal vom PHY, wobei dort gleich 2 Sachen nicht passen.

Erstens ist es gar nicht mehr auf den Stiftleisten vorhanden, wie beim 810er.

Zweitens toggelt es beim W5100, wenn auf Tx oder Rx Datenverkehr ist, was an sich schon Blödsinn ist.
Man kann sich dann behelfen, indem man die LED-Signale der Tx und Rx LED mit den beiden Gattern von IC3 (siehe Schaltplan) mit dem /Link-Signal so verknüpft, dass das Toggeln wieder aufgehoben wird und ein stabiles /Link Signal am ATmega anliegt, was durch die Software dann auch vernünftig abgefragt werden kann.
Aber auch diese beiden LED-Signale (Tx und Rx LED) gibt es nicht mehr an der Stiftleiste, so dass es auch mit /Link nicht stabil wäre.

Da nur bei beiden Voraussetzungen eine zuverlässige Abfrage durch die SW möglich wäre, müsste man bei Nutzung des 811 das Pin 15 des ATmega auf GND legen und hätte damit natürlich immer einen /Link, auch wenn kein NW-Kabel angesteckt ist oder ein anderes physisches Problem (Unterbrechung u.s.w.) vorhanden ist.

Man kann sich natürlich die benötigten Signale direkt vom W5100 holen aber wer lötet schon gern an einem LQFP80 finepitch Gehäuse herum.

Die Schaltung mit den beiden Gattern ging übrigens aus einem Vorschlag von WIZnet selbst hervor - insofern kennen die das Problem, was die technische Ausführung und Umsetzung mit dem 811 umso fraglicher macht.

Also Ralph - meine Empfehlung lautet eindeutig umtauschen, auch wenn es etwas Arbeit macht.

Mfg Ralf

Dieser Beitrag wurde am 04.08.2008 um 19:56 Uhr von susowa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
026
04.08.2008, 09:25 Uhr
Ralph



@susowa... Na klar tausche ich um.. mach Dir mal keine Sorgen wegen der Problematik.. von mir bekommst Du ganz sicher keine Vorwürfe...
Ist halt mal anders rum.. diemal beisen eben nicht den Letzten die Hunde...

Gruß Ralph
--
Es geht alles erst richtig los !

Dieser Beitrag wurde am 04.08.2008 um 22:57 Uhr von Ralph editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
027
04.08.2008, 18:18 Uhr
Enrico
Default Group and Edit



Zitat:
Ralph schrieb
@Enrico.. und wie versteh ich dann das hier ..

Zitat:
Das auch erhältliche WIZ811MJ-Modul (2,54 mm Stiftleisten für den Anschluss) ist zwar mit dem gleichen Chip (W5100) ausgestattet aber die Pins sind erstens anders belegt als beim 810MJ und es fehlen drei wichtige Signale am Ausgang, so dass sich ein vorhandener LINK nicht sicher ermitteln lässt.


Stimmt, das habe ich ganz übersehen.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
028
11.08.2008, 21:27 Uhr
Ralph



@alle so.. jetzt hab ich die hoffentlich richtigen Module da.. nun brauch ich noch viel Zeit um das ganze hinzubasteln..
@susowa.. DACOMWEST hat die Module problemlos ausgetauscht...

Gruß Ralph
--
Es geht alles erst richtig los !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
029
11.08.2008, 22:59 Uhr
susowa




Zitat:
Ralph schrieb
@alle so.. jetzt hab ich die hoffentlich richtigen Module da.. nun brauch ich noch viel Zeit um das ganze hinzubasteln..
@susowa.. DACOMWEST hat die Module problemlos ausgetauscht...
Gruß Ralph

Frei nach dem Motto "Alles wird gut" - na dann streng' Dich mal an.

Seit gestern ist der KC85 unter CAOS auch "drin". Im Moment erst mal nur mit D004 aber ich habe noch mehr vor - lasst Euch mal überraschen ...
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
030
18.08.2008, 16:52 Uhr
Ralph



So Ihr lieben... wie man sieht, ist schnell zu sein, nicht immer gut.. :-(

Soeben habe ich den folgenden Wortlaut per Mail vom Lieferanten DACOMWEST bekommern und bin grade dabei mich zu ärgern..

Gruß Ralph


Zitat:
Sie haben vor einiger Zeit das Wiznet WIZ811MJ Modul von uns bezogen. Dieses Modul hat 2 Pinreihen je 20 Pins mit dem Rastermass 2,54mm. Leider waren diese nicht im Rastermass 2,54mm voneinander entfernt. Um dies zu korrigieren hat Wiznet jetzt das WIZ812MJ Modul angekündigt bei dem der Abstand zwischen J1 und J2 17,78mm beträgt, siehe angehängte Zeichnung. Pinout und Abmessungen des neuen WIZ812MJ Modules sind identisch mit denen des WIZ812MJ.

Die Dacom West wird nach Abverkauf der restlichen WIZ811MJ Module nur noch das WIZ812MJ vertreiben, da dieses Modul vielseitiger einsetzbar ist.

Wir bitten Sie deshalb, falls möglich, das Layout auf das neue WIZ812MJ Modul anzupassen.

Edit: Kommando zurück !!! Das bezieht sich ja auf das falsche Modul !! Wir nutzen ja das 810 er Modul !!
--
Es geht alles erst richtig los !

Dieser Beitrag wurde am 18.08.2008 um 16:54 Uhr von Ralph editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
031
18.08.2008, 20:25 Uhr
susowa




Zitat:
Ralph schrieb
Edit: Kommando zurück !!! Das bezieht sich ja auf das falsche Modul !! Wir nutzen ja das 810 er Modul !!

Genau - habe das aber jetzt mal zum Anlass genommen und eine Mail an DACOM West geschrieben, in der ich die merkwürdige technische Umsetzung des 811/812 zum 810 geschildert habe, vielleicht gibt es ja irgendwann dann mal ein 813er Modul, welches voll kompatibel zum 810 ist.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
032
30.08.2008, 22:55 Uhr
susowa



Lange vor mir hergeschoben aber nun online - die Projekt-Doku zum Interface, Nachnutzung und Inbetriebnahme.

Enrico ist derweil schon sehr fleissig gewesen, da wird es in wenigen Wochen dann langsam interessant.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
033
25.09.2008, 20:35 Uhr
susowa




Zitat:
susowa schrieb
... habe das aber jetzt mal zum Anlass genommen und eine Mail an DACOM West geschrieben, in der ich die merkwürdige technische Umsetzung des 811 zum 810 geschildert habe ...

Manchmal passieren die kleinen Wunder doch noch, scheinbar hat die Mail etwas bewirkt!

Habe mir heute das neue Netzwerkmodul WIZ812MJ (Nachfolger des WIZ811MJ) angeschaut und das passt nun doch wider Erwarten!

Damit steht jetzt auch ein geeignetes Aufsteckmodul mit 2,54 mm Stiftleisten zur Verfügung, welches auf handelsüblichen LR-Platinen verarbeitet werden kann.

Folgende Hinweise zum Schaltplan sind zu beachten:

- das /Link-Signal kann direkt (wie NM7010B+) an den Controller angeschlossen werden
- SPI_EN gibt es am WIZ812MJ nicht, das entfällt also
- RxLED bleibt frei
- TxLED bleibt frei
- alle anderen nicht genannten Signale des Modules bleiben frei

Die beiden Gatter an /RxLED bzw. /TxLED und der Jumper für die Modulumschaltung können natürlich dann auch entfallen. Alles andere bleibt wie bisher.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
034
26.09.2008, 19:51 Uhr
schnulli



Guten Abend,

möchte an dieser Stelle auf folgenden Diskussionsfaden hinweisen:

http://www.mikrocontroller.net/topic/109988

Damit sollte sich die Sache wesentlich vereinfachen lassen.

Dieser Beitrag wurde am 27.09.2008 um 22:57 Uhr von lenin editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
035
26.09.2008, 22:05 Uhr
susowa




Zitat:
möchte an dieser Stelle auf folgenden Diskussionsfaden hinweisen:

http://www.mikrocontroller.net/topic/109988

Damit sollte sich die Sache wesentlich vereinfachen lassen.

Das ist wie die Sache mit den "Äpfeln und Birnen" - wenn ich einen (beschränkten) Serial-Ethernet-Gateway gewollt hätte, wäre das schon vor 5 Jahren am KC gewesen, leider ist dieses NET-IO aber noch nicht mal das, da man ja eigentlich nur Zugriff auf die HW des Boards hat.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
036
15.11.2008, 14:13 Uhr
susowa




Zitat:
susowa schrieb
... da wird es in wenigen Wochen dann langsam interessant.

... und heute war es dann soweit.

Ein K8924 sendet den ersten PING mit CPMNET 1.5 durch das Ethernet und erhält nach ca. 1 ms Antwort.

Das heisst:

1. die erste KCNET-Nachnutzung mit/auf einem anderen Rechner war erfolgreich.

2. die eigentliche KC85 CP/M-Software läuft nach Änderung der OPTION.INC (PIO-Adresse eintragen, KC85 auf NO) und erneuter Assemblierung auch mit anderen CP/M 2.x kompatiblen Rechnern, was doch sehr positiv ist und mein gewähltes Konzept bestätigt, was mich natürlich auch sehr erfreut.

Bis demnächst - Happy Networking!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
037
15.11.2008, 18:55 Uhr
Ralph



@susowa... Hey da zitierst Du Dich mal selbst.. nicht schlecht ....

Na das sind doch gute Nachrichten.. Ich bin gespannt, wann ich Vollzug melden kann....und das auf dem AC1...

LG Ralph
--
Es geht alles erst richtig los !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
038
29.11.2008, 12:01 Uhr
susowa




Zitat:
K8924 im Netzwerk

So - es gibt dann ein paar Bilder mit etwas Text auf der Homepage zu sehen.

http://www.kc85.susowa.homeftp.net

Damit ist für mich dann auch 'MISSION Complete' und ich gebe den Staffelstab weiter an Enrico.

Ich kann erst weitermachen, wenn das KC-Modul zur Verfügung steht.

Schönes Wochenende !
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
039
29.11.2008, 13:55 Uhr
Enrico
Default Group and Edit


Bei dem hohen Druck ist es ja kein Wunder nicht, wenn ich nicht mehr wachse.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
040
29.11.2008, 16:06 Uhr
Volker

Avatar von Volker

Wart´s ab, das kommt schon noch - nur meist in die falsche Richtung
--
Das Gerät selbst ist ein kompli-
ziertes elektronisches Erzeugnis, zu des-
sen Reparatur neben vielfältigen Kenntnis-
sen zum gesamten Komplex der Elek-
tronik eine Vielzahl hochwertiger Meß-
und Prüftechnik notwendig ist. Von ei-
genhändigen Eingriffen wird abgeraten.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
041
29.11.2008, 16:29 Uhr
Blaupunkt



Die Frage, die sich jetzt stellt, wann kann ich den auf dem KC 85 im Internet googlen. ;-)

Wäre sowas denkbar, ok Bilder lassen wir jetzt mal außen vor, aber die Textinformationen?

Grüßle aus dem Schwobenländle.

Mirko
--
Sony TA-E 9000ES, Sony TA-P 9000ES, 2x Sony TA-N 9000ES, Sony SCD-XA 777ES, Sony DTC-ZA 5ES, Sony DVP-NS 999ES @ 2x Nubert Nuline 264, Nubert Nuline CS-174, 2x Nubert Nuline DS-22
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
042
29.11.2008, 23:37 Uhr
susowa




Zitat:
Blaupunkt schrieb
Die Frage, die sich jetzt stellt, wann kann ich den auf dem KC 85 im Internet googlen. ;-)

Wäre sowas denkbar, ok Bilder lassen wir jetzt mal außen vor, aber die Textinformationen?

Wenn Du einen Browser schreibst, welcher die betreffenden HTML-Tags kennt und die relevanten Informationen auf den Bildschirm schreibt, ist das technisch kein Problem.

Ich würde sogar mal kühn behaupten, dass man bei der Verarbeitung von Textinformationen keinen grossen Unterschied zum PC merken würde, da das Interface unter CAOS schnell genug ist.

Dort dürften eher die 40 Zeichen pro Zeile die Lesbarkeit in Frage stellen, von Frames und Javascript u.s.w. will ich mal gar nicht anfangen ... selbst die verschiedenen Fonts, Standardformatierungen und Farben würden wahrscheinlich schon einigen Aufwand auf dem KC erfordern, welcher erst mal erbracht werden muss.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
043
03.12.2008, 17:54 Uhr
ralle



mir hat schon kontiki auf den c64 gereicht, der ging nur mit 40 zeichen...

unter cpm, die ram-floppy a: als cache, das könnte was werden...
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
044
03.12.2008, 18:07 Uhr
Enrico
Default Group and Edit


"reicht", in Form von ist nix?
Was soll denn "kontiki" heissen?
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
045
03.12.2008, 18:22 Uhr
ralle



was weiß ich, des läuft eben auf dem c64 und benötigt eine retroreplay mit rj45-netzwerkadapter...

forum-64 sollte da weiterhelfen.

das das programm einen solchen namen hat, weiß nur der programierer...
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
046
03.12.2008, 19:19 Uhr
susowa




Zitat:
Enrico schrieb
"reicht", in Form von ist nix?
Was soll denn "kontiki" heissen?

http://www.sics.se/contiki

Ist durchaus interessant aber C liegt mir nicht so :-)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
047
12.01.2009, 18:20 Uhr
Enrico
Default Group and Edit


So langsam geht es nun dem Endspurt entgegen. Das KC-Treffen ist ja nicht mehr weit. Die Platinen sind fertig geroutet, in Produktion, und sollen die Tage fertig werden. Dann gehts ans Bestücken und Testen.

Da das M052 nicht nur das Netzwerk betrifft, mache ich dazu mal ein neues Thema unter Flohmarkt auf (sonstiges passt ja auch nicht unbedingt und Diskusion auch irgendwie nicht).
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek