Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » KC85/4 mit Macke » Themenansicht

Autor Thread - Seiten: -1-
000
19.02.2018, 20:37 Uhr
PC-Opa



Hallo Leute,
seit ein paar Tagen habe ich wieder mal mein KC85/2-5 -Zeuchs rausgekramt. Der Soundmodul mußte mal auf allen Geräten getestet werden. Dabei habe ich in einer dunklen Ecke einen KC85/4 entdeckt, den ich mal vor Jahren vor der Verschrottung gerettet habe. Der Vorbesitzer hat unbedingt ein Steckerkabel gebraucht und alle raushängenden Kabel einfach abgeschnitten. Nachdem ich dann ein neues Stromkabel angelötet habe, konnte ich feststellen, dass Bild und Ton einwandfrei waren. Tastatur usw - alles augenscheinlich O.K.
Bei meinem heutigen Test liefen auch Soundmodul und USB-Modul sowie das ROM/RAM-Modul M062 ohne Probleme. Aaaaber: eine Macke hat er: Basic-Programme mit VPOKExxx,xxx laufen nicht. Sobald die Basic-Zeile erreicht ist, friert das Bild ein und der Rechner bleibt stehen . Basic-Programme ohne VPOKE laufen durch.
Nun meine Frage:
1. Was kann die Ursache sein?
2. Kann mir einer den Rechner auf KC85/5 CAOS-Version 4.7 umbauen?? (gegen Aufwandsentschädigung natürlich), da ich mir das Auslöten der RAM- und ROM-Bausteine nicht zutraue.
Vielen Dank für Eure Hilfe.
Gruß Wolfgang

Dieser Beitrag wurde am 19.02.2018 um 20:51 Uhr von PC-Opa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
19.02.2018, 20:52 Uhr
Mobby5



Na "irgendwas" bei VPOKE einzugeben kann schon zum Absturz führen. Programme für den KC85/2 oder 3 müssen auch nicht unbedingt auf dem 4er funktionieren.
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden

Dieser Beitrag wurde am 19.02.2018 um 20:54 Uhr von Mobby5 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
19.02.2018, 21:05 Uhr
PC-Opa



@Mobby5: das sind normale Basic-Programme, die laufen auf meinen KC85/3-5 normal durch. Nur auf dem o.g. Rechner stürzen die ab.
Gruß Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
19.02.2018, 21:21 Uhr
Mobby5



Hab schon verstanden, dass das normale BASIC-Programme sind. Trotzdem kann man mit POKE-Befehlen einen Rechner zum Absturz bringen. Das nur nebenbei. Wenn diese Programme auf einem anderen KC85/4 durchlaufen, stimmt natürlich was mit diesem einen KC nicht.

Ist es "egal", wo Du mir dem VPOKE hinschreibst? VPOKE 0,0 bringt den Rechner auch zum Absturz?
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden

Dieser Beitrag wurde am 19.02.2018 um 21:21 Uhr von Mobby5 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
19.02.2018, 21:33 Uhr
PC-Opa



Jaanee is schon klar
Der Fehler liegt am Gerät, keine Frage. Da ich aber ein besserer "Programmierer" als "Reparierer" bin brauche ich Eure Hilfe. Am liebsten wäre es mir, wenn jemand das gute Stück zu einem KC85/5 umbauen kann.
Gruß Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
19.02.2018, 22:04 Uhr
Mobby5



Ich tendiere dazu, dass der BASIC-ROM was vergessen hat.
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
19.02.2018, 22:10 Uhr
PIC18F2550

Avatar von PIC18F2550

Eher der EPROM da stecken auch noch Basic teile drin ob das aber den VPOKE betrifft weiß ich nicht genau liegt aber nahe da hier die Anpassung an das System vorgenommen wird.
--
42 ist die Antwort auf die "Frage nach dem Leben, dem Universum und dem ganzen Rest"

Dieser Beitrag wurde am 19.02.2018 um 22:11 Uhr von PIC18F2550 editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
20.02.2018, 12:14 Uhr
Bert



Ich hatte auch schon einen KC, wo das BASIC-ROM kaputt war.

Viele Grüße,
Bert
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
20.02.2018, 12:25 Uhr
ralle



VPOKE hört sich nach irgendwas in den Bildspeicher schreiben an.
Denk drann, das der 85/4 einen anderen Aufbau hat. Besonders im Bereich des Videospeichers.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
20.02.2018, 18:15 Uhr
maleuma



VPOKE ist ein Befehl aus den BASIC-Erweiterungen und nicht vom BASIC-Kern. Wenn ein ROM vergesslich geworden ist, dann wäre der CAOS-ROM-E wahrscheinlicher.

Für eine Fehlersuche bzw. -eingrenzung wäre aber interessant bei welchem POKE-Befehl der KC konkret abstürzt.
Funktioniert denn das VPEEK auf diese Adresse?
--
Mario.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
20.02.2018, 19:51 Uhr
PC-Opa



@Mario:
das betrifft das Poken zum ändern des Zeichesatztes der Kleinbuchstaben zwecks schöner Grafik und Bilder. Das kann natürlich auch sein, das der Rechner die DATA-Zeilen nicht findet?
Maschinenprogramme laufen wunderbar und ohne Probleme (habe jedenfalls noch keines gefunden, was hängen geblieben ist).
Gruß Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
20.02.2018, 19:58 Uhr
Mobby5



Wie: "das der Rechner die DATA-Zeilen nicht findet"? Liegt es nun am VPOKE oder sind die DATA-Zeilen weg? Wenn keine DATA's zu finden sind, gibt es aber eigentlich eine BASIC-Fehlermeldung. Es sei denn, das BASIC kennt auch keine DATA's mehr. Naja, bleibt wohl doch bei den ROM's . Welcher auch immer.
--
und ausserdem muss in Zeile 20 der Doppelpunkt durch ein Semikolon ersetzt werden
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
20.02.2018, 20:12 Uhr
PC-Opa



@Mobby5:
ich habe auch die Vermutung, das mind. 1 ROM Alzheimer hat
Die Basic-Programme laufen auf meinen anderen Rechnern (KC85/3 bis 5) ohne Probleme durch. An den Programmen liegt es also nicht.
Jetzt habe ich auch noch gesehen, das mein KC-Recorder (Original nach Micha) noch Asbach-Uralt-Firmware drauf hat. Kann mir jemand einen mit neuster Firmware programmierten ATmega Chip gegen Aufwandsentschädigung zur Verfügung stellen?
Gruß Wolfgang

Dieser Beitrag wurde am 20.02.2018 um 20:21 Uhr von PC-Opa editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
20.02.2018, 21:21 Uhr
maleuma




Zitat:
PC-Opa schrieb
das betrifft das Poken zum ändern des Zeichensatztes der Kleinbuchstaben zwecks schöner Grafik und Bilder. Das kann natürlich auch sein, das der Rechner die DATA-Zeilen nicht findet?


Dann probier doch einfach einmal die betreffenden BASIC-Befehle im Direktmode, also per Tastatureingabe. Wie sieht es dann aus?
--
Mario.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
25.02.2018, 16:51 Uhr
schlaub_01



Hallo Wolfgang,

wenn Du möchtest, kann ich Dir den KC gerne umbauen.
Hast Du meine Adresse noch? Ansonsten alles per PN oder Email.

Grüße
Sven.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
28.02.2018, 21:00 Uhr
PC-Opa



Hallo,
ich möchte mich erst mal ganz herzlich für eure Hilfsbereitschaft bedanken. Viele gute Tips und Ratschläge sind per E-Mail oder PN bei mir angekommen.
Ein netter Forumskollege (das ist bereits so abgesprochen) wird mein Problemkind heilen und aufrüsten. Allen anderen noch mal ein Dankeschön für die angebotene Hilfe.
Gruß Wolfgang
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek