Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » KC85/1: IDAS ROMs und ZM » Themenansicht

Autor Thread - Seiten: -1-
000
28.05.2017, 15:08 Uhr
bstrobel



Hallo allerseits!

Als Hintergrund und zur Vorstellung: Hab als Jugendlicher in der DDR einen KC85/1 selbst zusammengelötet. Mein Vater arbeitete in dem Betrieb, der die Leiterplatten herstellte (KSG) und meine Mutter konnte damals zu einer Familienfeier in den Westen reisen und mir die nicht besorgbaren ICs mitbringen. Kurz danach Armee, Wende, Anfang der 90er Jahre flog der KC in den Müll...
***Zeitsprung***
30 Jahre später bereue ich mein voreiliges Wegwerfen immer noch. Heute arbeite ich in einer recht großen Softwarefirma und bin immer noch von der Einfachheit (im Sinne von Zugänglichkeit) der Computer meiner Jugend fasziniert. Außerdem ist wohl eine erkleckliche Menge Nostalgie im Spiel. Daher hab ich mir vor einiger Zeit einen Z9001.10 in hervorragendem Zustand besorgt.

Zu meinem Problem. Ich besitze nun auch ein ROM-Modul, einen Batronix EPROM-Brenner und einen billigen Asia-EPROM-Löscher, außerdem noch etwa 30 U2716C35, von denen ich nicht mehr weiß, woher ich sie habe.

Als erstes sollte es mit dem IDAS und dem ZM losgehen. EPROMs brennen, verifizieren - alles kein Problem. Der IDAS lässt ich problemlos starten.

Allerdings nicht der ZM. Wieso nicht? Ich habe sowohl die IDAS ROMs von Ulrich Zanders Seite als auch die von Volker Pohlers (hucki) ausprobiert, die ja nicht identisch sind. Beide verhalten sich gleich. IDAS funktioniert bei beiden (mit den entsprechenden Unterschieden). Wenn ich jedoch ZM (oder ZM30, ZM70, ZMA8) eingebe - im OS Monitor natürlich - dann sagt er: start tape.

Woran kann das liegen? Oder bin ich zu blind und sehe nicht, dass es anders gehen müsste?

Schonmal vielen Dank für alle Anregungen und eure Hilfe!

Dieser Beitrag wurde am 28.05.2017 um 15:11 Uhr von bstrobel editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
28.05.2017, 16:51 Uhr
bstrobel



Das Rätsel ist gelöst! Da der ZM in den höheren beiden EPROMs liegt, hab ich zuerst einmal die Verbindungen der EPROM-Pins mit den Signalleitungen überprüft. Alle IC-Fassungen waren aber ok und alles war korrekt verbunden. Beim Betrachten der Leiterzüge ist mir dann aufgefallen, dass der Leiterzug zwischen Pin 12 von D10 (DL030) zum Pin 11 von D1 (8205) durchgetrennt und Pin 12 von D10 mit dessen Pin 11 kurzgeschlossen wurde. Das war sehr professionell gemacht und auf den ersten Blick wirklich nicht zu sehen. Zurückgebaut und nun geht es.

Als ich das ROM-Modul erhielt, waren nur 4 EPROMs bestückt. Der fünfte und höchste Sockel war leer. Da wollte wohl jemand den freien Adressbereich für irgend etwas anderes benutzen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
29.05.2017, 07:52 Uhr
volkerp
Default Group and Edit
Avatar von volkerp

Die beiden IDAS-ROM-Versionen unterscheiden sich leicht in der Version und in der zusätzlichen Software. Im Modul von robotron (idas.rom) ist die EPROM-Software enthalten, in Ulrichs Variante idas_c0.851 eine spezieller Turbolader (QUICK/NORMAL/LOAD), der allerdings auch extra Hardware braucht.

s. http://hc-ddr.hucki.net/wiki/doku.php/z9001:software:idas#hinweise
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
29.05.2017, 09:07 Uhr
bstrobel




Zitat:
volkerp schrieb
...in Ulrichs Variante idas_c0.851 eine spezieller Turbolader (QUICK/NORMAL/LOAD), der allerdings auch extra Hardware braucht.



Vielen Dank für den Hinweis, Volker! Auch vielen Dank für deine hilfreiche Webseite mit den vielen, liebevoll zusammengetragenen Informationen.

Ich hätte noch eine weitere Frage, für die ich nicht extra ein neues Thema aufmachen will: Bei meinem Z9001 waren zwei BASIC-Module dabei und zwar eins aus der ersten Serie, ein "84er" (also Gehäuse direkt bedruckt, wohl recht selten) und noch ein "85er".

Zwei BASIC-Module sind natürlich nutzlos. So spiele ich nun mit dem Gedanken, aus dem 84er die EPROMs heraus- und Fassungen einzulöten, damit ich ein weiteres ROM-Modul zur Verfügung hätte.

Aber mir widerstrebt das Ganze. Das 84er soll selten sein. Was sagt ihr dazu? Ich würde es auch gern gegen ein weiteres ROM-Modul oder ein 16k-RAM-Modul tauschen, falls jemand Interesse hat.

Generell will ich den KC soweit wie möglich im Originalzustand belassen. Umbauten kommen für mich nicht in Frage. Zumal mein Z9001 wohl einem MKD-Mitarbeiter gehört hat. Er hat eine MKD Inventarnummer aus Aluminium aufgeklebt. Außerdem steht auf seiner Abdeckung "Z9001" und hinten auf dem Gehäuse "KC85/1.10". Die "jüngsten" DDR-ICs sind von U9 (KW9 1986). Er hat auch schon die K565RU6 RAMs, die die +12V/-5V nicht mehr benötigen. Es ist also eher ein KC85/1 als ein Z9001.

Dieser Beitrag wurde am 29.05.2017 um 09:08 Uhr von bstrobel editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
29.05.2017, 09:31 Uhr
volkerp
Default Group and Edit
Avatar von volkerp

Das 84er BASIC würde ich nicht verbasteln

Ein RAM-Modul kann ich zum Tausch anbieten, ROM-Module habe ich leider nicht.
Ich hätte jedoch noch eine Leiterplatte für ein Mega-Flash-Modul.
--
VolkerP

http://hc-ddr.hucki.net
(z9001, Z1013, LC-80, ...)

Dieser Beitrag wurde am 29.05.2017 um 09:32 Uhr von volkerp editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
30.05.2017, 11:49 Uhr
bstrobel




Zitat:
volkerp schrieb
Das 84er BASIC würde ich nicht verbasteln

Ein RAM-Modul kann ich zum Tausch anbieten, ROM-Module habe ich leider nicht.
Ich hätte jedoch noch eine Leiterplatte für ein Mega-Flash-Modul.



Vielen Dank für das Angebot. Ich überlege es mir nochmal. Das 84er-BASIC Modul werde ich auf jeden Fall nicht auseinanderreißen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek