Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Flohmarkt » NDR Klein Computer (NKC) » Themenansicht

Autor Thread - Seiten: [ Erste Seite ] ... [ 6 ] [ 7 ] [ 8 ] -9-
800
26.04.2017, 09:59 Uhr
Creep



Hallo Eddi,

ich glaube, die negativen Spannungen waren eher für alte Speicherchips und die V.24 Schnittstelle mit Originalbestückung. Heute kommt man wohl mit +5V und +12V größtenteils aus.

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
801
26.04.2017, 10:08 Uhr
Creep



Hallo,

ich denke, mit dem Layout der BUS3 sind wir jetzt so ziemlich fertig! Bild siehe ein paar Beiträge zuvor, das stelle ich nicht noch einmal rein.

Viele haben sie ja schon reserviert. Ich würde sie gern heute bestellen, damit es schnell mehr platz für die vielen neuen Karten gibt. Wer also noch eine möchte, bitte melden!

BUS3: 12 Steckplätze, ca. 160x219mm, 2mm dick (stabil) mit 1 oder 2 doppelreihigen Steckplätzen - z.B. für 68000 CPU-Platine

ca. 10€/Platine bei 50 Bestellungen

dl1ekm 3x
millenniumpilot 4x
schnaari 3x
Lot 1x
hschuetz 2x
Siggi 4x
Mobby5 2x
derInder 4x
SOC4 2x
tom16 3x
Edbru 3x
Eural 2x
UR1968 3x
cw 4x
peter_b 1x
ich 4x

--> 45 Platinen

Gruß, Rene

Dieser Beitrag wurde am 26.04.2017 um 12:18 Uhr von Creep editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
802
26.04.2017, 10:25 Uhr
Creep



PS: Wenn die BUS3 bestellt ist, werde ich noch eine neue Version der ROA64 vorstellen, die einfacher auf 256k umbaubar ist, sowie eine darauf basierende reine SRAM256 Karte. Bei beiden hat sich Deff im Optimieren des Layouts selbst übertroffen! Sie sehen einfach schön aus. Die bereits vorhandenen Reservierungen für eine Neuauflage der ROA64 gehen dann natürlich gleich auf die neue Version.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
803
26.04.2017, 11:52 Uhr
peter_b



Hallo Rene,
für mich bitte 1x BUS3
Gruß - Peter
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
804
26.04.2017, 11:55 Uhr
Creep



OK, ist eingetragen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
805
26.04.2017, 12:17 Uhr
schnaari



Moin Rene,

ich erhöhe mal bei der BUS3 bitte auf 3 Stück.

MfG - Frank
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
806
26.04.2017, 12:29 Uhr
edbru




Zitat:
Creep schrieb
Hallo Eddi,

ich glaube, die negativen Spannungen waren eher für alte Speicherchips und die V.24 Schnittstelle mit Originalbestückung. Heute kommt man wohl mit +5V und +12V größtenteils aus.

Gruß, Rene



Die 12N braucht man für die SER (die originale), fällt ja bei der Neuen weg. Aber die haben ja sicher noch einige, ich z.B.
Und entdeckt: die AD10X1 (AD-Wandler 1 Kanal 10 Bit) braucht auch 5N.
Hat die überhaupt jemand?
Aber stimmt schon, da sie vorgesehen sind sollten sie auch bleiben.

Ist ja auch genug Platz für Wandler

Gruß
Eddi
--
ich brauch es nicht, so sprach der Rabe.
Es ist nur schön wenn ich es habe.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
807
26.04.2017, 13:39 Uhr
Creep



Hier übrigens nochmal der Link zu den produzierten Platinen bei DirtyPCB, falls sie irgendwann jemand einfach selbst nachbestellen möchte. Die kompletten Layouts kommen dann natürlich wieder zu Hans-Werner.

http://dirtypcbs.com/store/designer/browse/10727

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
808
26.04.2017, 17:58 Uhr
DerInder



Moin Eddi,

die einzige NKC Karte die ich kenne die die -5V braucht ist die AD 10x1 mit ZN432 AD-Wandler. Die -12V waren wohl vorallendingen für die SER Karte.

Kann man ja je nach Bedarf anschließen

Und ja, ich habe eine AD 10x1, allerdings scheint der ZN432 zerbaten zu sein
--
Gruß
-=jens=-

Dieser Beitrag wurde am 26.04.2017 um 18:08 Uhr von DerInder editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
809
26.04.2017, 18:08 Uhr
dl1ekm



Was spricht eigentlich gegen eine RAM256 mit DRAMs? Die nutzt mein NKC für CP/M.

Zur IOE: Dank 688 und RN geht schon mal der Eingang (IN0, IN1). Einzelne Bit-Änderungen (Kabel auf GND) werden angezeigt.
Der Ausgang macht noch nichts... da ändert sich mit dem Testprogramm nichts an den Pegeln, obwohl ich e0/e1 auf GND gelegt habe. Komisch.

Dieser Beitrag wurde am 26.04.2017 um 18:08 Uhr von dl1ekm editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
810
26.04.2017, 18:12 Uhr
DerInder



Moin Marcel,

ich hab die IOE auch zur hälfte getestet
Bei mir laufen die Ausgänge perfekt, alle Bits sind an der richtigen Stelle.

Eingänge kommen als nächstes drann.
--
Gruß
-=jens=-

Dieser Beitrag wurde am 26.04.2017 um 18:12 Uhr von DerInder editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
811
26.04.2017, 18:18 Uhr
Creep



Ich bau sie heute abend zusammen. Bei mir läuft dann hoffentlich alles. Kann ich dann gleich mit Vdip1 als Aufsteckmodul ausprobieren.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
812
26.04.2017, 18:32 Uhr
DerInder



So, nun hab ich die IOE komplett getestet, sie läuft einwandfrei.
Alle Pins habe die gleiche Position wie beim Orginal.
--
Gruß
-=jens=-

Dieser Beitrag wurde am 26.04.2017 um 18:32 Uhr von DerInder editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
813
26.04.2017, 19:04 Uhr
dl1ekm



Ok, was mache ich falsch? Die DIPs stehen für 30H wie folgt:





A4/A5 offen (5V), alle anderen geschlossen (GND).
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
814
26.04.2017, 19:18 Uhr
DerInder



Hmm, wenn du bei dieser Einstellung auf die Eingänge zugreifen konntest, muss es korrekt sein
Wie hast due die e0/e1 Anschlüsse beschaltet? Normalerweise würde ich dort Jumper hinsetzten, aber horizontal (ok in deinem Bild vertikal)
Sprich auf dein Bild bezogen müssten jeweils der linke violette und der linke gelbe Kabel zusammengeschaltet werden. Gleiches auch für die rechten Kabel.
Oder ist das jeweils nur ein Kabel?
Dann wäre es auch OK.
--
Gruß
-=jens=-

Dieser Beitrag wurde am 26.04.2017 um 19:26 Uhr von DerInder editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
815
26.04.2017, 19:36 Uhr
DerInder



Hmm,
bei deiner Anschlußbelegung sollte die Zuordnung (abgesehen von e0/e1) von unten folgende sein:

schwartz - Out0-5
weiß - Out0-1
grau - Out0-2
violett - Out0-6

blau - Out1-5
grün - Out1-1
gelb - Out1-2
orange - Out1-6

Die Positionen der beiden Leitungen am In-Port kann ich leider nicht genau erkennen.
--
Gruß
-=jens=-

Dieser Beitrag wurde am 26.04.2017 um 19:37 Uhr von DerInder editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
816
26.04.2017, 20:39 Uhr
dl1ekm



Alles klar, es geht. Habe die Kreuzknobelbecher-Verkabelung für e1/e0 durch Jumper ersetzt. Ich prüfe noch mal die Pin-Zuordnung.

Ansonsten bitte ich noch um Verbesserungsvorschläge, bevor das Layout zu Werner/Rene geht.

Bisher:
- Pin1-Markierung der Bus-Leiste ist noch auf der falschen Seite
- Die Markierung der ICs ist bei KiCad im Standard etwas gewöhnungsbedürftig. Pin 1 ist mit einer kleinen Ecke gekennzeichnet, es gibt keine "Lasche" im Bestückungsaufdruck. Aber dafür die Library anpassen - hab ich ehrlich gesagt keine große Lust zu :-)
- Wie hättet ihr gerne die DIP-Beschaltung? Derzeit ist DIP1=A1...DIP7=A7 und DIP8 ist frei. Oder lieber DIP1=A0 (frei) , DIP2=A1 ... DIP=A7 (fänd ich aber verwirrender).
- Passt das Lochraster-Feld, Bohrlöcher?
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
817
26.04.2017, 20:50 Uhr
UR1968
Default Group and Edit


Hallo,

die FLO3 Prototypen sind nun auch bei mir eingetroffen. Am Freitag gehen die dann auf die Reise.

Tschüß
Uwe
--
http://ddr-computerwelt.ch/
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
818
26.04.2017, 20:52 Uhr
Creep



Hallo Marcel,

die DIP-Zuordnung finde ich so schon OK. Schön auch, daß man stattdessen immer noch Pinheader und Jumper verwenden kann.

Ich fange jetzt mal an, das Teil zusammenzulöten. Vielleicht fällt mir dabei noch etwas auf. Schön, daß es auf jeden Fall funktioniert. Glückwunsch!

Beim Lochraster könnte man vielleicht noch etwas größere Pads nehmen, kostet ja nichts, lötet sich aber besser und bringt mehr Stabilität. Was hast Du für Bohrungen genommen? 0.8mm? Meine Steckverbinder passen. Aber ein Zehntel mehr könnte evtl. bei anderen Anwendungen helfen.

Ansonsten sieht das eigentlich SEHR gut aus.

Ach ja, eine Idee hab ich noch: Was haltet ihr davon, die oberste Lochrasterreihe am Rand um ein halbes Raster zu versetzen? Dann könnte man einfach SUB-D Buchsen einlöten.

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
819
26.04.2017, 20:57 Uhr
Creep



Ach ja: Wie auch Jens mich immer wieder drauf stößt: Größere Pads am BUS-Verbinder. Auf den wirken die größten Kräfte und das auch häufiger.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
820
26.04.2017, 21:11 Uhr
Creep



Noch etwas: Wenn es machbar ist, bitte die Werte für Kondensatoren und RN in den Bestückungsdruck nehmen. Der ist später irgendwann meist die einzige Dokumentation!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
821
26.04.2017, 21:42 Uhr
DerInder



Moin,

nochmal zum DIP-Key (wie ich Marcel schon geschrieben hab):

Bei der jetzigen Anordnung sieht ein 30h folgendermasen aus:

_ _ _ - - _ _ _
x 0 0 1 1 0 0 0

Das linke Bit ist nicht angeschlossen. Ich würde aus der Einstellung aber 18h lesen und nicht 30h

Daher die Idee, die Anschlüsse um ein nach links zu verschieben, dann würde es folgendermaßen aussehen:

_ _ - - _ _ _ _
0 0 1 1 0 0 0 x

Hier ist dann das rechte Bit nicht angeschlossen. Ich würde die Einstellung aber direkt als 30h lesen.

Ach ja und ein kleines + am Elko wäre auch noch ganz nett.

Ansonsten siehe Vorschläge von Rene
--
Gruß
-=jens=-
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
822
26.04.2017, 21:45 Uhr
dl1ekm



ok. ich schreibe mal mit...

mit den Bohrungen und Pads - da habe ich in die KiCad Library gegriffen. Wenn ich das anders haben will muss ich entweder mal googlen, ob es was gibt, oder die footprints selber anpassen. Auf jedem Fall für mich als Anfänger nicht einfach. Aber schauen wir mal.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
823
26.04.2017, 21:54 Uhr
Creep



Noch ein Vorschlag: Wie wäre es, den Footprint für die I/O-Leitungen, also, wo man z.B. einen Pinheader für eine Sub-Platine anbringen könnte, um ein Pin-Paar zu erweitern: +5V?

Der könnte auch im ein "leeres" Pin-Paar rechts von den ursprünglichen Pins getrennt sein, damit es keine Verwechslungen gibt.

Ich bin gerade dabei, meine VDIP1 USB-Subplatine zu löten und stelle fest, daß ich keine 5V habe und damit direkt an den BUS gehen muß

Ich habe dafür eine schmale Lochrasterplatine zum Aufstecken genommen, komme also auch nicht an die VCC-Anschlüsse am rechten Rand heran. Klar, kann ich etwas auf die IOR löten. Mache ich jetzt auch. Aber ginge halt auch leichter.

Das könnte viele Anwendungen der IOR enh erleichtern!

Dieser Beitrag wurde am 26.04.2017 um 21:56 Uhr von Creep editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
824
26.04.2017, 22:30 Uhr
dl1ekm



Kann man machen, dann muss man aber aufpassen, wenn man andere Dinge aufsteckt, denn dann ist die Leiste nicht mehr kompatibel. Es gibt z.B eine Centronics Aufsteckplatine (wer immer domeas noch braucht) und euch eine Roboter Ergänzung.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
825
26.04.2017, 23:02 Uhr
Creep



Hallo Marcel,

deswegen meine ich, vielleicht mit einer Pinreihe Abstand und evtl. einem eingelötetem Stopper. Dann kann man verhindern, daß "alte" Platinen falsch aufgesteckt werden und nur "neue" passen. So denke ich mir das jetzt jedenfalls. Aber notfalls kann man das auch selbst ergänzen auf dem Lochraster mit einem zweiten Pinheader.

Meine IOE scheint zu funktionieren, jedenfalls nach dem flüchtigen Messen. Mein USB-Aufsatz noch nicht. Aber das muß dann an der Verdrahtung der Sub-Platine liegen. Heute nicht mehr...

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
826
Heute, 09:41 Uhr
Creep




Zitat:
Creep schrieb
Meine IOE scheint zu funktionieren, jedenfalls nach dem flüchtigen Messen. Mein USB-Aufsatz noch nicht. Aber das muß dann an der Verdrahtung der Sub-Platine liegen. Heute nicht mehr...


OK, für Eingangsports mit freien Pins sollte man wohl auch keinen HCT stecken. Daran könnte es gelegen haben. Probiere ich abends nochmal.

Gruß, Rene


PS: Die SOUND3 ist schon in Zustellung. Da heute keiner zuhause ist, werde ich sie dann morgen haben. Nächste Woche kann ich dann alles verschicken. BUS3 bestelle ich heute!
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
827
Heute, 10:46 Uhr
Creep



BUS3 habe ich jetzt 60 Stück bestellt. Das heißt, es sind noch gut 10 Stück in Reserve.

Gruß, Rene
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: [ Erste Seite ] ... [ 6 ] [ 7 ] [ 8 ] -9-     [ Flohmarkt ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek