Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » PC1715W DIP-Schalter auf Hauptplatine » Themenansicht

Autor Thread - Seiten: [ 1 ] -2-
100
17.02.2019, 16:11 Uhr
wpwsaw

Avatar von wpwsaw

@Heiko,

zu 091 da hast du die Karte ja direkt auf dem Board. Teste es lieber so, wie es später möglich ist mit Kabel und an seitlicher Buchse

Hoffentlich werden meine Z84 nicht mit einem Esel transportiert ich möchte ja dann meinen 1715W damit testen.

in der Übergangszeit repariere ich dann die Bremsen von meinem Gabelstabler und fange eine neue Uhr an zu bauen.








gruß
wpw

P.S. ich bin begeistert, dass nun doch so viele hier ihr Bestes geben um gemeinsam eine Lösung zu finden!
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2

Dieser Beitrag wurde am 17.02.2019 um 16:14 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
101
17.02.2019, 16:23 Uhr
Heiko_P



@wpw: Das ist Absicht, ich möchte erst einmal so viele Fehlerquellen wie möglich ausschließen. Das ca. 10 cm lange Kabel scheint eine davon zu sein
Keine Bange, der Rechner soll am Ende kein neues Gehäuse bekommen
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
102
17.02.2019, 18:55 Uhr
Heiko_P



Ein kurzer Zwischenstand:

Zum Testen übertrage ich jetzt eine 6 MB große Datei. Als Server nutze ich einen Windows-PC oder meinen AC1 mit dem TFTP-Server. Das Verhalten ist bei beiden Servern gleich.

- Die Terminierung der Taktleitung (300 Ohm gegen +5V am Ende des Leiterzuges) hat leider keine sichtbare Verbesserung gebracht. Manchmal wird die Datei komplett übertragen, manchmal bleibt die Übertragung mittendrin stehen.

- Eine Ferritperle auf der Taktleitung im Verbindungskabel bringt zumindest eine kleine Verbesserung. Die Abbrüche sind seltener und wenn kommen sie später (meistens zwischen 2,5 und 4 MB).

- Wenn das Kabel auf der senkrechten Buchse steckt (wo der Floppycontroller sitzt) läuft die Übertragung etwas stabiler (weniger Abbrüche) als am seitlichen Steckverbinder.

Das klingt alles ziemlich seltsam, ich bin auch noch lange nicht am Schluss mit der Fehlersuche. Die Tests dauern immer länger, je später der Fehler auftritt

Gruß
Heiko
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
103
18.02.2019, 15:42 Uhr
wpwsaw

Avatar von wpwsaw

Hallo,

ich habe heute schon meine Z84C20 10MHz bekommen und gleich mal zwei Tests gemacht.

1. K8924: schaft von PC in Richtung GUN um die 2 MB Datentransfer und vom Gefühl her deutlich schneller als mit UA855

2. PC1715W: jetzt funktioniert das Netzwerk erst einmal in beide Richtungen.

leider zeigen sich ein paar komische Eigenheiten am Bildschirm, als wenn der BWS hin und her ruckelt. Das passiert beim Datentransfer zwischen GUN und Floppy. hatte ich voerher nicht. Werde noch einmal das Verbindungskabel tauschen und weiter Probieren.

Das jetzt das Netzwerk im 1715W funktioniert nur durch Tausch der PIO ist komisch.

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2

Dieser Beitrag wurde am 18.02.2019 um 15:43 Uhr von wpwsaw editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
104
18.02.2019, 16:32 Uhr
Alwin

Avatar von Alwin

Meine Z84 kommen spätestens Mittwoch, dann teste ich an meinem 1715W, gucke mal ob auch was flackert.
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
105
18.02.2019, 16:38 Uhr
wpwsaw

Avatar von wpwsaw

Das flackern hat sich jetzt gegeben. nur hin und wieder mal. Habe auch mehrfach RESET, funktioniert ohne Probleme. Der Transfer zum 1715w geht natürlich nur bis die Diskette voll ist.

Gruß
wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
106
18.02.2019, 16:55 Uhr
Alwin

Avatar von Alwin

Und Ping geht immer?
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
107
18.02.2019, 16:58 Uhr
Klaus




Zitat:
wpwsaw schrieb

1. K8924: schaft von PC in Richtung GUN um die 2 MB Datentransfer und vom Gefühl her deutlich schneller als mit UA855



Hallo wpw,

2MB. Hattest Du danach "Hänger" oder war die Datei "nur" 2MB?

Ich hatte bei meinem parallel laufenden Langzeittest (K1520 mit Z84C20 und NANOS mit UB855) gestern keinerlei Probleme. Die 7MB große Testdatei ist ohne Murren mindestens 8x hin-und her gewandert.
Der ganze Spaß hat natürlich einige Stunden gedauert, aber alles lief perfekt.

Viele Grüße,
Klaus

Dieser Beitrag wurde am 18.02.2019 um 17:00 Uhr von Klaus editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
108
18.02.2019, 20:01 Uhr
Enrico
Default Group and Edit



Zitat:
wpwsaw schrieb
Hallo,

ich habe heute schon meine Z84C20 10MHz bekommen und gleich mal zwei Tests gemacht.

1. K8924: schaft von PC in Richtung GUN um die 2 MB Datentransfer und vom Gefühl her deutlich schneller als mit UA855

...


Kann gar nicht sein, dass es wegen der anderen PIO schneller geht.
Das ist nur vom Takt abhängig. Kann also nur sein, dass es Übertragungsfehler, gibt
die ausgebügelt werden, wodurch die Geschwindigkeit runter geht.

Mach doch mal die Tests mit TCP-Übertragung.
Z.B. mit diesem Pumpkin, wie das auf SUSOWAs HP nachzulesen ist.

Ansonsten solltest Du das auch noch mal mit einer direkten Verbundung mit
einem gekreuzten NW-Kabel versuchen.
Glaub aber nicht, dass es das sein kann, da alle anderen Rechner doch
bei dir gehen.

Richtige Übertragungsfehler hatte ich nur mit dem Prototyp der K1520-Karte, wiel
die Fädeldraht aufgebaut war. Das Problem war das knappe Timing des AVR-
Controllers.
Da halfen 33 Ohm Widerstände in den Leitungen.
--
MFG
Enrico

Dieser Beitrag wurde am 18.02.2019 um 20:05 Uhr von Enrico editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
109
18.02.2019, 20:51 Uhr
wpwsaw

Avatar von wpwsaw

@Alwin habe ich noch nicht getestet, mache ich morgen früh alserstes

@Klaus abgebrochen bei 2,... MB K8924 hängen geblieben

@Enrico

gefühlsmäßig flüssiger beim K8924,ich weiß nicht, ob TFTP14 oder PUMPKIN wiederholungen macht, wenn es Übertragungsfehler gab.

beim PC1715W deutlich langsamer, so abgehackt immer. Ich werde morgen mal Zeitmessungen machen.

ich teste immer mit PUMPKIN
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
110
19.02.2019, 12:53 Uhr
kaiOr

Avatar von kaiOr

Zappelnder Bildschirm klingt fast nach BUS-Krieg.

@Heiko:
Noch zwei sinnlose Tests für Dich:
1. Verbinde bitte am Steckverbinder /RFSH direkt mit /IODI
2. Verbinde bitte vom GUN IO88h (IC1 Pin 13) mit /IODI
Sollte etwas davon greifen baue ein invertiertes /IORQ und verbinde es mit /IODI

MfG
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
111
19.02.2019, 13:48 Uhr
wpwsaw

Avatar von wpwsaw

Hallo,

bei meinem K8924 zappelt er auch. PINGs laufen ohne Probleme von und in allen Richtungen.

Hier mal ein paar Zeiten mit Diskettengröße 757kB

PC zum 8924 DOM 01:39,71
PC zum 1715W Disk 07:46,42
PC zum 8924 Disk 05:33,67
8924 Disk zum PC 04:36,46
8924 Disk zum 1715W Disk 11:16,01
1715W Disk zum 8924 Disk 08:22,01
1715W Disk zum PC 03:05,18

wpw
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
112
19.02.2019, 16:26 Uhr
Alwin

Avatar von Alwin

Meine Z84 sind heut gekommen und eingebaut. Am 1715W funktioniert Ping ohne Probs. Wenns mal eng am Server wird, kommt ein Timeout und nicht wie vorher, das der ganze Rechner hängt.
Am 1715 teste ich später.
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
113
19.02.2019, 16:30 Uhr
wpwsaw

Avatar von wpwsaw

Es funktioniert, aber warum?.....
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
114
19.02.2019, 17:39 Uhr
Alwin

Avatar von Alwin

am 1715 bleibt er trotz Z84 noch hängen, mache noch die Widerstände in die Datenleitungen.
--
...Z1013, KC87, KC85/5, KC Compact, C64, PC1715+W, AC1-2010, LC-80ex
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
115
19.02.2019, 18:44 Uhr
Klaus



Hallo wpw,

ich habe bei meinen Tests am Wochenende für die Übertragung am PC das Programm TFTPD64 genutzt.

Das hat mir während der Übertragung der 7MB großen Datei ca. folgende Werte angezeigt. Gelesen und geschrieben von/auf DOM.

K1520 Gerippe: Vom PC zum DOM ca. 8600 Byte/sec
K1520 Gerippe: Vom DOM zum PC ca. 8200 Byte/sec
NANOS: Vom PC zum DOM ca. 9100 Byte/sec
NANOS: Vom DOM zum PC ca. 8700 Byte/sec

Die Werte sind Durchschnitt. Anfangs ein wenig mehr und zum Ende der 7MB hin ein wenig langsamer... das GIDE-LW (8MB) war dann aber auch schon fast voll.

Dies nur mal zur Info. NANOS ist schneller, weil da keine Interrupts im Hintergrund laufen.
Die Zeiten habe ich nicht gestoppt. Dazu müssten wir eine Standard Datei mit z.B. genauer Größe haben um direkt zu vergleichen.
Floppy habe ich nicht getestet. Das dauert natürlich viel viel länger.

Viele Grüße,
Klaus

Dieser Beitrag wurde am 19.02.2019 um 18:45 Uhr von Klaus editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
116
19.02.2019, 19:06 Uhr
wpwsaw

Avatar von wpwsaw

Hallo Klaus, was ist TFTPD64? noch nie von gehört
--
RECORD, CRN1; CRN2; PicoDat; LC80; Poly880; KC85/2,3,4,5 ; KC87; Z1013; BIC; PC1715; K8915; K8924; A7100; A7150; EC1834; ab jetzt ohne Tatra813-8x8 aber mit W50LA/Z/A; P3; ES175/2
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
117
19.02.2019, 20:04 Uhr
Klaus



Hallo wpw,

frag mal die Suchmaschine ;-)
Ist von einem Herrn Jounin.

Keine Ahnung wie ich vor Jahren mal darauf gekommen bin. Ist aber vermutlich sowas ähnliches wie dieses Pumpkin.

Viele Grüße,
Klaus
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: [ 1 ] -2-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek